"Dummy Device" only option for sound playback issue on fresh install

Hello there. I have just installed manjaro 21.2.5 gnome onto my new geobook 240 laptop, and the only issue is that no sound will play. When I went under the sound settings the only option for output is “Dummy Output” with nothing else to select. I have tried searching the forums and did not find anything specific to my situation, but I saw that the following info was often requested from those trying to assist the new users.

inxi -Fazy                                               
System:
  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=71a6f518-5244-46ca-aca1-50266bddfaec rw quiet
    cryptdevice=UUID=6db9ddf3-8278-4025-a8fa-6512930e386b:luks-6db9ddf3-8278-4025-a8fa-6512930e386b
    root=/dev/mapper/luks-6db9ddf3-8278-4025-a8fa-6512930e386b splash
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: GNOME v: 41.4 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 41.3
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: GEO product: GeoBook 240 v: N/A
    serial: <superuser required>
  Mobo: GEO model: EM_IG218_200B_ENE_TI_V2.0 serial: <superuser required>
    UEFI: American Megatrends v: LC--038-IG218-I date: 04/10/2021
Battery:
  ID-1: BAT0 charge: 38.0 Wh (100.0%) condition: 38.0/38.0 Wh (100.0%)
    volts: 7.6 min: N/A model: Emdoor Li-ion Battery type: Li-ion
    serial: <filter> status: charging
CPU:
  Info: model: Intel Pentium Silver N5030 bits: 64 type: MCP
    arch: Goldmont Plus family: 6 model-id: 0x7A (122) stepping: 8
    microcode: 0x1C
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
    desc: d-4x24 KiB; i-4x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2679 high: 2783 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2783 2: 2534 3: 2782
    4: 2617 bogomips: 8756
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel GeminiLake [UHD Graphics 605] vendor: nCipher Security
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:3184 class-ID: 0300
  Device-2: SunplusIT USB camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-6:4 chip-ID: 2b16:6689 class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.0
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Najing CEC Panda 0x002b built: 2018 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    driver: sof-audio-pci-intel-apl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0401
  Device-2: SunplusIT USB camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-6:4 chip-ID: 2b16:6689 class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:c821 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 119.24 GiB used: 9.5 GiB (8.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Netac model: SSD 128GB
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0A0 scheme: GPT
Partition:
  ID-1: / raw-size: 118.94 GiB size: 116.52 GiB (97.96%) used: 9.5 GiB (8.2%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-6db9ddf3-8278-4025-a8fa-6512930e386b
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 440 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 66.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 225 Uptime: 9m wakeups: 2 Memory: 7.59 GiB used: 2.19 GiB (28.8%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
  Packages: pacman: 1138 lib: 300 flatpak: 0 Shell: Zsh v: 5.8.1
  running-in: gnome-terminal inxi: 3.3.14

pacmd dump                                                                               
### Configuration dump generated at Thu Mar 31 13:25:31 2022

load-module module-device-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="usb-SunplusIT_Inc_USB_camera_J20210323V000-02" card_name="alsa_card.usb-SunplusIT_Inc_USB_camera_J20210323V000-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-null-sink sink_name=auto_null sink_properties='device.description="Dummy Output"'
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:1 xauthority=/run/user/1000/.mutter-Xwaylandauth.X2NTJ1
load-module module-x11-cork-request display=:1 xauthority=/run/user/1000/.mutter-Xwaylandauth.X2NTJ1
load-module module-x11-xsmp display=:1 xauthority=/run/user/1000/.mutter-Xwaylandauth.X2NTJ1 session_manager=local/home-geobook240:@/tmp/.ICE-unix/921,unix/home-geobook240:/tmp/.ICE-unix/921
load-module module-cli-protocol-unix
load-module module-stream-restore

set-sink-volume auto_null 0x10000
set-sink-mute auto_null no
suspend-sink auto_null no

set-source-volume alsa_input.usb-SunplusIT_Inc_USB_camera_J20210323V000-02.analog-stereo 0xd34e
set-source-mute alsa_input.usb-SunplusIT_Inc_USB_camera_J20210323V000-02.analog-stereo no
suspend-source alsa_input.usb-SunplusIT_Inc_USB_camera_J20210323V000-02.analog-stereo no
set-source-volume auto_null.monitor 0x10000
set-source-mute auto_null.monitor no
suspend-source auto_null.monitor no

set-card-profile alsa_card.usb-SunplusIT_Inc_USB_camera_J20210323V000-02 input:analog-stereo

set-default-sink auto_null
set-default-source alsa_input.usb-SunplusIT_Inc_USB_camera_J20210323V000-02.analog-stereo

### EOF

amixer --card=0                                                                         
Simple mixer control 'Mic',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 4096
  Mono: Capture 2816 [69%] [11.00dB] [on]

http://alsa-project.org/db/?f=2519c92c91bcf88a38cf253137401c8384ea0de5

I had a similar problem on my desktop setup, although probably unrelated to yours: – card was detected but no output device other than the “Dummy” was shown on PulseAudio Volume Control. After a while I figured out my problem: I simply did not have a speaker plugged in to the card. lol.

There are a lot of possible solutions if you search for Dummy Device/Output.
The most successful one was installing sof-firmware. sof-firmware

sof-firmware was already installed and up to date.

I have tried (with rebooting in between each step):

All with no luck and the same symptoms persisting.