No password prompt asked, hence tasks like installing kernels, editing user profiles fail

hello there.
im not sure what ive done wrong but basically i dont get prompted to put in my password for things that need them. For example: auto installing drivers and installing new kernels through settings> manjaro> hardware or kernel options. I even faced this issue when i needed to change my users profile picture. That gui password prompt is missing and idk what ive done to disable it or stop it from appearing…

Increase your chances of solving your issue:

Provide Information:

  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=10286a18-2380-49ed-b8fb-70b33da62b3b rw quiet
    resume=UUID=08aad876-2ad0-4b8d-ac5e-49fc0465d0a8 udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 3254N2Q v: ThinkPad Edge E430
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 3254N2Q serial: <superuser required>
    UEFI-[Legacy]: LENOVO v: H0ET95WW (2.55 ) date: 01/20/2014
  ID-1: BAT0 charge: 2.4 Wh (100.0%) condition: 2.4/52.8 Wh (4.6%) volts: 11.4
    min: 11.1 model: LGC 45N1055 type: Li-ion serial: <filter> status: N/A
  RAM: total: 7.35 GiB used: 2.99 GiB (40.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge
    family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1305 high: 1315 min/max: 1200/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1310 2: 1303 3: 1315
    4: 1295 bogomips: 19962
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept
    erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida
    lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdtscp rep_good sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic
    xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Acer ThinkPad Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-1.6:3 chip-ID: 5986:02d2 class-ID: 0e02
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
  Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel
    bus-ID: 03:00.0 chip-ID: 8086:0888 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 0c:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp12s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.3:3 chip-ID: 8087:07da class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 104.63 GiB (22.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM030-2E717D
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GT50N rev: LC02
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 456.96 GiB size: 448.72 GiB (98.20%)
    used: 104.63 GiB (23.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 10286a18-2380-49ed-b8fb-70b33da62b3b
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: 08aad876-2ad0-4b8d-ac5e-49fc0465d0a8
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.3:3 info: Intel Centrino Bluetooth Wireless Transceiver
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    chip-ID: 8087:07da class-ID: e001
  Device-2: 1-1.4:7
    info: Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.0 speed: 12 Mb/s
    power: 100mA chip-ID: 147e:1002 class-ID: 0000
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.6:3 info: Acer ThinkPad Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 5986:02d2 class-ID: 0e02
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-4:2 info: Logitech Wireless Receiver type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 50mA
    chip-ID: 046d:c542 class-ID: 0301
  Hub-6: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 58.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 209 Uptime: 9h 46m wakeups: 1 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1219 lib: 350
  Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

its just that the system doesnt ask for my password when applications require root access to install things. For example i am unable to install anything with pamac. i get the error: “authentication failed”. its obvious that it failed since i was never given a chance to type in my password…

We can’t know either :wink:

Have you done something but don’t remember what it was?
“accidentally” uninstalled something along with something else?

Terminal commands instead of GUI …:

tac /var/log/pacman.log | grep removed | less
gives a list of removed packages with the most recent shown first

passwd -S
a “P” should be there after the user name

sudo passwd -S
a “P” should be there after the user name root
… but if sudo works here, it should work elswhere, too …

su -

… changed any files in the /etc directory?

Perhaps your user isn’t eligable to be asked. Check the groups your user belongs to:

$ groups

   ~  passwd -S  :heavy_check_mark:
infntelights P 12/24/2021 0 99999 7 -1
   ~  sudo passwd -S  :heavy_check_mark:

[sudo] password for infntelights: 
root P 12/24/2021 -1 -1 -1 -1

   ~  su -  :heavy_check_mark:

[Thinkpad-manjaro ~]#

i do get P after my username in both cases…
here is the output for:
tac /var/log/pacman.log | grep removed | less

[2022-01-04T17:15:28+0530] [ALPM] removed fingerprint-gui (1.09-7)
[2021-12-31T13:43:07+0530] [ALPM] removed yakuake (21.12.0-1)
[2021-12-30T10:13:00+0530] [ALPM] removed kmediaplayer (5.88.0-1)
[2021-12-30T10:13:00+0530] [ALPM] removed kmplayer (0.12.0.b-4)
[2021-12-30T10:10:22+0530] [ALPM] removed qt5-script (5.15.7-1)
[2021-12-30T10:10:22+0530] [ALPM] removed konqueror (21.12.0-1)
[2021-12-25T12:08:25+0530] [ALPM-SCRIPTLET] be removed:
[2021-12-25T11:24:53+0530] [ALPM] removed t1lib (5.1.2-8)
[2021-12-25T11:24:53+0530] [ALPM] removed libgxps (0.3.2-1)
[2021-12-25T11:24:52+0530] [ALPM] removed gspell (1.8.4-1)
[2021-12-25T11:24:52+0530] [ALPM] removed libsynctex (2021.58686-4)
[2021-12-25T11:24:52+0530] [ALPM] removed gnome-desktop (1:41.2-1)
[2021-12-25T11:24:52+0530] [ALPM] removed evince (41.3-1)
[2021-12-25T11:24:47+0530] [ALPM] removed xdg-desktop-portal-gnome (41.1-1)
[2021-12-25T00:30:09+0530] [ALPM] removed spotifyd (0.3.3-1)
[2021-12-24T20:51:55+0530] [ALPM] removed amd-ucode (20211027.1d00989-1)

We have established that your password does work
and also that you do have the ability to acquire administrator rights.

So you should be able to update, install, remove things using the command line,
but not in a terminal or by using the graphical pamac-manager
because the graphical utility to ask for your password is somehow missing
and I don’t know it’s name.
It could be polkit-kde-agent.

Go to a TTY by pressing
or any Fx key between F2 and F6
log in there and run your update:
pamac update
or the command to install the missing utility once you know the name
pamac install missing_program

In TTY mode you will get asked your password without the missing tool.
ALT (the left or right arrow) to cycle back to the graphical session.

You can also use
sudo pacman -Syu
sudo pacman -S missing_program
in a terminal - as pacman will not require the graphical tool

That command was more for you (to refresh your memory) rather than for me.
tac /var/log/pacman.log | grep removed | less

use the up and down arrow to scroll through the list

You last removed something on the evening of January 4th
and some rather important looking stuff in the days before that.
gnome-desktop and other GTK programs …

You can run variations on this:
tac /var/log/pacman.log | grep PACMAN | less
to see what you instructed pacman (or pamac) to do

or you can just use the full list:
tac /var/log/pacman.log | less
to see everything in the log
tac is used to get the last, most recent, entry first … it’s cat in reverse

I don’t know the name of the program that is responsible for asking your password in KDE.
You’ll need to find that out yourself - but someone here surely knows.
You likely removed it inadvertently along with something else - it will probably in the list …

1 Like

right i think i remember removing or disabling this polkit agent in order to set up the fingerprint GUI, but it never worked. I ended up uninstalling the fingerprint scanner utility in the end. i’ll dig deeper into this, i remember following some arch wiki page for the setup.

all right so iirc, i followed this installation guide:
it says to remove
from /etc/xdg/autostart/
sure enough, that agent is missing when doing the ls command in that directory.

i tried re installing it via pacman:
   /etc/xdg/autostart  sudo pacman -S polkit-kde-authentication-agent-1.desktop  :heavy_check_mark:  7s 
error: target not found: polkit-kde-authentication-agent-1.desktop
how do i get it back?

You are trying to install a file the package provides, not the package.

sudo pacman -Syu polkit-kde-agent

PS - I got here late, but yes it seems apparent that sudo and pasword and all works - simply polkit does not.

PPS - In the future, you can look for files in the database like this:

pacman -Fx polkit-kde-authentication-agent
### also note the database needs updates too, so this would be reasonable at times:
sudo pacman -Fyx polkit-kde-authentication-agent

thanks, it did the job!
thanks to everyone else who helped out as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.