No network connection msi b660m-e intel l219

Hey there, I’m pretty new to Manjaro, after Installation I had no internet connection out of the box

I had no issues before. as I used this PC as a hackintosh, but also for Windows I first had to install the Intel Driver Package.

I already tried building and enabling the ice driver of Intel, without success.

lspci -v output

00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (17) I219-V (rev 11)
        DeviceName: Onboard - Ethernet
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7d46
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at 80400000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Kernel modules: e1000e

dmesg output

[    5.416100] e1000e: Intel(R) PRO/1000 Network Driver
[    5.416102] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    5.416308] e1000e 0000:00:1f.6: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    5.625860] e1000e 0000:00:1f.6: The NVM Checksum Is Not Valid
[    5.670691] e1000e 0000:00:1f.6: probe with driver e1000e failed with error -5

A full inxi output would be helpful. Are you dual-booting Windows? If so , is Windows fully shutdown, hibernation, hybrid sleep and fastboot fully disabled? Have you tried a different kernel? A LTS kernel such as 6.1 or 6.6 would be preferable to troubleshoot.

Please read: