No IRQ Handler for Vector - can't boot

Hi All,

Did a general update via the package manager last week. Since then I’m entirely unable to boot into Manjaro (KDE Plasma)

I’m getting a string of No IRQ Handler for vector errors as per this thread Here

I’ve tried various solutions suggested. Have waited a few days and managed to get a command line via TTY which I’ve used to update again but still get the same result.
I have Kernel 5.9.16-1 and 5.11.22-2 installed, both give the same error where 5.9.16-1 was certainly working as my go to option last week.

As per the other threads with this issue I’ve tried adding pci=nomsi,noaer to my boot options but to no avail.

Does anyone have any suggestions on where I can look next?

Many thanks in advance,

Hello @Avionyx :wink:

Well, i read a bit through the thread, but in general you have not many options if normal workarounds don’t work:

  1. Upgrade, Downgrade your BIOS/UEFI until it works.
  2. Upgrade, Downgrade your Kernel until it works.
  3. Add loglevel=0 to the kernel parameter to hide the message.
  4. Compile the kernel yourself with debugfs, isolate the problem and report it to the linux devs.

Both Kernels 5.9 and 5.11 are EOL so please install both 5.4 and 5.10 LTS (Long Time Support) and see which one of the two troubles you least.