No grub theme after fresh install

So I went ahead and did it: After a decade of using openSUSE as my only Linux distribution ever, I switched to Manjaro on my main system last night. There were a few bumps in porting my home directory and all data between distros but it worked out in the end.

At the moment I’m only running into one notable bug: The bootloader works but no theme is installed. When booting there’s a black screen for several seconds… if pressing esc during this time I see the grub menu, but only in console format without any graphics. The splash screen does appear after this. Obviously the grub-theme-manjaro package is installed so the theme should be getting installed.

I assume the ‘bug’ has been produced by this:

The boot loader has nothing to do with the user home directory, it’s exclusively a root / system thing. It started happening the moment I installed Manjaro before even fully setting up my user account.

Gratz on your success switching (& porting) over :+1: . Technically it is an “almost fresh” install, right? :slight_smile:

Did you do this?

P.S. The grub menu is by default hidden, you may also want to set GRUB_TIMEOUT_STYLE=menu instead of “hidden” there.

Thanks, I think I see the problem now: Looking at /etc/default/grub the only GRUB_THEME I see is this commented-out section:

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

I didn’t even think to check as on a fresh VirtualBox install the theme is always set; For some reason the configuration differs on a normal install, and in it theme is absent! A Manjaro setup bug perhaps? I’ll try fixing when I return, but it sounds like tweaking that config should do the trick.

Some quirk on the ISO. You can uninstall and install grub-theme-manjaro to get it added to the grub file (note: reinstall will not do it because that is not triggering the post_install script which does the modification in the default/grub file)

Setting GRUB_THEME fixed the main problem: When pressing esc on boot I see the menu with the proper graphics now. Even so, the screen is completely black for those 5 seconds… on the Virtualbox install it would show the Manjaro logo, which helped differentiate it from POST not finishing yet.

This might be related to the fact that instead of the Manjaro splash screen I get an ASUS logo; I noticed grub likes to detect your motherboard and theme the loading screen based on its brand. This is a cool idea though to be fair I might prefer the Manjaro graphics all the way if I can help it.

Did you read what I wrote above?

I know. But while it’s hidden you have a roughly 5 second timespan to hit the esc key to show it: On VirtualBox you see the Manjaro logo during this interval, so you know when it’s time to press esc… on a normal install it’s just blackness however, which is easy to confuse with the system not having fully entered the boot phase. Something tells me the behavior in VB might be the anomaly though… hidden means it’s likely intended to be fully dark with no notice.

Update: Took a screenshot of the VBox boot screen. It’s likely a VirtualBox thing: The logo during the grub hidden period actually says VirtualBox. A normal machine won’t show anything like this.

Seems not. Please read the thread again from the beginning.
You keep repeating how

while it’s hidden you have a roughly 5 second timespan to hit the esc key to show it:

while I already gave you the solution.

Thanks. I took note of that setting last time but initially wanted to avoid messing with the defaults. In the end I set GRUB_TIMEOUT_STYLE=menu and now it looks and works in a way I truly feel happy with! I really don’t get why it’s set to hidden and not menu by default, I see no point in blackening out the menu until a key is pressed… but as long as I can easily edit those options it’s all good.

U can set the timeout to 0
While booting I hold the shift button to go to the grub menu…otherwise it boots to the display manager directly

It will, enable vendor logo in BIOS.

Mine looks like this, even AFTER Grub (I modified my BIOS with a tool from motherboard vendor). Click to see

1 Like

Grub theme is working ok again when you install from the latest ISO (tested with manjaro-xfce-21.0.1-210409-linux510)

That’s great to hear! Already fixed it on my end so I should see no difference when updating.

Any thoughts on also defaulting GRUB_TIMEOUT_STYLE=menu though? I feel hidden is an annoyance that serves no purpose whatsoever; It doesn’t even show any sort of logo to say “press esc for boot options”, it just feels like the boot process stalls on a black screen 5 seconds longer than it should. It’s literally the only thing I consider a bad decision in the vanilla Manjaro configuration.

The modern norm in the last years is power on your PC and land to your desktop, no BIOS/UEFI entries, no GRUBs, no init/systemd messages for the untrained & casuals, except when they need help and ask in the forums for that. You can set your TIMEOUT value to 0 instead of 5 in grub (GRUB_TIMEOUT=0 in /etc/default/grub ) if you don’t want to wait 5 seconds (it’s still accessible with Esc).
Also you should not think with the “unflexible”, “untransparent” mentality of OpenSUSE’s YasT and of other fixed/semi-rolling distros, Arch & Arch-based distros are made with the KISS principle, meaning everything is transparent and visible in config files, with a fully fleshed-out wiki for everyone to understand how everything works, so tweaking & experimentation is not prohibited but welcomed.

1 Like

True but if you set the timer to 0 you won’t have time to press esc when you need that menu, which can be required for debugging or recovery. The irony is that if it was set to menu by default, you could boot faster by pressing enter when you see grub… with those defaults you’re forced to wait for 5 seconds on a black screen, unless you always press esc and then enter :stuck_out_tongue:

And yes: One reason why I took the massive step of switching from openSUSE to Manjaro is that this OS is designed with even more user friendliness in mind. SUSE is user friendly too yet a bit more technical by comparison… here it’s easier to tweak certain things safely, as well as getting everything up and running more quickly and efficiently. In my book this is now the only distro that managed to take the lead over openSUSE in doing Linux right.

As for boot loader, it might be a nice idea if Manjaro had a GUI to edit it like YaST does… something that could be added someday in the same category as the kernel installer. Just a menu to tweak the basic and safe settings, like the theme and timeout and default boot parameters.

Did you try that before being so sure of it?

1 Like

It was a logical assumption: If there’s no wait time there’s no time to press esc, it would mean an instant boot. Although if there’s also an option to hold down shift to show it, I imagine grub could detect the key being held in a one frame check and the menu still opened.