No connection with BCM4360 Wi-Fi card (TP-link T6E)

Hello all, been needing a bit of help, have been at it for a good few hours. I got a new PC and my first instinct was, of course, Manjaro. Wi-Fi doesn’t work automatically, no biggie, I’ll download the drivers. Well, I’ve tried both broadcom-wl and broadcom-wl-dkms and neither seem to work. My WiFi card is detected as hardware. WL is running and active. There is simply zero WiFi interface or connection though and I am extremely confused as to why … I’m not even getting any errors (from what I can tell), updated kernel, and headers both to 6.6.26-1, both packages are fully updated with DKMS fully installed as well. I’ve tried all steps listed here multiple times to no luck: – This will be a lot so thanks a lot in advance, please let me know if any logs or additional info is needed.

$uname -a

Linux leonis 6.6.26-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Apr 10 20:11:08 UTC 2024 x86_64 GNU/Linux

$ inxi -Fxxxza:

  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI RTL8111/8168/8411 driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 05:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF-ID-1: enp0s20f0u5i1 state: up speed: 425 Mbps duplex: half
    mac: <filter>
  Info: services: NetworkManager

$ dkms status:

broadcom-wl/, 6.6.26-1-MANJARO, x86_64: installed

$ rfkill list all:
no output. Doesn’t hang, just nothing,

$ lspci -vnn -d 14e4:43a0

05:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Dual Band Wireless Network Adapter [14e4:43a0] (rev 03)
        Subsystem: Broadcom Inc. and subsidiaries BCM4360 802.11ac Dual Band Wireless Network Adapter [14e4:0619]
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at 82400000 (64-bit, non-prefetchable) [size=32K]
        Memory at 82200000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: <access denied>
        Kernel driver in use: wl
        Kernel modules: bcma, wl

$ ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 04:7c:16:01:8e:0e brd ff:ff:ff:ff:ff:ff
3: enp0s20f0u5i1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 6a:f1:ce:a1:41:3f brd ff:ff:ff:ff:ff:ff

$ sudo dmesg | grep -Ei 'b43|bcma|brcm|wl|[F]irm|deauth'

[    1.507268] i915 0000:00:02.0: [drm] GT0: GuC firmware i915/tgl_guc_70.bin version 70.20.0
[    1.507276] i915 0000:00:02.0: [drm] GT0: HuC firmware i915/tgl_huc.bin version 7.9.3
[    1.507328] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/adls_dmc_ver2_01.bin (v2.1)
[   24.826731] wl: loading out-of-tree module taints kernel.
[   24.826735] wl: module license 'MIXED/Proprietary' taints kernel.
[   24.826736] wl: module verification failed: signature and/or required key missing - tainting kernel
[   24.826737] wl: module license taints kernel.
[   24.830623] wl 0000:05:00.0: enabling device (0000 -> 0002)
[   24.845290] Missing ENDBR: otp_read_bit+0x8ce/0x106c [wl]
[   24.845361] RIP: 0010:otp_read_bit+0x8ce/0x106c [wl]
[   24.845389]  ? otp_init+0xa5/0xc3 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845407]  otp_read_word+0x51/0x9d [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845425]  ? si_set_sromctl+0x50/0x5b [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845451]  wlc_phy_attach_acphy+0x164d/0x182d [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845493]  ? wl_init_timer+0x6a/0xa0 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845533]  wlc_phy_attach+0x818/0xfc2 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845575]  ? osl_malloc+0x1d/0x50 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845613]  wlc_bmac_attach+0x8ee/0x1215 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845649]  ? osl_malloc+0x1d/0x50 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845691]  ? wlc_scan_attach+0x161/0x1b9 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845731]  wlc_attach+0x283/0x1a93 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845765]  wl_pci_probe+0x2a0/0xf50 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]
[   24.845801]  ? __UNIQUE_ID_vermagic197+0x36ffbc52f853/0x36ffbc52f853 [wl 6b6bc0ab06cd445651d23e7dc80a1b1c0a7df2ed]

$ grep -r "blacklist\|install\|options" /etc/modprobe.d/

/etc/modprobe.d/blacklist.conf:blacklist b43
/etc/modprobe.d/blacklist.conf:blacklist b43legacy
/etc/modprobe.d/blacklist.conf:blacklist ssb
/etc/modprobe.d/blacklist.conf:blacklist bcm43xx
/etc/modprobe.d/blacklist.conf:blacklist brcm80211
/etc/modprobe.d/blacklist.conf:blacklist brcmfmac
/etc/modprobe.d/blacklist.conf:blacklist brcmsmac
/etc/modprobe.d/blacklist.conf:blacklist bcma

$ pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia


$ hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"

  Model: "Broadcom BCM4360 802.11ac Wireless Network Adapter"
  Driver: "wl"
    Driver Status: bcma is not active
    Driver Activation Cmd: "modprobe bcma"
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: enp4s0
  Link detected: no
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Model: "Google Pixel 6"
  Driver: "cdc_ncm"
  Device File: enp0s20f0u5i1
  Link detected: yes
    Driver Status: cdc_ncm is active
    Driver Activation Cmd: "modprobe cdc_ncm"
    Driver Status: cdc_mbim is active
    Driver Activation Cmd: "modprobe cdc_mbim"

Hi @novel and welcome to the Manjaro community.

No, that’s not ok, but this example is:

This doesn’t produce a live link, but it does give a string that others can select, and copy to clipboard. This is achieved simply by placing the link between two backticks `like this`. This is your best workaround until you pass the initial stage of forum membership.

Your BCM4360 is obviously detected. You could try reverting to kernel 6.1 (LTS) to see if that makes any difference.

I understand there have been WiFi issues for some users, linked to a few of the 6.6.x iterations, but I haven’t been following those closely enough to offer anything constructive. If you search the forum for similar threads, you might find something useful.

In the meantime, and as a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.


Thanks, haha. I was wondering about some sort of workaround but that is much cleaner than what I had done. I’ll edit it accordingly.

I hadn’t known about WiFi issues relating to the kernels at all, so I appreciate it. I had read up that kernel 5.X had some issues with Broadcom drivers but well, can’t say that applies. I did just try to revert to Linux61 to no avail, unfortunately. Can’t say anything seems different or I am getting any new errors.

Thank you for the links as well, I’ll be sure to check them out.

Should work with broadcom-wl-dkms according to [SOLVED] How to get WiFi working with BCM4360 (Macbook Air 2014) / Newbie Corner / Arch Linux Forums

Is b43-firmware pkg installed? There is an issue with using 5GHz band, see here, set router/channel accordingly.

b43-firmware is not installed at the moment, no. I have built and installed it but it doesn’t seem to have helped at all. b43 is already blacklisted, but, yeah, no dice. My Wi-Fi is dual band. I have no issues getting 2.4ghz and 5ghz to both work on my Windows dualboot set-up, fortunately, so I don’t think this is faulty hardware.