New Monitor keeps flickering (just under Manjaro)

I got the Alienware oled monitor and since then the screen is flickering (just with Manjaro - no flickering with Kubuntu). I have tried different refresh rates but other than that I dont know what I could do.

It is just this one Monitor I am using. Connection via DP.

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 5.15.128-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-9700K CPU @ 3.60GHz
Memory: 15,6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2080/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: Z390 AORUS PRO

1 Like

Hey @Fred_VIE this could help… specially since you have problems with the GUI after reboot.

I hope this info is self explaining to you… just create a emty file and copy that stuff and into it also add .sh at the end of the filename. btw you dont see a good result when changing in the UI and using Terminal commands… so the powermizer may didnt show up the right result… you have decide for yourself which way fits better for your like.

I total with you here and for me its works after a restart, but this can be solved… :wink:

With this little script you can also reload nvidia settings after restart:

nvidia-settings -l

Try if this works…

You can also create a autostart command if you dont want to always clicking on the bashscripts on your desktop… there are several ways to add something in autostart…

I could even deactivate g-sync on my Monitor, this was a much bigger fight :upside_down_face:

1 Like

Thanks! The only thing I would like to change though is “force full composition pipeline”.
I have never used scrpits. Would I just righklick it and choose “run in console”? Well when I try that it says Warning: Could not find ‘/home/fred/Desktop/’, starting ‘/bin/bash’ instead. Please check your profile settings.`
(All those cryptic error messages :P)

Adding something to autostart is the easy part, making it actually run is a whole different matter.

Just as i said, create a file on desktop (desktop is just a option btw)… as a sample you can name it then open it with kate and copy that 2 lines which i posted in this files and save it.

After that you can simple double click it and you should see the result, its a total simple task.

But you can also copy the second line in a Terminal and just enter it, to see if you get a error.

Doubleclicking the sh file opens kate.

The 2nd line works in the console without error but no settings are being saved still.
I can now suddenly export the settings file but that’s kinda pointless if the program refuses to load it on restart.

If this is really true, then you have a really big issue with your system.
Did you really created a empty file and copy that text in it?

nvidia-settings -l just loads your previous settings, nothing more.

I have this in autostart and it works.

I have no idea which export settings are you talking now… if you talking about the simple savefile option is working now… just overwrite the old setting file and check if nvidia-settings -l or follow the youtube video guide, that i had sending to you from my yesterdays answers from another Thread.

What big issue can one have after just installing the OS and a few programs?

Yep, I created a new one on the desktop and renamed it. Maybe the issue was that the created one used to be a txt file (that came automatically)?

Once it works after doubleclicking it I’ll put it in the autostart. The savefile option works, just not in the folder it suggests. I could just save it in my documents folder but it wont load from there.

I’ll recheck the guide and get back to you later.

Yeah just try to copy that file with terminal command into that folder where he suggested and name it the right way…

So does the scripts works now when you double click it?

If not maybe look in file association:

1 Like

Need to make it executable - chmod +x or right-click → Properties → Permissions → Is Executable.

1 Like

Well Kate is in the file associations but if I remove them all it just asks for one on double click.

I set it via Properties.
When I double click following error shows in dolphin:
´execvp: Exec format error`

Just to make sure I created a new file, copied the

nvidia-settings -l

inside but the same error shows on double click.

You dont have to count on this bash script (but it should work per default), anyways you can also load nvidia-settings -l with another autostart solution.

Is this command restore that settings when executed in Terminal?

Does it load your settings that you need?

I mean, i mainly need this command for my colour settings… so i dont know if you have to use it or not.

Edit: Would be helpfull to report back, if this youtube guide could solve your problem or not.

Using it in the console wont restore the settings I changed. Probably because I can not save them in the suggested path.

I dont know howto autostart a command without a file. Most apps I am using have preferences where I can tick/untick the autostart option.

With the guide I could save the settings in my documents folder but they never restore.

He also gave you the info how to name the file and where to sudo copy command to the right folder… did you follow it?

Btw. that you cant execute the bash script is another problem, you may need to open another topic. I dont think i can assist you there.

Here is a little info, how i did add nvidia to autostart in the past, the screenshots should explain it:

1 Like

I copied it now, restarted and it loaded the settings! Many thanks! I had a typo in the name when I did it the first time, which caused the fail.

After a restart the sh-file does suddenly not cause an error anymore, instead nothing happens, but now it loads the settings while loading Manj. anyways.

So you also using now max performance to temporary cure your flickering?

I also send some bug reports to nvidia and a developer reported back that they can
debug the problem, but no update since 2 weeks now.

Someone else in this Topic mentioned that also switching from auto to adaptive helps him to.

But for me i get better result with max performance… even my 2080Ti went from 10watt to 50watt, while system is in idle :frowning:

I just hope we see a true fix soon… after 6 month, atleast there is light now at the end of the tunnel.

1 Like

I used Kubuntu because of the flickering, but I am going to try max performance next time I need Manj. Atm I am still running both for personal reasons, but also in case I can not fix a problem in one of them (to avoid having to start Win).

I could also use the onboard GPU considering I am not playing lately anyways thus the 2080 is not really needed at this point (and way too slow).

Unfortunately the flickering still happens in adaptive mode for me. It seems to be flickering a bit less frequently but maybe I am imagining it. I did not try performance mode because I dont want to waste unnecessary energy for mere desktop work.

Weird is though. When I restarted Linux and started the nv-settings from the task bar it said mode auto (currently adaptive).
When I started the nv-settings panel via the console with sudo it said adaptive.

I installed today nvidia driver 535.129.03 and the flickering is finally gone.


No driver in the auto update.
I guess I have to find the panel again where I can choose from different drivers.

I installed it from pacman UI, its in stable branch.