New Install on SSD (Do I have a problem here?)

Hi, I don’t know what’s the issue here, but it looks like a problem to me.

I just recently bought an SSD because my old HDD went bad.

So after install, this is what I saw before I entered login screen:

/dev/sda2: clean, 238989/30507008 files/ 3779618/122018696 blocks

I had to take a video to capture that message. then after that login screen appeared and I was able to proceed to Desktop.

Then I head on to shutdown, and these are the messages I see:

/dev/sda2: clean, 242357/30507008 files/ 3806661/122018696 blocks
[   67.079695] ACPI BIOS Error (bug) Could not resolve symbol [\RPTS.1082], AE_NOT_FOUND (20200925/psargs-330)
[   67.079767] ACPI Error: Aborting Method \RPTS due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
[   67.079811] ACPI Error: Aborting Method \_PTS due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
[   67.079939] reboot: Power down
and This below is what happened to my **old HDD** that went bad before I use a **new SSD**
mount: /new_root: can’t read superblock on /dev/sdb2
You are now being dropped into an emergency shell.
sh: can’t access tty: job control turned off

A little note: I’m using a Samsung SSD 870 Evo

You should boot into a Live Media and run:

sudo fsck /dev/sdb2

Afterwards try to fully update the manjaro-chrooted system, and then run:

sudo mkinitcpio -P
sudo update-grub

ok I’ll do that, but what happened here? I was expecting no more issues once I used a new drive. If I just reinstall again using livemedia, is this going to persist?

The first block of a disk or of a partition is called the superblock. A superblock can be damaged for example in a sudden power outage, but there are backup copies of the superblock in a block group. Let’s hope fsck will repair it.

1 Like

omg, I hope fsck will, because I just invested some for an SSD. ok I’ll do what you said, I just inserted the SSD just yesterday and tried to install, the SSD hasn’t experience a Power outage yet.

I was thinking it got affected by the previous HDD because of the phrase “ACPI Error Aborting method due to previous error” but I’m no Expert.

I’ll head to do chroot now, BRB.

Hi @Wollie

From Live Media Summary
[manjaro@manjaro ~]$ sudo fsck /dev/sdb2
fsck from util-linux 2.36.2
fsck.fat 4.2 (2021-01-31)
/dev/sdb2: 6 files, 74/2036 clusters

I checked with fdisk, I think it should be sda2

[manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 870
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6D6A93F0-E3F3-534F-8AE5-D8D5BB4F445E

Device      Start       End   Sectors   Size Type
/dev/sda1    4096    618495    614400   300M EFI System
/dev/sda2  618496 976768064 976149569 465.5G Linux filesystem

Disk /dev/sdb: 14.45 GiB, 15518924800 bytes, 30310400 sectors
Disk model: TransMemory
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *         64 4698483 4698420  2.2G  0 Empty
/dev/sdb2       4698484 4706675    8192    4M ef EFI (FAT-12/16/32)

Disk /dev/loop0: 26.02 MiB, 27283456 bytes, 53288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 370.47 MiB, 388464640 bytes, 758720 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 1.11 GiB, 1188855808 bytes, 2321984 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 697.21 MiB, 731078656 bytes, 1427888 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

So I head on to do fsck to sda2

[manjaro@manjaro ~]$ sudo fsck /dev/sda2
fsck from util-linux 2.36.2
e2fsck 1.46.2 (28-Feb-2021)
/dev/sda2: clean, 243207/30507008 files, 3810649/122018696 blocks

Seems fsck failed?

Just did the following, still the same
Smart CTL
sudo smartctl --all /dev/sda
[sudo] password for zaiakursed: 
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.36-2-MANJARO] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke,

Device Model:     Samsung SSD 870 EVO 500GB
Serial Number:    S5Y1NJ0R157754Y
LU WWN Device Id: 5 002538 f31130e90
Firmware Version: SVT01B6Q
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
TRIM Command:     Available, deterministic, zeroed
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-4 T13/BSR INCITS 529 revision 5
SATA Version is:  SATA 3.3, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Tue May 25 02:36:38 2021 PST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                        was never started.
                                        Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever 
                                        been run.
Total time to complete Offline 
data collection:                (    0) seconds.
Offline data collection
capabilities:                    (0x53) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        No Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine 
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        (  85) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
  5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       0
  9 Power_On_Hours          0x0032   099   099   000    Old_age   Always       -       2
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       13
177 Wear_Leveling_Count     0x0013   100   100   000    Pre-fail  Always       -       0
179 Used_Rsvd_Blk_Cnt_Tot   0x0013   100   100   010    Pre-fail  Always       -       0
181 Program_Fail_Cnt_Total  0x0032   100   100   010    Old_age   Always       -       0
182 Erase_Fail_Count_Total  0x0032   100   100   010    Old_age   Always       -       0
183 Runtime_Bad_Block       0x0013   100   100   010    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0032   067   056   000    Old_age   Always       -       33
195 Hardware_ECC_Recovered  0x001a   200   200   000    Old_age   Always       -       0
199 UDMA_CRC_Error_Count    0x003e   100   100   000    Old_age   Always       -       0
235 Unknown_Attribute       0x0012   099   099   000    Old_age   Always       -       1
241 Total_LBAs_Written      0x0032   099   099   000    Old_age   Always       -       33048143

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
  256        0    65535  Read_scanning was never started
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

I’m really sorry about this, I really have no idea, but upon duckduckgo’in I found this

Summarizing what that message means,

/dev/sda2: clean, 286631/611123 Files, 2586472/24413952 Blocks

The message /dev/sda2: clean, 286631/6111232 files, 2586472/24413952 blocks has the following meaning:

The partition that was checked is “/dev/sda” The file system is “clean”, i.e. there are no inconsistencies “286631/6111232 files”: The file system has been created to allow a maximum of 6,111,232 files, and currently there are 286,631 files, “2586472/24413952 blocks”: The storage capacity of the file system is 24,413,952 blocks (probably 4096 bytes each), and 2,586,472 blocks currently are in use.

This is an informational message confirming that the file system is ok. There is nothing that needs to be resolved or repaired.

Now, what are these ACPI Errors?

Hi @Zaiakursed,

While I honestly don’t know what to do about it, according to this website:

ACPI specifies how a computer’s basic input/output system, operating system, and peripheral devices communicate with each other about power usage.

So it seems to me, that the error is caused by something to do with power usage. I don’t know what, though. Could be the power supply, in fact, it probably is. Not an official diagnosis, but that’s my opinion.


I really don’t think you have anything to worry about, from the message you provided, it seems it’s caused by a bug, not a fault with your system.

Hope this helps!

I see, if that’s the case, then it’s pinpointing my Battery because it has gone bad and I have salvage it last year for my flashlights.

I also found this, so I’m trying to go for an LTS Kernel (anyway, I’m always on LTS). It’s quite a recent issue, that’s why I have been wondering, I though I had a bad SSD. Phew.

I just really want to restore my daily driver without any issues and then I stumbled on this ACPI Error and fsck checks that I never saw before.

Yes, I don’t think there’s any need to worry. At least at the moment, as things stand now.

@Mirdarthos Thanks, I can sleep on it now…

Thanks for the support Guys… :smiley:

1 Like

This annoying message is caused by fsck on recent installations (because by default there is the fsck hook in mkinitcpio). You can hide it by forcing a different log level in grub parameters (but that might hide other messages too, to be verified).

But in my opinion this message shouldn’t be shown at all when there is no issue during the check (which is the case here from the message), I think it is a problem from fsck itself outputting a ‘warning’ type of message for what should be a simple ‘notice’.

For the ACPI messages though I can’t really tell. Maybe trying other kernel can help.

1 Like

This is not an annoying message but totally normal, just ignore it. If you have a problem in your filesystem you will get a different message.

It is definitely annoying as when you set quiet splash Grub boot parameter, it doesn’t respect it, and shows you this message to say ‘nothing wrong’. This is dumb.

It’s always amazing how people get annoyed by such a simple and short message. Are you booting your system every half hour? Why is it so difficult for you to simply ignore it?

It is annoying because I set my system in a specific way, no boot message, and splash screen of my motherboard until I reach desktop, and if I let this as is, it “breaks” my configuration because it forces output of a console message when it shouldn’t (there is no error so why should it give a Warning message? default log level is 4 in Manjaro right? So this is a level 4 log message?).

I could have same way of thinking with your reply: “why are people so annoyed by people affected by an illogical issue”.

//EDIT: ho I see, clicking the yawning emoji is the best you can reply to that… take this -1 emoji then. I gave you proper points about why it is annoying, you can’t beat that because this is an actual issue and makes no sense.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.