Stuck at Manjaro: clean, .../...files, .../...blocks when shutting down

When I shut down my computer, it will stuck at:

Manjaro: clean, 623494/4333568 files, 9352667/17323345 blocks

Appear after testing update today.

This sentence also appear when I open my computer, but it won’t stuck there. What does it mean? Can I unable it?

I found another post: Stuck on "... clean, ... files, ... blocks" on laptop screen at boot - #2 by megavolt

This is my Graphics Information:

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: server: X.Org 1.20.11 driver: loaded: intel unloaded: modesetting s-res: 2736x1824 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.0

Hi @Firestar,

That is part of the fsck…hook? during startup and shutdown. It’s no reason for concern if it says ...clean..., it just means the filesystem is…well…is clean.

It can be disabled, but it’s not recommended as then your fsck won’t run. It’s not JUST the message you’ll have to disable, it’s the whole fsck hook.

As for being stuck during shutdown, it’s not really. It just takes a (relatively short) while to complete the check and go on. Yeah, it got to me at first as well.

So it will certainly display when fsck enabled? Is there a way to use fsck without displaying this? I remember this sentence did not happen last year, on Manjaro 20.

I don’t know if there is a way, but I, for one, am glad I can catch a warning of a drive problem as quick as possible.

It also wasn’t there at first for me, but it became visible after I put the fsck hook into /etc/mkinitcpio.conf, so perhaps you also did it, or perhaps it became standard for Manjaro. :man_shrugging:

I suggested that in another thread

If you both could try and report that could help.

//EDIT: also in the other thread there was another suggestion above my reply

Thanks @omano. I’ll try it and remember to revert, as I’m quite happy with mine.

@omano, well. This is so, so, so cool. THANK YOU!

Just edited etc/default/grub and added loglevel=3 to the end of the `` line and executed sudo update-grub. Rebooted. And now the message is gone on both shutdown and reboot’s much faster. All while startup seems unaffected. And I did it again, to make sure it wasn’t a fluke, and it stuck!

So thank you!

1 Like

Nice :smiley: but apparently it would hide some messages then (see the log level link in my post). I still didn’t have a chance to try on the friend laptop yet but I’ll apply it then next time I will have a chance.
//EDIT: I think log level by default in Manjaro is 4 for info

I noticed, that fschk is permanently activated in fresh installations since Manjaro version 21.0, but not in systems upgraded to version 21.x

That’s interesting.

@omano, I see yes. Don’t know how I feel 'bout that. There could, potentially, be useful info hidden now…and I like to keep an eye on my system and know what’s going on…

Which line? the GRUB_CMDLINE_LINUX="" line or a new empty line?

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

Yes, sorry. That exact one. At the end of it.

No, sorry. I misread. It’s been a long day. At the end of the GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3" line.

1 Like

You can edit your original post there, it will be

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 loglevel=3"


Looks right to me.

Remember to run

sudo update-grub


A bit off-topic, but I see you’ve set GRUB_DISABLE_OS_PROBER=false twice.


Sorry it seems not right to me …

I have added the loglevel=3 run sudo update-grub

Here’s mine, if it’ll help:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=1b3f894f-5481-4241-ace5-c129a0cdb412 udev.log_priority=3 loglevel=3"

But I have not installed apparmor

the UUID can be known by lsblk --fs

Just add the GRUB loglevel parameter to the end of your GRUB_CMDLINE_LINUX_DEFAULT line. Then update-grub.

Sorry it seems not right to me …

I have added the loglevel=3 run sudo update-grub but it still gives fsck messages.

Maybe we can look the Silent Boot(fsck) on ArchWiki

Silent boot - ArchWiki (This can turn the fsck messages down)

After I do all the things I need via this website. It does not appear but… it still stucks, at blank screen, where you can type on.

**I believe the fault belongs to linux 5.12 kernel. See Stuck when shutting down (v5.12) · Issue #439 · linux-surface/linux-surface · GitHub **

(base) [firestar@FIRESTAR ~]$ journalctl -rb -1
-- Journal begins at Mon 2021-04-05 15:49:57 CST, ends at Fri 2021-05-14 00:14:15 CST. --
5月 14 00:08:28 FIRESTAR systemd-journald[275]: Journal stopped
5月 14 00:08:28 FIRESTAR haveged[274]: haveged starting up
5月 14 00:08:28 FIRESTAR haveged[274]: haveged: Stopping due to signal 15
5月 14 00:08:28 FIRESTAR systemd-shutdown[1]: Sending SIGTERM to remaining processes...
5月 14 00:08:28 FIRESTAR systemd-shutdown[1]: Syncing filesystems and block devices.
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=24 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=25 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=26 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=20 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=21 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=22 op=UNLOAD
5月 14 00:08:28 FIRESTAR audit: BPF prog-id=23 op=UNLOAD
5月 14 00:08:28 FIRESTAR systemd[1]: Shutting down.
5月 14 00:08:28 FIRESTAR systemd[1]: Reached target Power-Off.
5月 14 00:08:28 FIRESTAR systemd[1]: Finished Power-Off.

It is linux 5.12’s fault and it does not happen on 5.11. I downgraded to 5.11 and installed a 4.19-lts as backup.

Now it has been fixed and I can use 5.12 now!