My system freeze since last update

Hello,

Thank you in advance to whoever can help me with my problem.

I have been using Manjaro for about 6 months. Everything was working at its best, until the last update. After about ten minutes, the system freezes on the screen I’m working on; impossible to recover it, screen & mouse inactive, I have to shut down the system with the power button. This happens every time I’m on the net.

Browser: Chromium, Firefox
Manjaro stable
PC : HP G4
Dualboot win10/Manjaro
Free mem : 8G°

Thank you guys if you can helm me to solve my problem

Howdy!

Could you please open a terminal and punch in sudo pacman -S linux58 --noconfirm && sudo mkinitcpio -P please?

Reboot!

If the problem persists, feel free to reach me out! :smile:

Have a wonderful day!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:

    [HowTo] reboot / turn off your frozen computer: REISUB/REISUO

  2. Also, please read this:
    How to provide good information in your posts - Tutorials - Manjaro Linux Forum
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

    An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

Thank you for your answer;

What i’ve done :

[marqui@marqui-Manjaro ~]$ sudo pacman -S linux58 --noconfirm && sudo mkinitcpio -P
[sudo] Mot de passe de marqui :
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) linux58-5.8.6-1

Taille totale du téléchargement : 85,72 MiB
Taille totale installée : 148,96 MiB

because of “Sorry, you cannot include links in your messages.” my answer is uncomplete
But i have a “The requested URL returned error: 404” all the way.
Plus at the end :
“warning: error when recovering some files
error: transaction validation failed (failed to recover some files)
Errors occurred, no packages were updated.”

My comment :slight_smile:
it look weird, isn’it ???

Marqui

Thanks your answer, i will try asap.

have a good day

As my computer freezes regularly as soon as I go online I need to restart it each time.

Have a good day & again thanks

Pouvez-vous executer sudo pacman-mirrors -i, svp?
Merci :upside_down_face:!

  1. When providing output from commands, first type:

    export LANG=C
    

    From that moment on until you close the terminal, all output will be in English, puisque pas tout le monde comprend le Français because not everyone understands French.

  2. Please read this too… (sorry for making you read all that) :sob:

  3. Please try this:

    export LANG=C
    sudo pacman-mirrors --fasttrack && sudo pacman -Syyu #gets fastest mirrors for your location
    pamac upgrade #upgrades everything first
    sudo mhwd-kernel --install linux58 #installs 5.8 kernel
    

@The_Quantum_Alpha :fr: only here, please? (for moderation reasons) :man_shrugging:

Please don’t advise kernel installations via pacman - there is a manjaro tool for that:

sudo mhwd-kernel -i linux58

This will also take care of additional packages (graphics/network drivers for example).
Also --noconfirm should be avoided - the user should see warnings and confirm the action to be taken.

1 Like

My most sincere apologized, I will take note for future advices!
Thank you!

Oh, try executing
sudo pacman -S linux58 --noconfirm && sudo mkinitcpio -P une autre fois!


Some may dislike --noconfirm, but I know what I am doing (lisez ma description ) :wink:

Hello guys & thanks again.
I apologize for my problematic messages.

I have executed the following command :
“sudo pacman-mirrors -i”
“sudo mhwd-kernel -i linux58”
" sudo pacman -S linux58 --noconfirm && sudo mkinitcpio -P

it looks like I don’t have freeze problem anymore. But i need to reboot and run my device for some time before confirmation.
I will come back soon to confirm if it works.

Anyway, a great thanks to all of you for helping me.

Have a nice day.

1 Like

Sent you the commands above :baguette_bread:

Have a sweet day😂

Hello again,

It seems that the problem persists… My system freezes again and this time i was using a word processor & Libre Office Draw & i was not on the net.
Win10 is working fine (dual boot) on this computer…

Can you please provide me the output of cat /etc/fstab, may I ask?

Thank you!

Good morning,

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=6080-083E                            /boot/efi      vfat    umask=0077 0 2
UUID=d8ebbc17-efb4-4f64-b7c3-2138373badbf /              ext4    defaults,noatime 0 1

Plus others very weird things have happened :
1° I’ve change my passw yesterday - The system still ask me the old passw when i want to launch Firefox for ie, but when i connect to manjaro my new paswd is accepted.
2° When i first boot this morning, the grub had vanish and i had to pass through the boot menu to find Manjaro again.

Thanks again for helping me

In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

instead of like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

(as that makes our life much easier so you get helped more quickly and efficiently)

:innocent:

okay, open a terminal, type in sudo -i, and we will make a swap file.

Start with dd if=/dev/zero of=/swapfile bs=1M count=2048 status=progress
this will allocate 2GB of space for the swap file.

Then, enter chmod 600 /swapfile

Time to format the swap file to be a swap! mkswap /swapfile

Then switch it on. swapon /swapfile

After that, you will need to nano /etc/fstab and add /swapfile none swap defaults 0 0 .

Fine tune the swappiness to about 20 with nano /etc/sysctl.d/99-swappiness.conf and change the vm.swappiness value to 20. ctrl+s to save.

After all that, can test out you system, see if it does not freeze anymore!

Ok,

sorry for the delay. I will try your proposal during this day. A big hug !!!

1 Like

Citation Fine tune the swappiness to about 20 with nano /etc/sysctl.d/99-swappiness.conf and change the vm.swappiness value to 20. ctrl+s to save.

Citation
Hello, made the change you indicate me on my system.

Thus, i change the swappi that way :

sysctl vm.swappiness=2

Then :
sudo > /etc/sysctl.conf ```
vm.swappiness=1

I will tell you if it's ok or not

Have a nice day