My desktop shows up completely empty after system updates


In the TTY, what happens if you Ctrl+C and close EVERYTHING and then run


well, the display manager seems to be running already with no indication of a problem

you could try to stop it, then start it again - perhaps the output generated in the TTY will yield some information …

systemctl stop sddm.service
systemctl start sddm.service

sudo should not be needed - it will ask for authentication on it’s own (at least: it should)

well, the display manager seems to be running already with no indication of a problem

I do see a few error messages in the output from journalctl above that look related to sddm. Don’t those indicate any problem?

… I don’t :man_shrugging:

It would look like auto login is a issue with SDDM.

Are you using auto login on startup without entering password?

I get a new separate graphics session in Ctrl+Alt+f2 that also exhibits the issue.

I think so, yes.

Edit /etc/sddm.conf.d/autologin.conf to remove some block code:


Then try to restart SDDM.

1 Like


OK, I have absolutely no idea,

Check in the logs if there really is something about SDDM:

journalctl --boot=0 --unit=sddm.service --no-pager --priority=4

Also a few messages in the output I posted before look related to sddm and not reassuring.

Try running:

DISPLAY=:0 startplasma-x11

caused this popup to show up:

Other than that, had no visible effect.


It seems I’m either being cursed by your PC in arabic or something, or it’s possessed and you need an exorcist.

Either way, I don’t know what to do. Sorry.



Just thought of this: try running it without the prefix:


I meant these:


That was the first thing I tried. Just gives me the error:

$DISPLAY is not set or cannot connect to the X server.

That didn’t help.
I rebooted, entered the password, and the issue persists.

rerun update again:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

if you are up to date, and there are no errors, check with:
sudo ldconfig
it should return nothing, if it does, create a new test user, reboot, log in with it and see if it has the same issues

There have been some recent forum posts suggesting that corruption of a KDE configuration file was to blame for some similar issues. You could try renaming the file; plasma will create a fresh one after logging out and back in.

mv ~/.config/plasma-org.kde.plasma.desktop-appletsrc ~/.config/plasma-org.kde.plasma.desktop-appletsrc.bak

If things work properly afterwards, you could try to restore your original desktop appearance with the relevant lines from the original config file.


Indeed, that was the issue.

I just found this:

I didn’t need to move/remove the file, just deleting the [ScreenMapping] section was enough.

My gosh the KDE people really need to get their s*** together :roll_eyes:

some process(es) after autologin failed to start, from what I can see
(looks like telegram.desktop)
you could try to disable autologin

it (in theory) should not affect the display manager itself

have you tried stopping and then starting the service?

but perhaps what @Takakage said
I don’t run KDE (only in a VM) and have never experienced a problem
but I also never had autologin - too many problems with apps that want or need authentication before they start

I used KDE5/Plasma for a brief time, and during that time, I routinely backed up:

  • $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc
  • $HOME/.config/plasmashellrc

to $HOME/kdeSaves.

I restored when the desktop seemed to , “randomly lose the desktop settings”. Never found the root cause, but was leaning towards multiple monitors. Interesting that it is still necessary to backup config files.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.