My desktop shows up completely empty after system updates

I have had Manjaro for a few months and never had this issue before.

I have just installed a bunch of system updates and rebooted. No error was shown at any time.

My desktop shows up completely empty (there should be a few icons as I have a few files and links in it), and I can’t launch ANY application.

I tried opening Dolphin, Console, Kate, Chrome, it shows the loading icon for a few seconds and there nothing. Not even an error message.

My computer basically turned into a brick.

Please help me urgently fix it and report the bug to the right culprit.

This post was flagged by the community and is temporarily hidden.

Without any system information or logs it’s only speculation that is possible.
mine is: perhaps your disk is full

to get the information, as well as assess and remedy the situation, boot a live system (the install medium, for instance)

LOL no the disk is not full.

What logs should I try to fetch?

Boot the live CD, enter a chroot environment, and provide the output of:

journalctl --boot=-1 --priority=4 --no-pager

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

When I try to launch any app, like dolphin or a terminal, certainly that’s throwing some errors. Is there a way I can get to see those errors? Normally I would try launching the apps from a terminal, but I can’t open a terminal in the first place.
If I go to a separate virtual tty with ctrl+alt+f2, is there a way I can run a command from there but have it run like “from within” the graphic screen (the one I see in ctrl+alt+f1)?

I do not have a live CD, and now I don’t have a PC to download a live CD from.
Hope this does it

In theory you should be able to just prepend


But I don’t know if this’ll work, I’ve never done it, hence it’s only a theory.

Hmmm, funny.

From the ctrl+f2 I ran “DISPLAY=:0 dolphin” and this does successfully run dolphin in the graphic display with no error.

Did the same with Chrome and it successfully ran Chrome but for some reason it behaved like it’s running for the first time. Maybe I’m running the programs as root.

Edit: no, the programs I launched are running as my non-root user…

Well, then check is SDDM is started.

sudo systemctl status sddm.service


In the TTY, what happens if you Ctrl+C and close EVERYTHING and then run


well, the display manager seems to be running already with no indication of a problem

you could try to stop it, then start it again - perhaps the output generated in the TTY will yield some information …

systemctl stop sddm.service
systemctl start sddm.service

sudo should not be needed - it will ask for authentication on it’s own (at least: it should)

well, the display manager seems to be running already with no indication of a problem

I do see a few error messages in the output from journalctl above that look related to sddm. Don’t those indicate any problem?

… I don’t :man_shrugging:

It would look like auto login is a issue with SDDM.

Are you using auto login on startup without entering password?

I get a new separate graphics session in Ctrl+Alt+f2 that also exhibits the issue.

I think so, yes.

Edit /etc/sddm.conf.d/autologin.conf to remove some block code:


Then try to restart SDDM.

1 Like


OK, I have absolutely no idea,

Check in the logs if there really is something about SDDM:

journalctl --boot=0 --unit=sddm.service --no-pager --priority=4

Also a few messages in the output I posted before look related to sddm and not reassuring.