Multiple problems when suspending (closing lid) and resuming my laptop

Hey everyone, first of all I want to say that I am very happy with manjaro (ex-ubuntu user here). So, thank you.
Said this, I have multiple problems.
I recently switched to wayland with kde plasma and:

  1. systemd when shutting down decides to wait forever for sddm to terminate. (AFAIK this can be solved by installing sddm-git from AUR, but I did not tried yet)
  2. When closing the lid of my laptop, suspend is ok, however when I re-open the lid the wifi is disabled and I have to do systemctl cancel or systemctl restart NetworkManager (I figured out that it’s better to do the cancel otherwise I would not be able to reboot if there is a kernel upgrade)
    When closing the lid again it looks like suspend is not active… I have a thinkpad and the led does not blink. Which usually means that the system has not suspended.
  3. Last (I hope!) sometimes, when I shutdown or reboot systemd waits for an script forever so I have to hard shutdown the laptop by pressing the power button for some seconds.

Thanks in advance for the help! cheers!

It is quite well-known, or should be in any case, that there are multiple problems with Wayland, and it’s in my opinion at least, not nearly ready for prime-time. Especially with KDE.

So I’m thinking that’s the cause of this. In my opinion, it shouldn’t be used if you want, or require stability and no glitches. If that’s you, I recommend switching back to X11. Otherwise, continue using it, file bugs for it so that it can get developed, but know there’s going to be issues.

1 Like

I would like to try to go ahead with wayland, however do you know to what repos can I submit my findings. (i.e. KDE Plasma, wayland, systemd or what?)

Thanks @Mirdarthos

I have absolutely no idea where you can provide the feedback. Maybe @bogdancovaciu can help with that.

1 Like

This is a known bug with SDDM:

As to other issues, I experienced it too on Wayland, so I guess those are bugs too, but I don’t know if they are reported.

I am impressed with the state of Wayland on Plasma, but those shutdown/suspend glitches, plus the crash issue that I described in my topic Wayland on Plasma 5.27 make Wayland still not usable for a serious work. Wayland needs another year or more.

Basically, Plasma is Wayland ready, but Wayland itself is not ready.

Add to this the problem of streaming the desktop. There are special apps that can do that, but that is not enough. TeamViewer, Teams, Zoom and many other apps that we require for work, don’t offer desktop sharing in Wayland, and I’m afraid, some of them won’t offer it ever, unless there will be workarounds on Linux side.

This is why, I returned to X11, which is sad, because I enjoyed some Wayland perks.

Today I switched back to Xorg.
I confirm that there was a strange “streaming” problem, but not related to those programs that you cited, but related to switching virtual desktops. For instance, if I would watch a youtube video, stream it on the tv and change the virtual desktop, the frame rate would drop dramatically. The same thing would happen with my laptop being plugged in to electricity, configured to not suspend when the lid is down.

There are a lot of details to polish with wayland, however I felt that the system graphically was more responsive than xorg. But I am not sure if it was just a fake feeling due to the new shiny wayland configuration.

I used “streaming” in quite different way. I meant “capturing and sending picture/video from our desktop”. Streaming to our computer works fine.

When you use Team Viewer, it shows an info: “Wayland session detected. Inbound connections are a beta feature” - or something like that. Outbound connections are not supported yet. I assume, the same is for most of the app that are sharing our desktop. I hope this will change in time. OBS for example introduced Wayland support, but it’s not as smooth as it should be, because you often need additional operations and commands in terminal to make it work:

I also don’t think that Microsoft will be rushed to introduce this feature to Teams.

I found out that Zoom did introduced Wayland support since 5.11.1, so slowly things are getting better. However, there are tons of software that use that feature, and they are slow to implement Wayland, so we have to be weary of it. On X11 we just expect them to work, on Wayland it’s not so obvious. In a few years this should be fixed as more users will be on Wayland.