Mouse stops, computer freezes

yesterday I installed manjaro-gnome-24.0-240513-linux69 via usb stick on my old MacBook Pro (2010, 2,4 GHZ Intel core i5, 8GB DDR, Intel hd graphics 288 MB). This has worked so far Aires, but the mouse pointer (touchpad) keeps hanging up and the whole computer freezes.

1st mouse connected with usb cable, unfortunately the same effect
2. old kernel 5.4 installed, unfortunately no change

What else could I do, do you have any ideas?

1 Like

Hello @IdEBugla and welcome :wink:

Take a look at

and provide some substantial information, so that the community is able to help and there is no guesswork based on scant information.

It’s the graphics, your Intel hd graphics aren’t up to such a sophisticated desktop as Gnome. Try Xfce, it will run fine. Best start with the minimal edition and add what you need.

To make sure you don’t run into similar issues there check Control Centre >> Window Manager Tweaks >> Compositor. Remove as many eye candy features as possible (maybe leave the top 1 or 2 on) and set transparency sliders to ‘opaque’ and all should be well.

1 Like

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

I hope this helps. Cheers.

Try this, reboot and then report back:
sudo bash -c ‘echo “never” > /sys/kernel/mm/transparent_hugepage/defrag’

Thank you very much! I have installed Xfce and it works great.


1 Like

Thank you very much! I have installed Xfce and it works great.

ok, good, please mark this as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.