Mouse speed changed by itself(since 2016 till nowadays) on amd cpu and amd videocard

Fresh install archlinux/majaro/debian testing/debian stable. Play some games and mouse speed changed by itself and it feels very weird. Also it can be happend when you will start to record video with obs/ffmpeg with h264vaapi. This bug happends more frequently in archlinux. Then it less frequently happends in debian testing/manjaro. Then it les less frequently happends in debian stable. Also with installed amd-ucode(amd64-microcode) this bug happend more frequently. Even after installation cpu microcode mouse movements feels different compare to mouse movements without installation cpu microcode. I wrote about this bug at obs-studio github, xorg bug tracker/mailinig list, steam github. But no anwers. This bug happends from 2016/2017 year till nowadays. I thought that it can be bios related issue for my old am3+ rig(amd cpu and amd video card), cuz latest bios for my motherboard was too too old. But few weeks ago i switch to new am4 rig(amd cpu and amd video card) with latest bios and again i got this bug when mouse speed changed by itself. Almost 8 years i cant normally play games and with this bug even navigation in browser feels like a sh#$%^#$%t. I tested many linux distros(arch,manjaro,debian,ubuntu,mint,fedora,centos) with different DE and WM, use mesa opensource drivers amd proprietary drivers, use mouse accel archwiki, but no success.
But today i found how to reproduce this bug immediately:
1.Fresh install archlinux/manjaro/debian testing/debian stable with XFCE and default WM for XFCE. For archlinux/manjaro you need to install xorg-xinput
2.Open terminal, launch xinput, find id for your mouse under virtual core pointer tree
3.Launch xinput list-props “id of your mouse”
4.Save this output, esp watch to few options:
libinput Accel Speed (294): 0.000000
libinput Accel Speed Default (295): 0.000000
libinput Accel Profiles Available (296): 1, 1, 1
libinput Accel Profile Enabled (297): 1, 0, 0
libinput Accel Profile Enabled Default (298): 1, 0, 0
libinput Accel Custom Fallback Points (299):
libinput Accel Custom Fallback Step (300): 0.000000
libinput Accel Custom Motion Points (301):
libinput Accel Custom Motion Step (302): 0.000000
libinput Accel Custom Scroll Points (303):
libinput Accel Custom Scroll Step (304): 0.000000
5.Go to whisker menu->settings manager->mouse and touchpad->device tab
6.Choose your mouse in device list
7.Under pointer speed set acceleration to 0.0
8.Close mouse and touchpad settings
9.Move your mouse and remember how mouse feels, this mouse speed good for me and i always us it
10.Launch xinput list-props “id of your mouse”. Compare output from step 4 with this output and you will see that changed only this option:
libinput Accel Speed (294): -1.000000
11.Now we start how to manually fast reproduce bug with weird mouse movement
12.Launch xinput set-prop “id of your mouse” “libinput Accel Profile Enabled” 0 1 0
13.Your mouse almost didnt move if you will start to move
14.Launch xinput set-prop “id of your mouse” “libinput Accel Profile Enabled” 1 0 0
15.Now we have this “weird mouse speed”
16.launch xinput list-props “id of your mouse”. Compare this output with output from step 10. Those two outputs will be identical, but mouse moves will be different
17.After reboot system mouse speed feels normal like in step 9, but after few period of time this bug happends again. So reboot system is not solution when you play online games.

How it is possible that mouse with same settings moves differently? How mouse speed changed by itself?
How to fix this bug?

Please see

System info would make sense

inxi -Farz

And from a quick read

What do you mean?

amd proprietary drivers - official amdgpu-pro drivers for linux(ubuntu/rhel) from amd site.
new rig: ryzen 5 5600, msi b450m pro-vdh max, rx560 polaris
manjaro xfce stable branch, default out of the box, 6.6.26-1-MANJARO #1 SMP PREEMPT_DYNAMIC
Display: x11 server: Xorg v: compositor: xfwm4 v: 4.18.0
driver: X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa
dri: radeonsi gpu: amdgpu display-ID: :0.0 screens: 1
libinput 1.25.0-1
xf86-input-libinput 1.4.0-1

I use csm(bios legacy mode) and mbr partition table on my sata ide hdd

Hi @457man - Please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

Note that if you fail to present your posts in a more readable fashion (show more consideration), it’s doubtful you will receive much quality attention to your issues.


As it stands, your vague descriptions are not helping; you have a new system; your mouse speed has changed since 2016 (on this new system?) :man_shrugging:

Please tidy your posts to make them more readable, as this might encourage others to help. If you don’t know how to do that, please read through the links already given. You seem to be ignoring them completely.


and this is readable post

There are forum requirements to format various content in a more readable fashion - placing output from commands in a preformatted (and scrollable) text box, for example. This is what is meant by readable. You can easily edit your posts to change that.

Most people tend to not read great blobs of unformatted text, so it’s really in your best interest to tend to that; some Moderators might insist on it. You’re not a new forum user - you should already know all of this to be true.

I don’t use XFCE, and don’t recall exactly where the setting is, but there is usually a slider or similar to change the speed of mouse tracking. In KDE (for example) it’s under System SettingsMouse. You just need to find where a similar setting is XFCE.

All of your previous text dumps are likely irrelevant; but still, having them generally better presented would most likely be appreciated by anyone reading. How about some consideration for that, eh?


Any manajro maintainers with professional skills can help here?

Have a nice life.

Fact is:

  • you posted a wall of text, which is a pain in the butt to try and read
  • didn’t make an effort to format command output to be readable and distinct from normal text
  • didn’t give system info even after being asked

And, unfortunately, you where not successful in conveying what your issue is.
Some transition between “weird” mouse speed to what you like - and the speed setting changing without you doing anything to cause it.

All posts/threads is a wall of text do you understand it?

You better get some air and come back when you have cooled down.

I want to help - I stared five minutes at your description (which IS hard to read)
and tried to understand your xinput list-props examples
(even harder to read - it’s terminal output, not formatted as such)

I can’t replicate what you where doing - partly because I only have two profiles, not three, like you:

xinput list-props 10
Device 'Logitech Wireless Receiver Mouse':
	Device Enabled (177):	1
	Coordinate Transformation Matrix (179):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (316):	0
	libinput Natural Scrolling Enabled Default (317):	0
	libinput Scroll Methods Available (323):	0, 0, 1
	libinput Scroll Method Enabled (324):	0, 0, 0
	libinput Scroll Method Enabled Default (325):	0, 0, 0
	libinput Button Scrolling Button (326):	2
	libinput Button Scrolling Button Default (327):	2
	libinput Button Scrolling Button Lock Enabled (328):	0
	libinput Button Scrolling Button Lock Enabled Default (329):	0
	libinput Middle Emulation Enabled (330):	0
	libinput Middle Emulation Enabled Default (331):	0
	libinput Accel Speed (332):	0.000000
	libinput Accel Speed Default (333):	0.000000
	libinput Accel Profiles Available (334):	1, 1
	libinput Accel Profile Enabled (335):	1, 0
	libinput Accel Profile Enabled Default (336):	1, 0
	libinput Left Handed Enabled (318):	0
	libinput Left Handed Enabled Default (319):	0
	libinput Send Events Modes Available (301):	1, 0
	libinput Send Events Mode Enabled (302):	0, 0
	libinput Send Events Mode Enabled Default (303):	0, 0
	Device Node (304):	"/dev/input/event4"
	Device Product ID (305):	1133, 50498
	libinput Drag Lock Buttons (320):	<no items>
	libinput Horizontal Scroll Enabled (321):	1
	libinput Scrolling Pixel Distance (337):	15
	libinput Scrolling Pixel Distance Default (338):	15
	libinput High Resolution Wheel Scroll Enabled (322):	1

and have never experienced the mouse speed change on me for no apparent reason.

And I watched you lose your temper.

I won’t, not anymore.
I wasted too much of mine already.

Additionally, I found the following which may help. These show the mouse settings available in XFCE4:

This is probably the best I can do for you, given the information provided.

For the record, it wasn’t me that hid your post(s).

However, some other community member clearly found your content to be offensive or otherwise inappropriate. This might be something you should take into consideration, going forward. Cheers.