Mntray is disappearing from the system tray

I have noticed that ‘mntray’ keeps getting disappeared from the system tray. All other system tray icons remain as usual. After clicking mntray from the application menu of Gnome nothing happens.

If I write mntray in the terminal it says that it is already running.

I tried reinstalling mntray but nothing happens.

I also tried disabling other extensions. But still, the problem persists.

‘mntray’ is not something which is super important for me. But it is unique to manjaro gnome and so I wish to see it fixed and working flawlessly like before.

1 Like

Hmm, maybe you have set to hide itself when there is no news available?

Could you post the output of:

cat ~/.config/mntray/settings.json
{
	"Version": "1.1.2",
	"ServerURL": "http://manjaro.moson.eu:10111/news",
	"MaxArticles": 5,
	"AvailableCategories": [
		"Testing Updates",
		"Stable Updates",
		"Stable Staging Updates",
		"Unstable Updates",
		"Twitter",
		"News",
		"Releases",
		"ARM News",
		"ARM Releases",
		"ARM Stable Updates",
		"ARM Testing Updates",
		"ARM Unstable Updates"
	],
	"Categories": [
		"All"
	],
	"AddCategoriesBranch": [],
	"RefreshInterval": 500,
	"HideNoNews": false,
	"Autostart": true,
	"ErrorNotifications": true,
	"DelayAfterStart": 60,
	"SetCategoriesFromBranch": true
}%

Hmm, that looks ok actually.
I don’t use gnome and I must admit that I did not test it in all manjaro flavours lately.
I’ll see if I can check it in a VM.

edit
Does it disappear after a while or is not even showing up at all?

1 Like

It started disappearing recently. It does not show up at all. (After logging in)

I just deleted the config files and I deleted all temp files just now then reinstalled mntray.

It is now showing up again. But I did the same thing a week ago when it first started disappearing. It worked as usual for a week. Today it disappeared again.

edit
After logging out and logging in, it no longer shows up again.

1 Like

hmm strange.
Does it show up when you do:

killall mntray && mntray

After giving that command in terminal mntray shows up.

Closing the terminal and then clicking mntray from the application menu and restarting it also works then.

But then again if I log out and log in, it stops showing up again.

I’ve tried to reproduce it on a fresh Gnome VM (stable branch), but I can’t.
For me it always show up, also after logging out and in again.

1 Like

I am sharing this. If you watch it, you will see the problem. I kept the mntray at default settings.

1 Like

For me, I didn’t get any news, I only get the error messages in the notification.
Screenshot from 2020-10-18 23-46-51

1 Like

I understand your problem. However I cannot reproduce it on my end.
Are you using some additional gnome extensions or something? (I see the “moon” icon thing is showing twice?)

@man_user
Different issue it seems. Could you make another thread for it?..

1 Like

One moon icon seen in the system tray is the Default Night Theme Switcher extension which I turned on.

Another moon icon is actually Gnome night light.

I use a clipboard indicator, internet speed meter and a cut off monitor extension.

But I already tried to solve the problem by disabling all those three extensions and it didn’t work.

Hmm, I’m pretty much out of ideas.
Do you have KStatusNotifierItem/AppIndicator Support enabled?

There seem to be two startup files also in the latest package, could you try:

sudo rm /etc/xdg/autostart/mntray.desktop

I just tried what you suggested and it didn’t help, I guess.

I am literally out of ideas too. :sweat_smile:

Current situation:

In a normal boot, mntray starts normally. If I reboot, mntray starts normally.
If I logout and log in, mntray does not autostart.

1 Like

Do have some “auto-save-session” thing active maybe (does this even exist in gome) ?

Maybe try to add a startup delay like this (make sure /etc/xdg/autostart/mntray.desktop file is gone):

echo "X-GNOME-Autostart-Delay=10" >> ~/.config/autostart/mntray.desktop
1 Like

made sure /etc/xdg/autostart/mntray.desktop file is gone.

then did the echo one.

After that logged out and in. And mntray autostarted.

Then again logged out and logged in. Mntray didn’t autostart.

I am sorry. I think my problem is too unique. It is not solvable at this moment.

@MDIntisar,
I was checking your ~/.config/mntray/settings.json file and found % in the last line after }. Can you remove that and restart mntray.

.....
"ErrorNotifications": true,
"DelayAfterStart": 60,
"SetCategoriesFromBranch": true
}%     <---------

Hope this will solve :sweat_smile:

Sorry. But I had already deleted all config files and then reinstalled mntray. But it didn’t solve the problem.