Missing boot/vmlinuz-5.10-x86

I was dumb and interrupted my laptop while it was updating and on restart I’m missing ‘/boot/vmlinuz-5.10-x86-64’.
I tried the fix here: Boot file not found
and it didn’t seem to fix the problem. I’m just looking to get my System back and working with all of my files intact.

1 Like

I followed this guide, 3 times. It now only boots to memtest and loading grub menu on startup only shows memtest as an option. I’m so lost rn. Also apparently update-grub was not recognized as a valid command when trying all 3 times. I would like to add that there is very much a chance I did something wrong as well as I tried another command that supposedly also updates grub the second time around.

If you would tell us
(by posting the commands that you used along with their output)
we could likely spot where something went not as planned or intended
and point to appropriate action.

That command is provided by the package of the same name.
If it is not installed for some reason - install it:
pacman -Syu update-grub

It is not really needed - what it does is:

mkinitcpio -P
grub-mkconfig -o /boot/grub/grub.cfg

Without knowing what you did we have no way to help/correct.

1 Like

The above howto didn’t work for me either, had to reinstall my kernels. While chrooted list them:
mhwd-kernel li
and reinstall them (replace XXX and YYY with the versions listed)
pacman -S linuxXXX linuxYYY
then I reinstalled grub completely. For more see: Manjaro disappeared from grub after botched update - #2 by 6x12 .

not adequate - the kernel will be installed with:

but the initrd is still missing - and the grub configuration is not updated

update-grub would do this


Why not:
mhwd-kernel -i linux_xyz
the Manjaro way to install kernels

This should be all that is needed if the file system is not btrfs.
(same link as in the first post)

Whatever the case may be - we need commands and their output to spot what might not have worked.


then I reinstalled grub completely

Check the linked post; worked for me and was marked as a solution by others…

I didn’t - partly because this is not the topic of this here post/thread.
… but I will …

Reinstalling Grub is something quite different from updating it’s configuration
so it can show and boot the initrd/kernel …

This is not something that will be missing after an interrupted update.
The initrd and the kernel will be missing - Grub itself is untouched by this.

I ran this:

sudo grub-mkconfig -o /boot/grub/grub.cfg (without the “mkinitcpio -P” you mentioned)

in replacement of the update-grub command the second time I think. As it has been a bit, and I have restarted since then, I do not know what its output was. But all I know is that doing that in combination with the other commands mentioned in the [HowTo] caused it to only have memtest on grub and startup.
As far as I am aware, other than that second attempt, I followed the guide exactly, even to the point of copy/pasting every single command to make sure I didn’t accidentally misspell something or forgot to add a character somewhere.

No no no.
You used chroot (manjaro-chroot)

Something might already have gone south at this point.

We need the complete procedure.

you are (supposedly) in chroot

This means:
sudo is not required - you are already root (in chroot …)

Repeat the process, document it.
If you want meaningful help.

Why? Why would you leave that out?
This is what generates the initrd.
Leave it out and you’ll have none.

Install update-grub (if it is missing) - and you won’t have to deal with the more complicated procedure.

As already said:
complete procedure …


It wasn’t included as a part of the command when I saw it. I would’ve included otherwise.

if you, for some reason, do not have the update-grub command
you can’t leave it out.

This is, of course, not in the guide - because it assumes that update-grub is there.
It is easily installed - if it, for some reason, is not there.

I’m just explaining (or: trying to explain) what happens “behind the curtain” of the update-grub command.

It just finished. Is there anything in particular I should be looking for? Or should I just send the entire process?

I really have no idea about what you could possibly mean by saying this.

So: you are good?

very unclear message

My bad. I meant that the commands finished running.

and my suggestion was:
document what commands you where running - and the responses to them

We have no way to see what you see - no way to follow your path
except that you tell us
you did what the guide told you to do

you have feedback - we don’t

So should I look through the output for any red flags if something went wrong by looking at the output? Or should I restart my computer and see if it worked or not. I’m not sure what kind feedback I’m meant to be focusing on giving.

No - since you (obviously) did not spot any.

You should repeat the process - and provide the results.
So we can see what you saw.

It obviously didn’t yield the result you where hoping for.

You don’t know why.

And we can’t know because we can’t see what you saw (or did).

document the process - go through it again and document the inputs and results
at each step of the way.

You can’t figure it out … ok.

But how are we (others, not present at your computer) supposed to figure it out?
… if you don’t provide us with … what you see …?

We simply can’t help if we can’t see what is going on. :man_shrugging:

no focus neccessary - document everything :nerd_face:

So should I send the output of the commands?

that is what I said/suggested
didn’t I?

Go through the process again.
From the beginning.
Document it while you are going along the way.