Mhwd unable of finding the intel graphics card

using the command lspci, unable to see VGA of intel CPU
using the command mhwd -lh, unable to see it as well
however, using cat /proc/cpuinfo, the info is correct, it shows 11500 here

Hi @TheDishonored,

Please provide the output of:

mhwd --list

Also for all the commands you’ve run as well as the information asked for here: How to provide good information and, if applicable, see: [HowTo] post screenshots and links

Please remember to wrap any console output in three backtics (```), adding the three backtics before as well as after console pasted output. Like this:

```
pasted text
```

Alternatively, you can select it once pasted and click the </> button on the editor’s toolbar.

This just formats it properly for displaying.

1 Like
 mhwd --list
> 0000:01:00.0 (0300:10de:2208) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

so, the above one is the result of the mhwd --list.
Here is the mhwd -lh

                          TYPE            BUS   CLASS  VENDOR  DEVICE   CONFIGS
--------------------------------------------------------------------------------
            Network controller   0000:03:00.0    0200    10ec    8125         0
       Mass storage controller   0000:00:17.0    0106    8086    43d2         0
                        Bridge   0000:00:1c.0    0604    8086    43bc         0
     Generic system peripheral   0000:00:08.0    0880    8086    4c11         0
                        Bridge   0000:00:1f.0    0601    8086    4388         0
       Mass storage controller   0000:02:00.0    0108    144d    a809         0
                        Bridge   0000:00:01.0    0604    8086    4c01         0
            Network controller   0000:00:14.3    0200    8086    43f0         0
      Communication controller   0000:00:16.0    0780    8086    43e0         0
            Display controller   0000:01:00.0    0300    10de    2208         4
         Serial bus controller   0000:00:1f.5    0c80    8086    43a4         0
         Multimedia controller   0000:00:1f.3    0403    8086    43c8         0
                        Bridge   0000:00:00.0    0600    8086    4c53         0
                        Bridge   0000:00:1d.0    0604    8086    43b3         0
         Multimedia controller   0000:01:00.1    0403    10de    1aef         0
             Memory controller   0000:00:14.2    0500    8086    43ef         0
         Serial bus controller   0000:00:14.0    0c03    8086    43ed         0
         Serial bus controller   0000:00:1f.4    0c05    8086    43a3         0


> USB devices:
--------------------------------------------------------------------------------
                          TYPE            BUS   CLASS  VENDOR  DEVICE   CONFIGS
--------------------------------------------------------------------------------
                           Hub        1-9:1.0   10a00    05e3    0608         0
              Bluetooth Device       1-14:1.0   11500    8087    0026         0
                           Hub        1-0:1.0   10a00    1d6b    0002         0
                           Hub        2-0:1.0   10a00    1d6b    0003         0

The reason why I want to see intel graphics card, is because that I initially wanted to set xorg.conf to use the internal graphics card running the lightdm service, however, lspci command cannot see intel graphics card, therefore i assumed that this is because the lack of driver, so i checked the mhwd, and it still cannot see the internal graphics, here is lspci

 lspci
00:00.0 Host bridge: Intel Corporation Device 4c53 (rev 01)
00:01.0 PCI bridge: Intel Corporation Device 4c01 (rev 01)
00:08.0 System peripheral: Intel Corporation Device 4c11 (rev 01)
00:14.0 USB controller: Intel Corporation Tiger Lake-H USB 3.2 Gen 2x1 xHCI Host Controller (rev 11)
00:14.2 RAM memory: Intel Corporation Tiger Lake-H Shared SRAM (rev 11)
00:14.3 Network controller: Intel Corporation Tiger Lake PCH CNVi WiFi (rev 11)
00:16.0 Communication controller: Intel Corporation Tiger Lake-H Management Engine Interface (rev 11)
00:17.0 SATA controller: Intel Corporation Device 43d2 (rev 11)
00:1c.0 PCI bridge: Intel Corporation Tiger Lake-H PCI Express Root Port #5 (rev 11)
00:1d.0 PCI bridge: Intel Corporation Device 43b3 (rev 11)
00:1f.0 ISA bridge: Intel Corporation Device 4388 (rev 11)
00:1f.3 Audio device: Intel Corporation Tiger Lake-H HD Audio Controller (rev 11)
00:1f.4 SMBus: Intel Corporation Tiger Lake-H SMBus Controller (rev 11)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Tiger Lake-H SPI Controller (rev 11)
01:00.0 VGA compatible controller: NVIDIA Corporation GA102 [GeForce RTX 3080 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GA102 High Definition Audio Controller (rev a1)
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a809
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)

Intel is part of the video-linux driver package.

1 Like

Thanks, but why cannot I see it inside the lspci ? I need the pci num of internal graphics card to modify the xorg.conf file

You sure you have a iGPU?,I suspect there is no iGPU at all,that can happen if you have a high end laptop,those laptops usually don’t come with iGPUs.

That shows the CPU name,not really the GPU I think.

Then you must have disabled it on BIOS/UEFI level.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.