Videos stuttering/lagging in Chromium based browsers with radeon driver

Only Firefox plays the videos smoothly. Why do Chromium Browsers fail? Other Browser Videos play fine. I have a Radeon HD4250 Graphic Card using radeon driver.

The difference may be due enabled or disabled hardware acceleration. Check your browser settings.

works fine here (amdgpu, ungoogled-chromium)

If aragorns guess is right …

1 Like

Checked with enabled/disabled hw acceleration. Same issue…

Then maybe those videos don’t like the chromium rendering engine. It is possible. :man_shrugging:

Here, works just fine in chromium. Highest resolution, amd machine.
With and without hw-accelereation.

Tip: Install play-with-mpv-git from AUR (yes, from AUR sadly).
always good to have an alternative in linux, I’m using this for several years.

Checked with my laptop, with intel gpu (driver i915), videos working there.
So it must have something to do with radeon driver…and Chromium browsers?
But strange is, thats the only site in which videos stutter, other sites working fine.

If so, then this is unmistakenly tied to hardware acceleration. If acceleration is disabled, then the CPU does the rendering, and if it’s enabled, then the GPU does the rendering.

This would point to

but also sadly no longer up-to-date for stable branch . so he may compile himself.

1 Like

In that case, the adapted solution would be… :arrow_down:

rm -rf ~/.config/chromium/GrShaderCache
rm -rf ~/.config/chromium/ShaderCache
rm -rf ~/.config/chromium/Default/GPUCache

@ara, try this while chromium isn’t running. :point_up_2:

1 Like

No change. Same issue.

Tried play-with-mpv, but can’t get it working.

Try again, it’s working fine.

1 Like

It is something driver/acceleration related, not chrome related. I tested too

Device-1: Intel JasperLake [UHD Graphics] vendor: Lenovo driver: i915

and the chrome://gpu

Graphics Feature Status
Canvas: Hardware accelerated
Canvas out-of-process rasterization: Disabled
Direct Rendering Display Compositor: Disabled
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
OpenGL: Enabled
Rasterization: Hardware accelerated
Raw Draw: Disabled
Skia Graphite: Disabled
Video Decode: Hardware accelerated
Video Encode: Software only. Hardware acceleration disabled
Vulkan: Disabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated
WebGPU: Disabled

The videos on the site are working fine with about 60 % cpu load on the highest quality.

Great! Finally got it working with play-with-mpv. Forgot to install the browser extension.

This means nothing, only when playing a video in chromium, pressing ctrl+shift+i will give you a real answer if vaapi is “true”.

And where exactly can i see it? Inspection is not exactly easy to navigate.
I am at work now and only on mobile phone.
More tonight, if needed.

Some info for usage

Well, i the only thing i see is the FFMpegVideoDecoder
And the message

FFmpegDemuxer: created video stream, config codec: h264, profile: h264 high, level: not available, alpha_mode: is_opaque, coded size: [1920,1080], visible rect: [0,0,1920,1080], natural size: [1920,1080], has extra data: true, encryption scheme: Unencrypted, rotation: 0°, flipped: 0, color space: {primaries:BT709, transfer:BT709, matrix:BT709, range:LIMITED}

but is that software or hardware :person_shrugging: