Since a few days after the update of the Mesa/Vulkan drivers, Chromium-based browsers have been visually corrupted

I am not a chromium user, but I do have ungoogled-chromium as a secondary browser. I don’t see any difference here on Unstable…but… is there a setting for GPU acceleration in Chromium? I see hardware acceleration which is enabled, but I don’t see a setting for GPU specifically, nor do I have a clue which flag I would need in chrome://flags

I dont have any issues … but I am also on ungoogled chromium.
Plus using nonfree repo and a custom raven ridge 6.4 kernel.
So I’ve been missing out on most of the wonky fun recently.
For what its worth though that means that amdgpu on a mobile iGPU is working here with hw-accel.
vulkan is not enabled though.


It appears you already have your workaround … and since things have been a little bit funky with amd/kernel6+/mesa in unstable/testing … you might want to just keep using that and doing your updates for a little while.

greetings @all :smiley:

remove GPUCache from $Home/.config/chromium/Default/GPUCache

and the glitches will be gone !

" Die Realität ist eine Illusion, die durch Mangel an ehrlicher Kommunikation entsteht "


Then your Mesa package is out of date. @boredland hasn’t updated it in months and has not responded when I asked him about it.

It was a bit behind for a little bit…
But …
Current regular:


So it seems it was current until just a little bit ago.
And oddly ahead for the others.

NVM. Cached results.
nonfree is actually at:


So not behind at all

My point is it’s no longer updated and he doesn’t care. Keep using an outdated version of Mesa if you prefer.

Anyway, this discussion is completely off-topic for this thread.

And my point is I have been seeing updates…

$ pacman -Qi mesa
Build Date      : Thu 06 Jul 2023 06:34:50 AM

You dropped in to say something you now consider OT … is it unfair to respond?
This is a weird trend.

Release unstable-23.1.3-3: Merge pull request #32 from mesa-freeworld/upstream_master · mesa-freeworld/mesa-nonfree · GitHub ?

I think we should never have started supporting anything else then unstable. I lack the interest, because after using my amd machine for months, I just don’t see why anyone actually needs this.

Yes, 23.1.3 introduced some regressions there. 23.1.2 seems fine so far …

Thanks for the solution!

This has worked on Brave, Opera, and Edge. However, in Vivaldi, which is the one I use the most, this solution doesn’t work, even though I delete the files and see that they are recreated when I open Vivaldi again, the window is still completely corrupted…

I’ve already managed to fix it for Vivaldi, it’s been a bit more complicated than for the other Chromium browsers. I have found more information about the problem in the following links:

On the Fedora page it says to delete these directories:

rm ~/.config/google-chrome/GrShaderCache -rf
rm ~/.config/google-chrome/ShaderCache -rf
rm ~/.config/google-chrome/Default/GPUCache -rf

I have tried to do it for Vivaldi, but it still did not work, although I saw that it recreated the files in the directories, the window continued to show itself corrupted.

So, what I have tried to do is rename the $Home/.config/vivaldi directory with another name, so that Vivaldi would create the user directory again, since the links said that it worked.

Indeed, I saw that doing this Vivaldi opened fine, so what I did next was rename the new user directory that it created for me, rename the vivaldi directory that I had renamed before, leaving it as it was, and copy from the new user directory that it had created, the content of the 3 directories that I mentioned above, and with this it has already worked.

Thanks for your help!

EDIT: However, after several tests, although now the Vivaldi interface is displayed correctly, it still presents some glitches with the rendering of some web pages such as GMail or buttons that disappear as in this forum…

Sorry, it is up to date…now. I hadn’t looked in a few days.

No. I also participated in the off-topic discussion. I was just saying it was and I planned to refrain from continuing.

I wholeheated agree.

As for the topic at hand - I saw a problem with vivaldi.

I had to remove .cache/vivaldi and .config/vivaldi to fix the issue - and I played around a little using a backup and a fresh version - it seems to be theme issue - something changed with the vivaldi configuration - since it is based on chromium …

I fixed the similar problem with vivaldi:

$ rm -rf ~/.config/vivaldi/GrShaderCache
$ rm -rf ~/.config/vivaldi/ShaderCache 
$ rm -rf ~/.config/vivaldi/Default/GPUCache
$ rm -rf ~/.cache/vivaldi/*

After a lot of testing I found it to be (the exact foldername may differ for your system)

rm -r ~/.config/vivaldi/Default/Storage/ext/mpognobbkildjkofajifpdfhcoklimli/def/GPUCache
browzer=vivaldi; find ~/.config/"$browzer"/ -name 'GPUCache'

Initially I nuked the whole thing - but I wanted to know where, what and hopefully why.

You are quite right - but I didn’t know where or what - so I slow worked my self through my dysfunctional config - testing by copying know to work config over until I hit it


Thank you. This worked for me. Had the same browser glitch that @Alden20 mentioned.

Is this a permanent fix? Or does this folder need to be deleted from time to time?

I am using Brave browser.

you all are welcome, always :smile:

it happens from time to time @ man-jar-oh - so maybe yes.


This or something like it popped up again elsewheres …so heres a quick line to find possible agitators:

for i in {Shader,GPU}; do find ~/.config -name *"$i"Cache*; done