Manjaro hangs on boot - Started CUPS scheduler

Trying to boot into Manjaro Gnome and it hangs on ”[OK] Started CUPS scheduler.”

I don’t have any idea on what to do here. So help is greatly appreciated!

I am having the same issue after update a few days ago. The answer was in the old forums, but obviously that is gone :pleading_face:

The old forum is just archived

I managed to get through “Started CUPS scheduler” -message by doing either CTRL+ALT+F3 or F2. It opened TTY and then I just did CTRL+ALT+F1 and it let me sign into manjaro like I usually would.

I don’t know what this does or whether it has any negative effects but so far I haven’t noticed anything.

That worked for me as well, however having to do that on every boot is frustrating, perhaps someone is aware of a fix.

Glad to hear it worked. I certainly hope someone has a fix for this.

Alright, just did this and it fixed my problem

sudo pacman -Syu haveged
systemctl enable haveged --now
then reboot the system.

1 Like

I’ve never heard of haveged and couldn’t find much about it by googling. Are there any downsides on running it?

I haven’t seen any thus far. It hasn’t fixed this permanently, about every 3rd or 4rth boot I run into the same problem. We are reviewing Manjaro for our Podcast these past few weeks. I shared this “kinda-fix” with my co-host that is also using the GNOME version and he is having the same experience. This really seams to be a GNOME issue. It would be nice to get some feedback from the Devs on this. I hate to let it effect the review.

Hey guys, I think I found the solution. Today I have updated my system’s kernel from 5.7.19-2 to 5.8.6-1, which caused that issue when the system was hanging at the "Started CUPS scheduler’ during the system boot. So I decided to dig a little bit deeper and went into the journalctl boot log. it appeared that “nvidia” and “nvidia-drm” modules couldn’t be found for that new kernel. So, I simply reinstalled the nvidia driver while I was in the text mode and after the reinstallation, I literally was automatically booted into the SDDM.

You can check the log with the modules being not found by the system like this:

journalctl -b | grep 'Failed to find module'

I have Virtualbox installed, so I have a couple of related modules needed to be reinstalled for that app as well.

Here what I actually did:

mhwd -li -d --pci   # checking what video driver is currently installed (in my case it was "video-nvidia-450xx"
sudo mhwd -r pci video-nvidia-450xx   # removing the driver
sudo mhwd -i pci video-nvidia-450xx   # installing the driver (for my card it is currently the latest driver available)

For you, it may differ since it depends on what kind of driver you use (free/non-free) and what kind of video card vendor you have.

The console output is a bit misleading - in reality it is the last message printed you see - a lot can have happened after that - so you really have to at the logs - it’s the only way of knowing.

Yea, good point, it is indeed better to look through the whole boot log. Well, at least I hope it might give some hints on what could happen. For me, it was just the video driver. Perhaps for someone it might be a bit different, maybe some more or even different modules missing or else.