Manjaro hanging from boot

Hello everyone. I finally got up the nerve to install a dual boot system. :slight_smile:

So I reformatted the hard drive on my older Lenovo laptop, created two partitions, installed Windows in one and Manjaro Gnome in the other. All went well. Grub shows up, Windows boots, but Manjaro hangs at “Console: switching to colour frame buffer device…”. The Live system booted fine with the proprietary drivers (it didn’t with the open source ones).

I tried rebooting the live system and chrooting into the live system and reinstalling the proprietary drivers, but it says they are already installed.

I also tried adding nomodeset to the linux line of the boot loader.

I also tried the alternative “- fallback initramfs” option, with the same problematic result.

SecureBoot is disabled in the BIOS, as is Fast Boot from Windows.

All to no avail.

Just for fun, I installed Linux Mint. It worked perfectly. Now I could stick with that, but after much searching I was really hoping Manjaro would be “the one” :slight_smile:

I hope you can help me in some way.

Just for fun, why not try Manjaro KDE Plasma, instead?

Fair enough. I can try that. Just would prefer Gnome.

Will KDE Plasma make a difference in the boot process, though? If so, what could be the issue with the Gnome version?

I don’t know; there are many potential possibilities for a boot failure. Normally, nobody can begin to take a guess until they have at least seen some logs, and have a good idea of your environment. Sometimes clumsy mistakes during install can be a cause; the list goes on. I will note though, that I see more issues with a Nvidia-Gnome combination, than much else.

Exactly, how old is the laptop (out of curiosity)?

Some information might help others;

inxi --admin --verbosity=8 --filter --no-host --width

and logs from after a failure to boot:

journalctl --boot=-1 --priority=3 --catalog --no-pager

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

I hope this helps. Cheers.

Thanks for the tips.

First things first: I installed the KDE version. Same issue. So I tried to get the logs. I applied the advice “Append the runlevel 3 to the kernel boot line”. No effect. Stuck on the usual error.

I could find no logs anywhere in /var/log. All folders are empty, except a pacman.log.

Here is the system info I got from booting into the live system:

  12Kernel 6.6.25-1-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 13.2.1
    12clocksource tsc 12avail hpet,acpi_pm 12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64
    lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_KDE_2314 quiet systemd.show_status=1 splash
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  12Desktop KDE Plasma 12v ERR-101 12tk Qt 12v N/A 12dm N/A 12Distro Manjaro
    12base Arch Linux
  12Type Laptop 12System LENOVO 12product 20EGS15P00 12v ThinkPad W541 12serial <filter>
    12Chassis 12type 10 12serial <filter>
  12Mobo LENOVO 12model 20EGS15P00 12v SDK0E50510 WIN 12serial <filter>
    12part-nu LENOVO_MT_20EG 12uuid 779d6601-5472-11cb-a036-b2501a15da10
    12UEFI-[Legacy] LENOVO 12v GNET94WW (2.42 ) 12date 06/02/2021
  12ID-1 BAT0 12charge 47.7 Wh (99.6%) 12condition 47.9/56.2 Wh (85.2%) 12volts 12.5
    12min 10.8 12model SANYO 45N1159 12type Li-ion 12serial <filter> 12status not charging
  12Info 12model Intel Core i7-4810MQ 12socket rPGA988B (U3E1) 12note check 12bits 64
    12type MT MCP 12arch Haswell 12gen core 4 12level v3 12note check 12built 2013-15
    12process Intel 22nm 12family 6 12model-id 0x3C (60) 12stepping 3 12microcode 0x28
  12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 256 KiB
    12desc d-4x32 KiB; i-4x32 KiB 12L2 1024 KiB 12desc 4x256 KiB 12L3 6 MiB 12desc 1x6 MiB
  12Speed (MHz) 12avg 800 12min/max 800/3800 12base/boost 2800/2800 12scaling
    12driver intel_cpufreq 12governor schedutil 12volts 0.8 V 12ext-clock 100 MHz 12cores
    121 800 122 800 123 800 124 800 125 800 126 800 127 800 128 800 12bogomips 44719
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Type gather_data_sampling 12status Not affected
  12Type itlb_multihit 12status KVM: VMX disabled
  12Type l1tf 12mitigation PTE Inversion; VMX: conditional cache flushes, SMT
  12Type mds 12mitigation Clear CPU buffers; SMT vulnerable
  12Type meltdown 12mitigation PTI
  12Type mmio_stale_data 12status Unknown: No mitigations
  12Type reg_file_data_sampling 12status Not affected
  12Type retbleed 12status Not affected
  12Type spec_rstack_overflow 12status Not affected
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer
  12Type spectre_v2 12mitigation Retpolines, IBPB: conditional, IBRS_FW, STIBP:
    conditional, RSB filling, PBRSB-eIBRS: Not affected
  12Type srbds 12mitigation Microcode
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel 4th Gen Core Processor Integrated Graphics 12vendor Lenovo
    12driver i915 12v kernel 12arch Gen-7.5 12process Intel 22nm 12built 2013 12ports
    12active eDP-1 12empty DP-1, DP-2, HDMI-A-1, HDMI-A-2, VGA-1 12bus-ID 00:02.0
    12chip-ID 8086:0416 12class-ID 0300
  12Device-2 NVIDIA GK106GLM [Quadro K2100M] 12vendor Lenovo 12driver nvidia
    12v 390.157 12alternate nouveau,nvidia_drm 12non-free 12series 470.xx+
    12status legacy-active (EOL~2024-09-xx) 12arch Kepler 12code GKxxx
    12process TSMC 28nm 12built 2012-2018 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 16
    12link-max 12gen 3 12speed 8 GT/s 12bus-ID 01:00.0 12chip-ID 10de:11fc 12class-ID 0300
  12Device-3 Lite-On Integrated Camera 12driver uvcvideo 12type USB 12rev 2.0
    12speed 480 Mb/s 12lanes 1 12mode 2.0 12bus-ID 3-12:5 12chip-ID 04ca:7035 12class-ID 0e02
  12Display 12server 12v 12with Xwayland 12v 23.2.5 12driver 12gpu i915
    12display-ID :0
  12Monitor-1 eDP-1 12model BOE Display 0x08e7 12built 2019 12res 1920x1080 12dpi 142
    12gamma 1.2 12size 344x193mm (13.54x7.6") 12diag 394mm (15.5") 12ratio 16:9
    12modes 1920x1080
  12API EGL 12v 1.5 12hw 12drv intel crocus 12platforms 12surfaceless 12drv crocus
    12inactive gbm,wayland,x11
  12API OpenGL 12v 4.6 12vendor mesa 12v 24.0.2-manjaro1.1 12note incomplete (EGL
    sourced) 12renderer Mesa Intel HD Graphics 4600 (HSW GT2)
  12API Vulkan 12Message No Vulkan data available.
  12Device-1 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 12vendor Lenovo
    12driver snd_hda_intel 12v kernel 12bus-ID 00:03.0 12chip-ID 8086:0c0c 12class-ID 0403
  12Device-2 Intel 8 Series/C220 Series High Definition Audio 12vendor Lenovo 8
    12driver snd_hda_intel 12v kernel 12bus-ID 00:1b.0 12chip-ID 8086:8c20 12class-ID 0403
  12Device-3 NVIDIA GK106 HDMI Audio 12vendor Lenovo 12driver snd_hda_intel
    12v kernel 12pcie 12gen 1 12speed 2.5 GT/s 12lanes 16 12link-max 12gen 3 12speed 8 GT/s
    12bus-ID 01:00.1 12chip-ID 10de:0e0b 12class-ID 0403
  12API ALSA 12v k6.6.25-1-MANJARO 12status kernel-api 12with aoss 12type oss-emulator
    12tools alsactl,alsamixer,amixer
  12Server-1 JACK 12v 1.9.22 12status off 12tools N/A
  12Server-2 PipeWire 12v 1.0.3 12status off 12with 121 pipewire-pulse 12status off
    122 wireplumber 12status off 123 pipewire-alsa 12type plugin
    12tools pactl,pw-cat,pw-cli,wpctl
  12Device-1 Intel Ethernet I217-LM 12vendor Lenovo 12driver e1000e 12v kernel
    12port 5080 12bus-ID 00:19.0 12chip-ID 8086:153a 12class-ID 0200
  12IF enp0s25 12state down 12mac <filter>
  12Device-2 Intel Wireless 7260 12driver iwlwifi 12v kernel 12pcie 12gen 1
    12speed 2.5 GT/s 12lanes 1 12bus-ID 03:00.0 12chip-ID 8086:08b2 12class-ID 0280
  12IF wlp3s0 12state down 12mac <filter>
  12IF-ID-1 wwp0s20u10 12state down 12mac <filter>
  12Info 12services No services found.
  12Device-1 Intel Bluetooth wireless interface 12driver btusb 12v 0.8 12type USB
    12rev 2.0 12speed 12 Mb/s 12lanes 1 12mode 1.1 12bus-ID 3-11:4 12chip-ID 8087:07dc
    12class-ID e001
  12Report rfkill 12ID hci0 12rfk-id 2 12state down 12bt-service N/A 12rfk-block
    12hardware no 12software no 12address see --recommends
  12Local Storage 12total 462.03 GiB 12used 8.5 GiB (1.8%)
  12ID-1 /dev/sda 12maj-min 8:0 12vendor Leven 12model JAJS300M480C 12size 447.13 GiB
    12block-size 12physical 512 B 12logical 512 B 12sata 3.3 12speed 6.0 Gb/s 12tech SSD
    12serial <filter> 12fw-rev SC6A 12temp 47 C
  12SMART yes 12state enabled 12health PASSED 12on 273d 11h 12cycles 1866
    12read 255.3 MiB 12written 237.8 MiB
  12ID-2 /dev/sdb 12maj-min 8:16 12vendor Kingston 12model DataTraveler 2.0
    12size 14.9 GiB 12block-size 12physical 512 B 12logical 512 B 12type USB 12rev 2.0
    12spd 480 Mb/s 12lanes 1 12mode 2.0 12tech N/A 12serial <filter> 12fw-rev 1.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 251.77 GiB 12size 246.76 GiB (98.01%) 12used 8.5 GiB (3.4%)
    12fs ext4 12block-size 4096 B 12dev /dev/sda4 12maj-min 8:4
  12Alert No swap data was found.
  12System Temperatures 12cpu 52.0 C 12mobo N/A
  12Fan Speeds (rpm) 12fan-1 1611
  12Memory 12total 32 GiB 12note est. 12available 30.99 GiB 12used 1.86 GiB (6.0%)
    12igpu 32 MiB
  12Processes 0 12Power 12uptime 6m 12states freeze,mem,disk 12suspend deep
    12avail s2idle 12wakeups 0 12hibernate platform 12avail shutdown, reboot, suspend,
    test_resume 12image 12.37 GiB 12Init systemd 12v 255 12default graphical
    12tool systemctl
  12Packages 12pm pacman 12pkgs 1158 12libs 354 12tools pamac 12pm flatpak 12pkgs 0
    12Compilers 12clang 16.0.6 12gcc 13.2.1 12Client systemd 12inxi 3.3.33

Anything else I can provide?

Thank you for taking the time. :slight_smile:

Mount the drive (anyway you can, and live boot works), and use systemctl --directory /mnt/var/log/journal

I put in line numbers from from a hard reset boot, to give you an idea where it comes up in mine. (Over 1500 entries later.)

  1556  Apr 20 23:05:49 mbox systemd[1]: Starting Create Volatile Files and Directories...
  1557  Apr 20 23:05:49 mbox systemd[1]: Received SIGRTMIN+20 from PID 352 (plymouthd).
  1558  Apr 20 23:05:49 mbox systemd[1]: Finished Tell Plymouth To Write Out Runtime Data.
  1559  Apr 20 23:05:49 mbox kernel: fbcon: Taking over console
  1560  Apr 20 23:05:49 mbox kernel: Console: switching to colour frame buffer device 135x120
  1561  Apr 20 23:05:49 mbox systemd[1]: systemd-vconsole-setup.service: Deactivated successfully.
  1562  Apr 20 23:05:49 mbox systemd[1]: Stopped Virtual Console Setup.
  1563  Apr 20 23:05:49 mbox systemd[1]: Stopping Virtual Console Setup...
  1564  Apr 20 23:05:49 mbox systemd[1]: Starting Virtual Console Setup...
  1565  Apr 20 23:05:49 mbox systemd[1]: Finished Virtual Console Setup.
  1566  Apr 20 23:05:49 mbox systemd[1]: Finished Create Volatile Files and Directories.
  1567  Apr 20 23:05:49 mbox systemd[1]: Mounting RPC Pipe File System...

Also, what’s your mhwd -l and lsmod? And what model Lenovo?

I think that’s the wrong driver, you should be using, see here: [SOLVED] Trouble Using NVIDIA Optimus / K2100M as primary X11 GPU / Newbie Corner / Arch Linux Forums

The simplest possibility is often overlooked. How did you create the Installer? It might have not been written correctly (if written to USB). The ISO itself may have suffered during download (did you check it?).

Generally I’d recommend creating a Ventoy USB to install an OS (the ISO is simply copied/dragged to the Ventoy USB instead of writing it).

sudo pacman -S ventoy
# type `ventoy` for usage.

I would typically use a command similar to this when creating the USB:

sudo sh ventoy -i -r 100 -S -g -L VOLUME /dev/sdX
  • Substitute VOLUME for a volume label name to use.
  • Substitute /dev/sdX for the location of your USB device.
  • Preserve some space on the target device (example allows 100mb).

Thank you all for the tips. Will definitely give this a shot.

Version 418.113 appears to be the last official Nvidia driver to support the Quadro K2100M, so the AUR is as good a guess as any - it may (or may not) still have some support for it. Using the official Nvidia driver installer might reap some results, but doing so isn’t ideal. Using a much older kernel might also be promising, if the OP would be happy using Nouveau. :man_shrugging: