Manjaro freezes and overheats [2]

I have installed manjaro a few weeks ago on a new partition. It worked very well at the beggining but after a day weeks it started getting very slow, and I couldnt play any games after - the CPU was at high capacity, it was very slow/ low FPS on a (reasonably heavy) browser game, and the temperature was high (reaching 100degrees celsius by the monitor).

THis is an old laptop but it used to run very well. 6GB ram, good intel graphics. It is an intel i5 which used to run perfectly well some games [i used to use elementary os].
After i installed manjaro, it gets 1) very hot (temperature reaching 100c when running a heavy browser game), 2) very slow, and 3)CPU at high capacity.

I have read so much about all kinds of possible solutions dealing with cooling fans on my laptop (supposedly thats the issue? [specially because heat+i cant hear the cooling fan work]), but absolutely nothing works.
I have tried changing kernels (installing it, on boot screen changing the one Im going to use, etc.), didnt work.
I have tried TLP, POWERTOP, LMSENSORS, PWMCPONFIG, everything.

At PWMCONFIG, i reach a point where it says: “/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed”. I have tried a possible solution (" fancontrol-under-ubuntu-14-04-resolving-usrsbinpwmconfig-there-are-no-pwm-capable-sensor-modules-installed "), didnt work to.

MY elementary os (in the another partition) got slow as well after this issue arrived.
I have tried to fix it in elementary os, but got nothing new too.

Is it due to manjaro not ‘‘geting my cooler to work’’?
COuld it be a coincidental hardware issue? (for instance, laptop fan suddenly not working…?)

When I typed “inxi -F -x -G -xx -S”, it said: Sensors:
System Temperatures: cpu: 62.0 C mobo: N/A
Fan Speeds (RPM): N/A

PS: I cant see if it works, I dont know how to open a laptop and I think this is not a likely scenario.
PS: right now, after i tried to configure TLP, it runs at around 50-66 with daily use (browser, notepad, etc.). I think it solved a little bit of the heat issue (it was higher on average), but i just dont see this as a solution. It feels like im just trying to make my laptop slow down, when I think there’s an issue and I want to try to solve this issue.
I cannot play anymore in this laptop, and If i try to run a game, it gets to 80-100 degrees.

Thank you! Which part of it would you like me to transcribe in detail? I didnt want to make this text too long, so I summed it up the essentials.

Start with inxi -Fazy

C

    [gabriel@gabriel-ne56r ~]$  inxi -Fazy
    System:
      Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
      parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
      root=UUID=94b98c23-cda4-4767-8e61-0df4d0001931 rw quiet 
      acpi_enforce_resources=lax 
      Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: plank wm: kwin_x11 dm: SDDM 
      Distro: Manjaro Linux 
    Machine:
      Type: Laptop System: Gateway product: NE56R v: V2.16 serial: <filter> 
      Chassis: Insyde Corp. type: 10 v: 2.16 serial: <filter> 
      Mobo: Gateway model: EG50_HC_CR v: Type2 - Board Version serial: <filter> 
      UEFI [Legacy]: Insyde v: 2.16 date: 06/11/2013 
    Battery:
      ID-1: BAT1 charge: 15.9 Wh condition: 15.9/47.5 Wh (33%) volts: 12.2/10.8 
      model: SANYO Li_Ion_4000mA type: Li-ion serial: <filter> status: Full 
    CPU:
      Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
      arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
      L2 cache: 3072 KiB 
      flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20756 
      Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1197 
      3: 1197 4: 1196 
      Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
      Type: l1tf 
      mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
      Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
      Type: meltdown mitigation: PTI 
      Type: spec_store_bypass 
      mitigation: Speculative Store Bypass disabled via prctl and seccomp 
      Type: spectre_v1 
      mitigation: usercopy/swapgs barriers and __user pointer sanitization 
      Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
      IBRS_FW, STIBP: conditional, RSB filling 
      Type: srbds status: Vulnerable: No microcode 
      Type: tsx_async_abort status: Not affected 
    Graphics:
      Device-1: Intel 3rd Gen Core processor Graphics 
      vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
      chip ID: 8086:0166 
      Device-2: Chicony type: USB driver: uvcvideo bus ID: 1-1.3:3 
      chip ID: 04f2:b374 
      Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
      unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
      Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 338x190mm (13.3x7.5") 
      s-diag: 388mm (15.3") 
      Monitor-1: LVDS1 res: 1280x720 hz: 60 dpi: 96 size: 340x190mm (13.4x7.5") 
      diag: 389mm (15.3") 
      Monitor-2: HDMI1 res: 1280x720 hz: 60 dpi: 20 size: 1600x900mm (63.0x35.4") 
      diag: 1836mm (72.3") 
      OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
      v: 4.2 Mesa 20.1.8 compat-v: 3.0 direct render: Yes 
    Audio:
      Device-1: Intel 7 Series/C216 Family High Definition Audio 
      vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
      bus ID: 00:1b.0 chip ID: 8086:1e20 
      Sound Server: ALSA v: k5.8.11-1-MANJARO 
    Network:
      Device-1: Broadcom and subsidiaries NetLink BCM57785 Gigabit Ethernet PCIe 
      vendor: Acer Incorporated ALI driver: tg3 v: kernel port: 2040 
      bus ID: 02:00.0 chip ID: 14e4:16b5 
      IF: enp2s0f0 state: down mac: <filter> 
      Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On 
      driver: ath9k v: kernel port: 2040 bus ID: 03:00.0 chip ID: 168c:0032 
      IF: wlp3s0 state: up mac: <filter> 
    Drives:
      Local Storage: total: 465.76 GiB used: 27.13 GiB (5.8%) 
      SMART Message: Unable to run smartctl. Root privileges required. 
      ID-1: /dev/sda vendor: Western Digital model: WD5000LPVX-22V0TT0 
      size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
      rotation: 5400 rpm serial: <filter> rev: 1A01 scheme: MBR 
    Partition:
      ID-1: / raw size: 188.72 GiB size: 184.76 GiB (97.90%) 
      used: 27.13 GiB (14.7%) fs: ext4 dev: /dev/sda2 
    Swap:
      Alert: No Swap data was found. 
    Sensors:
      System Temperatures: cpu: 72.0 C mobo: N/A 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 224 Uptime: 13h 58m Memory: 5.63 GiB used: 1.54 GiB (27.4%) 
      Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1339 pacman: 1328 
      lib: 358 flatpak: 6 snap: 5 Shell: Bash v: 5.0.18 running in: konsole 
      inxi: 3.1.05 
    [gabriel@gabriel-ne56r ~]$

Between 8 and 6 years old and:

Start at the basics first:

  • Buy a can of compressed air and blow out all of the holes (including in-between the keyboard keys, speakers, …)
    OR

  • Turn your vacuum machine to its lowest setting and then gently vacuum all holes as per above

  • See if your BIOS allows you to run the fans at max speed all of the time

  • provide the output of:

    lscpu | grep "CPU MHz"
    
  • run the following command while playing your game:

    watch --interval=5 "sensors | grep 'Core 0';lscpu | grep 'CPU MHz';free --human"
    
  • copy-paste the output if it goes above 90°C and stop the game.

  • report back here with the output you gathered in the step above.

:innocent:

1 Like

THank you for your detailed answer Fabby.
It is an old laptop, yea. I actually have just started using this one (with elementary os) after my family discarded it, but it was running perfectly fine.
I will post the results of your instructions now. BUt just FYI, i think there is a similar issue disccused in an arch linux topic called ‘’ [[SOLVED] Fan not working in Linux]’’, but his fan just randomly started working.

1.I feel a bit hesitant in regards to the compressed air/vacuum machine alternatives (i have neither at home, too), if I cannot make this laptop work out as before I might ask help for a computer technician.
2.I have tried looking into BIOS settings - I’ve heard there is an ‘‘update’’ option somewhere that could be helpful -, but there was no option available for me to either change fan settings or update it…

Now to your instructions:

  1. [gabriel@gabriel-ne56r ~]$ lscpu | grep “CPU MHz”
    CPU MHz: 1280.015
    CPU MHz máx.: 3200,0000
    CPU MHz mín.: 1200,0000

  2. run the following command while playing the game:
    A cada 5,0s: sensors | grep ‘Core 0’;lscpu | grep ‘CPU MHz’;free --human gabriel-ne56r: Wed Oct 7 17:50:00 2020

Core 0: +100.0°C (high = +87.0°C, crit = +105.0°C)
CPU MHz: 2991.805
CPU MHz máx.: 3200,0000
CPU MHz mín.: 1200,0000
total usada livre compart. buff/cache disponível
Mem.: 5,6Gi 1,9Gi 2,4Gi 377Mi 1,4Gi 3,2Gi
Swap: 0B 0B 0B

PS:
2 things came up temporally that preceded all this issue:

  1. I installed manjaro
  2. I had to use a very RAM-demanding process on an app (i installed a plugin on Anki, a flashcard app, to convert cards into pdf, but anyway i digress), and I had to set its priority as Very High or something, because my laptop wasnt handling it.
  3. Maybe i also updated graphci cards or something on manjaro settings, but that felt harmless on the moment, i dont know

Thank you again for your effort and patience

I do have to add: the same issue is happening on the other distribution, elementary os.
DO you think the most likely scenario is a hardware issue?

Could be.
I remember an old Dell that after it got some years on it just started to heat like no other.
To the point where it would stutter and lock.
Now I cant remember if it was anything particular like the nvidia card … that machine had met its end of life.

In your case, I do suggest a clean up like @Fabby mentioned above. Especially if its old and never had that kind of treatment, you might be surprised to find anything from a ton of dog hair to an ant colony in there :wink:


But of course there are more software avenues too, like TLP, thermald, and/or some of these power savings help with heat too:

3 Likes

Please do.

yep because this:

Doesn’t show anything from a software side.

I’m not saying you have an ant colony living in your laptop, but a second hand machine that has never had any maintenance? That’s like a second-hand car that has never had any maintenance. Please have it serviced or service it yourself.

:man_shrugging:

2 Likes

But if you do, this is a quick and easy solution:

(ok to be clear … jokes is jokes :slightly_smiling_face:)

3 Likes

Chiming in to say that while I did not have much dust inside of the laptop, my heatsink was clogged to the brim in dust and I ended up replacing the fan because not only had I broke it, it too ws also caked with dust. So yeah, open your laptop if you can, give the components a good clean with rubbing alcohol and be very careful through the whole process.

My laptop which was clearly not meant to be user-serviceable with its multitude of screws and tabs is still kicking along as good as it had, and better after a gentle cleaning to get the bulk of the dust off. Pro tip for laptop research: See how easy it is to disassemble before you buy.

Serviceability and maintenance should be primary factors in your purchases, not secondary!

3 Likes

Try servicing a Microsoft Surface Pro: You need to use an iron to iron clothes with on its hottest setting to melt the glue it’s been stuck together with!

:hot_face:

I also suffered from random freezing because of the new implemented I/O schedulers in new kernels which boost performance for new laptops with SSD. So try to use kernel 4.14 which has good I/O schedulers for old laptops.

That shouldn’t be a problem for future kernels, though if it is you should consider building your own. I don’t have an SSD and I am on 5.8.11-1.

I kinda doubt the IO schedulers were the thing … many work fine with either hardware … and I think most versions implement a dynamic udev rule like this:

# set scheduler for NVMe
ACTION=="add|change", KERNEL=="nvme[0-9]*", ATTR{queue/scheduler}="none"
# set scheduler for SSD and eMMC
ACTION=="add|change", KERNEL=="sd[a-z]|mmcblk[0-9]*", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="mq-deadline"
# set scheduler for rotating disks
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="1", ATTR{queue/scheduler}="bfq"

(so you get different schedulers for different devices)

But of course … also … you could always just change your scheduler instead of kernel.
I am not sure changing kernel alone would even do the same for you automagically … unless its such an old kernel that a modern scheduler is inoperable and thus it falls-back to some old default.
(which would also not be the way you want to do that)

2 Likes

I already posted a question here on old forum (I couldn’t found it), the problem is that the new kernels dropped a type of scheduler that was supported before 4.14 and there is no way to select it with new kernels, so changing to 4.14 resolved my problem with my old laptop with HDD.

1 Like

Guys, everyone, thank you for your effort to help me with this issue. I will definitely contact a technician to help me with the process.
I wont have this topic as ‘solved’ so that in a few weeks I can share any updates on that :slight_smile:

Hey medmedin, I did read about that, but i changed the kernel several times and it hasnt changed a thing. That feels like a weird options specially because it wwas working before no problem.
BUT, in any case, were I to change my kernel… I have just opened the manjaro tab, but the earliest kernel I can change is the 4.4 version… what do I do ?

I’m on another computer but kernel 4.14 is still available on Manjaro settings