Manjaro ARM Beta4 with Phosh (PinePhone)

Manjaro ARM Beta4 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our fourth BETA release for the PinePhone running Phosh!

This image is running the 5.10 kernel from Megi, which is designed for the PinePhone.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps with working GPS
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta3

  • uses 5.10 kernel by Megi, which supports the dock better
  • Phosh updated to 0.7.0
  • Squeekboard is now at 1.11.1
  • Gnome packages got updated to 3.38.2
  • updates like Megapixels 0.13.1, Mesa 20.2.3, Pipewire 0.3.15, Pulseaudio 14.0, Qt 5.15.2, Xorg-Server 1.20.10, modemmanager 1.14.8
  • make GTK3 more elegant when in convergence mode
  • readded Geary-Mobile for emailing
  • adjusted alsa-ucm profiles
  • Fixes to phoc including double-tab on lockscreen
  • Update Uboot including Vibration on startup, Issue with Labels is now fixed

Currently broken:

  • Mic-Mute function in calls not working

Known issues

  • Megapixels might not show your back camera unless you had switched cameras once
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta4

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

You can now order the Manjaro CE Edition and the Manjaro CE Convergence Package of the Pinephone!

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

8 Likes

Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta5 here

  • Beta4 (2020-12-17) Download

    • based on stable branch
  • Dev (2020-12-22) Download

    • based on unstable branch
    • updated Firefox to 84
    • added Portfolio as minimalist file-browser
    • kernel is now at 5.10.2
    • renewed Mesa to 20.3.1
    • Phosh is at 0.7.1
    • Systemd got renewed to 247.2
  • Dev (2021-01-02) Download

    • based on testing branch
    • re-added Anbox
    • calls, phosh, phoc, squeekboard and geary got more fixes
    • icu is now at 68.2
    • kernel got updated to 5.10.4
    • mesa got downgraded to 20.2.6
    • updates to gnome-session and gnome-shell
    • firefox is now at 84.0.1
  • Dev (2021-01-07) Download

    • based on unstable branch
    • some packages got updated: calls 0.2.0, phoc 0.6.0, pipewire 0.3.19, mesa 20.3.2
    • Kernel is at 5.10.5
    • chatty got more fixes
  • Dev (2021-01-10) Download

    • based on unstable branch
    • Autorotate got readded to Phosh
    • Kernel is at 5.10.6
    • squeekboard got downgraded to 1.11.1+8+gc9f9a3b-1
    • several updates to Gnome 3.38.3
    • Firefox got updated to 84.0.2
  • Dev (2021-01-14) Download

    • based on unstable branch
    • we introduced eg25-manager
    • updated gtk3-mobile to 3.24.24
    • pulseaudio is now at 14.1
    • Kernel got updated to 5.10.7
    • Mesa is at 20.3.3
    • pinephone-modem-scripts and GPS enabled
    • we lowered the default DRAM speed back to 552
  • Dev (2021-01-19) Download

    • based on unstable branch
    • Kernel got updated to 5.10.8
    • regular modem-power driver
    • update of Megapixels to 0.14.0
    • Gnome got some updates on 3.38.3
    • Updates to Phosh components: Phosh 0.8.0, Squeekboard 1.12.0
    • Updates to Gstreamer and Pulseaudio

@philm Thank you so much Manjaro-arm Team for the new release!

I already experience something that seem to look like some type of bug (?)-

Whenever I open a file browsing dialog (e.g. on Image Viewer > Open) I keep getting on the top of my PinePhone screen what seem to look like a small notification with a memory-card icon that reads on the title “Phone Shell” and the second line reads “ROOT_MNJRO” or “mmsbl…something”

It will not go away until I close the browsing dialog.

Just reflashed my phone setup asked for wifi, I entered my password correctly and it doesn’t seem to connect. Tried even next to the router.

Greetings,

I have browsed www for 5G and Tethering with PinePhone and not sure about these features.

If you do know, please advise.

Cheers,
Jimmy

As of now not supported, based on the hardware we use.

Import PGP key DAD3B211663CA268, "Dan Johansen <strit@manjaro.org>"? [Y/n] y
error: key "DAD3B211663CA268" could not be looked up remotely
Import PGP key 084A7FC0035B1D49, "Unknown Packager"? [Y/n] y
error: key "084A7FC0035B1D49" could not be looked up remotely
error: required key missing from keyring
❯ gpg --search-keys DAD3B211663CA268
gpg: data source: http://82.148.229.254:11371
(1)	Bernhard Landauer <oberon@manjaro.org>
	Bernhard Landauer <bernhard@manjaro.org>
	  2048 bit RSA key DAD3B211663CA268, created: 2015-07-12
❯ gpg --search-keys 084A7FC0035B1D49
gpg: data source: http://82.148.229.254:11371
(1)	Dan Johansen <strit@strits.dk>
	Dan Johansen <danjohansen@strits.dk>
	Dan Johansen (Manjaro) <strit@manjaro.org>
	  2048 bit RSA key 084A7FC0035B1D49, created: 2016-04-23

@oberon @Strit What happened here?

5G, ok, but tethering will never possible ?
I need it…

There was an update to the manjaro-keyring package recently. Did they get removed from it?

When building the images I see no issues. I only had an issue on updating from Beta1-Factory. Have to check that again. The only update was adding the Buildserver and Anupam’s key to the keyring.

looks good so far. Thank you for this update!

Not sure this belongs here, but I noticed a couple of times how browsing the net via Firefox hangs the phone, so that it needs a hard reset.
Another weird thing is the proximity sensor being activated when my hand is in the upper zone of the screen, it sort of puts a dark grey image on the screen. I assume it should turn the screen/touchscreen off during a call, but I’m not actually talking on the phone.

Phone shell problem here too. Hope its something we can set to fix it.

here too, in my case with the calendar app.

Calendar app brings up the shell over and over.

I also experience popups with the messages ‘BOOT_MNJRO’ and ‘ROOT_MNJRO’ when running the Calendar.

THANK YOU MANJARO-ARM team! This beta4 is a great improvement.

Connecting the PinePhone with Manjaro Beta4 to the dock (usb keyboard/mouse and 1920x1080 monitor via hdmi) is working without crashing. I was able to drag Firefox, Nemo, Terminal, and few other programs to the larger monitor and use the keyboard/mouse without any crashing. It was great! I did notice clicking the right-side mouse button on an application title bar did not bring up a menu to close the program. I had to use the PinePhone display to close open apps.

Software Center
In Manjaro Beta4 is the first time I noticed apps in the Software program. In the previous releases, I installed a program via the terminal. Now I see there are numerous programs that can be installed via the Software program, which is excellent! I have not tried installing any yet, but look forward to soon.

Convergence - a working dock with kb/mouse and monitor plus productive programs (forget dumb phone apps) is looking really possible!

Camera Program
The seeming freeze when changing the from front camera to rear camera seems fixed. There was a significant delay but the camera program did successful make the switch from the front camera to the rear, which is great! The live image when using the camera program is very responsive, which I appreciate.

Note: When I launched the camera program initially, the image from the rear camera appeared gray (little to no color) and the image was very wobbly/fluid and narrow. However, the color returned and the image looked more normal after I switched from front-to-rear.

Firefox
The dialog box that contains the list of urls that appears after pressing the address bar better fits on the Pinephone screen compared to Beta3; however, not all of the dialog box can be seen.

Overall, a big update with great improvements.

Cannot wait to try out more with Beta4. I cannot wait to do more with Pinephone + Manjaro-Arm Beta4.

1 Like

Yes I think so too! With Manjaro-arm for the PinePhone the system is improving and feels overall more and more stable and smooth with every release.

Huge thanks to the Manjaro-arm team!

I’m having much the same issue, it seems to occur in more apps than that too and it’s very annoying, it also seems to spawn instances of nemo as well as throw up an error about not being able to find a certain directory

A huge thank you to everybody especially the Manjaro team for getting the Pine Phone running nicely. Quick question. With this beta can I upgrade from the previous via the cli like I would with a desktop or should I flash after every release?
Thanks again.