Manjaro ARM Beta10 with Phosh (PinePhone)

Manjaro ARM Beta10 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our tenth BETA release for the PinePhone running Phosh!

This image is running the 5.12 kernel from Megi, which is designed for the PinePhone.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function we had to remove
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta9

  • we use now 5.12.3 kernel series with patches by Megi
  • Phosh gained media-control on lockscreen
  • Mesa is now at 21.1.0
  • Systemd got updated to 248.2
  • we are using now Pipewire
  • more Gnome 40.1 updates

A detailed list of package changes can be found here.

Currently broken:

  • Mic-Mute function in calls not working
  • GPS may not work as it should

Known issues

  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta10
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta11 here

  • Dev (2021-05-23) Download
    • based on unstable branch
    • fix headset button handling and jack/mic plug in/plug out detection
    • applied quick suspend/resume to modemmanager 1.16.4 (users from yesterday’s dev-image need to do a sudo pacman -Syyuu
    • more fixes to chatty
    • fixes to Phosh to support Japanese and Asian languages better
    • added more features to Phosh
    • Siglo is now at 0.8.0
    • Squeekboard is now at 1.14.0
    • fixes to kernel and uboot-firmware to stabilize RAM speed. Users can try again higher clock speeds
  • Dev (2021-05-24) Download
    • based on unstable branch
    • added a workaround to Calls to mute the Mic during a call. We are working on a better approach, though.
    • some small fixes to Phosh including better support for Asian languages
  • Dev (2021-05-29) Download
  • Dev (2021-06-03) Download
    • based on unstable branch
    • we updated Anbox
    • issue with starting chatty on received SMS/Text is fixed
    • updated patches for eg25-manager to stabilize the modem further
    • fixed issues with feedbackd to find themes
    • Firefox is now at 89.0
    • Siglo got updated to 0.8.2
    • wake-mobile got added
    • regular package updates
4 Likes

Just gave Maps a chance and GPS seems to be working quite acurate. Will test more once i’m on the move …
Pamac looks gorgeous and works fine! :wink: :+1:
UI rotation seems to be more coherent than before, and overall has smoother response.

1 Like

No better way to wake up on Saturday to hear the update news!

Thanks Manjaro Team!

A new daily build with some enhancements is now available …

1 Like

Even tho is still a supported protocol, is obsolete from quite some time now. Most developers will not actually invest energy into it … With clients like WhatsApp, Viber, Telegram etc, multimedia messaging is much easier.

1 Like

A new daily build with some enhancements is now available …

1 Like

Thanks for the response… and I get what you’re saying.

I guess it’s a pity I spent energy and effort to get many of my contacts to move to Signal instead of some of the easier to support on linux messaging systems… I am hesitant to ask them to move to a new messaging system again at this time.

With most of my contacts I’ll be falling back to SMS (arguably also obsolete). Most of my contacts won’t understand the difference between an MMS and an SMS message.

Any idea if there is movement on Axolotl? Last time I checked (a few months back) I couldn’t get it installed on Manjaro Phosh on my PinePhone. I think at the time it looked like a dependency issue with Axolotl/Snap and Manjaro… (could be totally wrong here :slight_smile: )

Not sure how relevant that is, but from reading a bit of it, has support for T-Mobile only ?!? Not very useful for other carriers i guess, but probably there is a way to use it trough Anbox ?

Not much to be hones, just that is available on Pine64 - pinephone forum
https://forum.pine64.org/showthread.php?tid=12047

1 Like

… as of now, neither the Pinephone nor the Librem 5 can do MMS using Phosh (they both share ModemManager and it doesn’t have MMS functionality).

Things should “just work” if you install ofono and MMSd. There are more details (urls, which forks are involved) at mms-stack: documenting and stewarding a free software SMS+MMS messaging stack

The basic debugging workflow is to run ofono, run MMSd, and try the scripts under the test directory in MMSd’s source tree. Error messages logged from the script, MMSd, or ofono might be relevant.

MMSd (mms parsing, mostly) and ofono (dual-stack IPv4/IPv6 networking) need patching to make MMS work on T-Mobile; other providers might also need debugging or custom patches.

4 Likes

Thanks … I’ll try Anbox again.

Thanks… I’ll give that a go when I next have a bit spare of time… :grinning:

  • added more features to Phosh

Is there a place to view these changes on the newest Dev channel build?

Well, you can check here: Commits · master · Librem5 / phosh · GitLab and also the additional changes we do: Commits · master · manjaro-arm / packages / community / Phosh / phosh · GitLab

Thanks for all your good work. A question asked by @codenul for the Beta 9 release, regarding updates, has not been answered yet. I installed Beta 9 some time ago. Is my phone automatically updated to this Beta 10 version if I run Software Updates? As far as I know I’m on the stable branch. It did not change branch after installing Beta 9.

1 Like

Hello, just installed the phosh beta 10 for pinephone and the default sms (chatty?) doesn’t show the green send button! I can see it when I minimize. It is off screen to the right in full screen mode and there doesn’t seem to be an auto-rotate. Is there any solution or keybaord shortcut to send? Very frustrating. Thanks.

Looks like if you turn the keyboard to terminal mode and use the ‘tab’ key, the green send button will then be visible

1 Like

thanks, i found an auto-rotate button in the quick settings as well.

Answering my own question.

In a terminal I ran phosh --version and that showed 0.10.2, so it has been updated.

I installed Release Release 202105240313 · manjaro-pinephone/phosh-dev · GitHub and when i try to use pacman it says invalid or corrupted package. I have tried to update mirrors, tried the keyring issue wiki, even the later steps, but also some of them failed with same error.

Issue seems to be “arch linux arm build system” gives incorrect key and it is not populated into the keyring, and packages depending on it fail to install.

The only unorthodox thing i did was i changed branch from unstable to testing after installation, can this cause these kinds of errors?

edit: needed to use pacman-key --populate archlinuxarm instead of what was in the guide.

1 Like

In the Phosh Beta9 thread I posted a remark regarding the fact that both mobile and wifi connections remained dead on my phone when it came out of (deep) suspend.

Since switching to the unstable branch and updating a couple of days ago I can happily say that this behavior no longer seems to be happening, at least for the mobile connection! It seems to come back up every time, and fast too! :smile: I’ve also tested calling the phone a couple of times when it was in deep sleep for about 30 minutes, and it rang every time. So fast even that I was wondering whether the phone went into suspend at all, but that seems to be the case since the battery is not being drained like crazy.

Really happy to see this massive fix, thanks for all the efforts! Will use the phone as a daily driver for the coming time to see how it holds up! :slight_smile:

Edit: of course, I knew I should not have posted this, now I jinxed it :wink: After having updated the phone and rebooting, the phone is now regularly losing connection to the modem when coming out of suspend again, which is only ‘fixed’ by a reboot. I’ll try to obtain some logs when this happens. I have the idea that it’s happening more often when wifi is also active - but that might just be my imagination as well.