Manjaro ARM Beta10 with Phosh (PinePhone)

We have updated the way on how we do the modem with the latest dev-images. Give them a try.

1 Like

Hey phil, thanks for your response. That is good to hear! Just updated and rebooted, will see for the rest of the day how it goes and report back this weekend :slight_smile:

Today’s dev-build will bring more modem fixes …

2 Likes

is there any plans to release Manjaro on other Android existing phones

Hey, does Manjaro currently support 911 calls? I understand this would be somewhat hard to test without having an actual issue worthy of calling 911 lol

AFAIK, that is handled/routed by your mobile service provider (it should work fine with most popular carriers).

I can confirm that with a Verizon SIM card, dialing 411 works as expected (I do not want to test 911 - they get too many calls already)

Could use a bit of help. After updating to Manjaro Arm Beta 10 with Phosh, there is an error message that says…

warning: libtool: local (2.4.6+44gb9b44533-14 is newer than core (2.4.6+42+gb88cebd5-15

What do I do to fix this error?

Any help will be greatly appreciated.

That package has been rolled-back for some reason or another. You can run: sudo pacman -Suu which will downgrade the package to the current package version in the repo.

Thanks!. The command worked! Appreciate the super quick reply.

Hello - after updating to beta 10, I no longer receive text messages (I use t-mobile). I can send a text message, I just cannot receive one. It is a bummer. Incoming text messages was working with previous manjaro-arm betas. I read the sms posts above but could not conclude whether they pertain to not receiving text messages.

I did notice a post from two weeks ago at the bug-tracker about not receiving text message notifications, which is titled No Notifications.

Is there a fix or simply wait for a fit in the next update (beta 11)?

Appreciate all the help from this forum.

Hey drh, I thought I had this issue too, but it seems that the problem is a bit different (for me at least):

if you already have a conversation ongoing with someone you will properly receive SMS messages for them. If a conversation did not exist, the incoming SMS will not be displayed.

So I think it’s a problem with Chatty where new conversations are not properly created when SMS messages are received from “new” contacts. You can ‘fix’ this by first sending an SMS to someone (number or contact) that you expect a message from so that the conversation is created. Afterwards you will receive SMS’s in that conversation properly, I think.

At least, this is the behaviour I observed :slight_smile: None the less, it’s a bit of annoying problem indeed.

Edit: it seems that it’s still a bit different than I wrote above: it seems SMS messages are received properly only when Chatty is opened/started. If not, SMS messages will be missed - the phone comes out of sleep and the display turns on, but the SMS is not visible in Chatty. So this makes the problem a bit more serious :confused:

latest testing update seems to have brought wifi status icon visible even when wifi adapter is turned off. This is a good change.

Regarding chatty

Hi p1x3l3d - Thanks for the reply. For me, it does not matter if chatty is open or not. I left a chat (i.e., leave via the options menu) and still do not receive text messages. I have not tried deleting a chat in chatty and then see if I can receive a text message. For now, it seems receiving text messages is not working with beta 10 (i.e., not developer).

Seems like todays update are reporting back some positive results. While the phone is idle, waking up the phone now, the phone almost instantly connects back to my WIFI network.

Will continue to monitor and report back results.

Updated Packages
Siglo (0.8.2-1 > 0.8.4-1)
Linux-pinephone (5.12.8- 2 > 5.12.9-1)
Chatty (0.3.1+24 > 0.3.1+31)
Calls (0.3.3+1 > 0.3.3+29)
gtk3-mobile (3.24.28-1 > 3.24.29-1)
libmbim (1.24.6-1 > 1.24.8-1)
js78 (78.10.1-1 > 78.11.0-1)

how exactly are you getting updates? when i clicked on add/remove software icon it said i was up-to-date.

He is using the developer image, which gets daily updates

got it, thanks! i see there is a beta 11 now.