Manjaro ARM Beta9 with Phosh (PinePhone)

Do I need to re-download each Beta release each time a new one comes out or can I just continue to update it normally. Currently on a Nightly build and wasnt sure if they are the same.

As always, Thanks for the continuous amazing work on this!

2 Likes

Just downloaded the latest beta(9) from github and installed it. Phone booted to a tty1 text login with no keyboard option, rebooted with the same result. Will try to flash again, but if it also fails, I may try the nightly.

Update - after waiting a while the gui did finally initiate. I just had to leave it alone for a bit.

2 Likes

Just downloaded the same and tried. From the first look of it… experience is fluid smooth. Very good improvement from beta 8. Add/remove software is a good addition and is fast. Looking forward for more updates. Calls are working fine. Will update more in few days. Thanks a lot for all the good work.

Screen keeps dimming off while “Automatic Brightness” is enabled.

Looks like there are some changes to display scaling. At 200%, all the fields are not fit in the screen. Is there a way to reduce it to 185% or so? Example in the messaging app, ‘Send’ button is not visible on the screen. ==> Never mind, disabling auto rotation took care of this. I can now see everything on the screen. Interesting…

1 Like

Updated using the command line. Took a while, but it seemed to work. The terminal/screen did become unresponsive. So, I waited a long time and then forced a reboot. Seemed like I waited long enough for the update to complete.

An improvement is megapixels. Before this update, megapixels would start with the rear camera without color (grey), which was corrected by switching to the front camera and then back to the rear camera. Now, megapixels starts with the rear camera with color. Also, the rear camera is less liquid/fluidy when moving the phone with this new update, which is also a plus.

Thanks for the updates!

1 Like

Would just like to report that the updated version of chatty that came with this Beta9 update (chatty-0.3.0-1) is not displaying texts. I can send but I cannot receive texts.

Edit: FYI The most recent follow up update seems to have solved the issue, but I’m not entirely sure how. Everything seems to be functioning.

p.p. This OS is really starting to come together nicely. Thank you everyone.

Another really nice release. Currently this is easily one of the (of not the) most function-complete distributions on the Pinephone AFAIK. Really great job, getting better with each beta. Thanks! :smile:

I do have one issue and was wondering whether other users are experiencing this as well: when the phone goes into suspend and wakes up, the connection to the modem seems gone. The phone no longer detects it and only a reboot fixes this. Very, very annoying, and I have no idea how to fix it.

Is there maybe a command that can be issued to restart the modem(service)? One that maybe even can be hooked to the resume-after-suspend event/trigger?

Yes, loss of the modem or wifi after wake up has happened to me a couple of times. However, it occurs sporadically. I fix it by rebooting. I have not investigated an alternative solution. I agree that the user experience will be improved if this can be prevented.

I’m glad to see the charger is no longer stuck at 500mA when the phone is started with it connected.

Please open an issue so we can track it. We got reports of that issue and there is work going on. It can depend on the modem firmware and other things. See also here:

Really impressed with Manjaro Phosh. Over the weekend I flashed over Beta8 and then on Monday Beta 9 came out and been running it for the last couple days. Switched over to the unstable branch and so far - so good on updating packages / no crashes.

Been “WIFI daily driving” Beta9 and been overall an enjoyable experience. Anbox is a huge benefit - I have installed Anbox on other Phosh installs but eventually ran into no keyboard input issue. Called my father on it and he mentioned that audio was very clear and in fact, best quality when testing out calling outbound to someone. Carrier is Mint Mobile

Like the idea of the Add / Remove Software App that was added. Quick and fast when checking for updates. Only gripe is that when updating, its hard to read the package names in Portrait mode.

Cant wait to hear about Beta10

Thanks for your response Philip! I’ll test some more with logs enabled and add my experience to the issue on Manjaro’s gitlab.

Currently I’m tracking these:

Been letting the phone sit in idle (no modem because no SIM) and am seeing the battery drop from 81% to 30% in roughly 39.5 hours. That’s a great improvement!

I take it this build is running the latest Crust and ATF?

Thanks for the great work. I successfully installed this Beta 9-version last weekend. Anbox worked, as it did with the Beta 8-version I installed some weeks ago. After an update of the Beta 8-version last week, Anbox failed. It only showed the green splash screen. To fix it, I installed Beta 9 and installed WhatsApp in it. Again I had a working WhatsApp in Anbox. But now, after an update this evening, Anbox fails to start once again. Anyone any idea how to fix this? My family insists on using WhatsApp, so I need Anbox. Thanks for any reply. Fred

1 Like

I think I found the cause.

Anbox fails to find libprotobuf-lite.so.26. That library has been updated to version 27 during the last update. Therefore Anbox fails to start.

I tried to create a symlink, as suggested by lemust83 in a thread titled " [Testing Update] 2021-05-12 - Kernels, KDE Frameworks, Plasma, Systemd, Mesa, LibreOffice, KDE Gear Mobile, FF, TB". But that didn’t help.

Yes, the latest update broke Anbox.

Summary
$ anbox system-info
anbox: error while loading shared libraries: libprotobuf-lite.so.26: cannot open shared object file: No such file or directory
1 Like

A rebuild is in progress …

3 Likes

New Anbox version is currently out when checking for updates through the Add/Remove Software App. Was able to download, install, and verify that Anbox is showing the welcome splash screen, but then eventually opens. Seemed like a reboot helps, although it didnt suggest it

Old Version : 0_git20201130-3
New Version : 0_git20201130-4

Thanks @philm

1 Like

I have been updating from beta 8, can I please ask you how do you install the new programs from the beta 9? Like Siglo and Add/Remove Software App?

I would like to get anbox working again too, but when checking updates on pacman nothing is there.
Do I need to be on unstable to get that update?

Apologies in advance for possibly silly questions.

Thank you @philm! I updated and now I have a working anbox again.