Manjaro ARM Beta 23 with Phosh (PinePhone / PinePhonePro)

Manjaro ARM Beta23 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our twenty third BETA release for the PinePhone running Phosh!

image

Those images either run the 5.16 kernel from Megi, which are is designed for the PinePhone or 5.16 cross-distro kernel, which supports the PinePhonePro.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta22

  • Kernel got updated to 5.16.11
  • Pipewire is at 0.3.47
  • Mesa is now at 21.3.7
  • Firefox is now at 97.0.1
  • Chatty got renewed to 0.6.2.
    • updated translations
  • Calls got its first Release Candidate of 42 release series
    • Call time now in sync with phosh
    • Updated libcall-ui to v0.0.2
  • Phosh got updated to 0.16.0
    • Fading labels in the overview
    • Keypad can shuffle buttons
    • More style refresh
    • Plenty of fixes and cleanups
  • eg25-manager got updated to 0.4.3
  • Toolchain got updated
  • Gstreamer is now at 1.20.0
  • ModemManager get renewed to 1.18.6
  • NetworkManager got updated to 1.34.0

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • Chatty may crash with experimental features like MMS enabled. You may disable them via gsettings set sm.puri.Chatty experimental-features false if that is the case
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta23
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta24 here

  • Beta23 (2022-02-27) Download
    • based on stable branch
  • Dev (2022-03-08) Download
    • based on unstable branch
    • Pipewire is at 0.3.48
    • simplification in callaudiod code
    • Firefox is now at 97.0.2
    • gnome-calls prepared for 42rc1 release
    • libpamac got needed AUR fixes
    • Kernel is now at 5.16.12
    • Phosh and Phoc got slightly improved
    • We updated the ALSA UCM profile for PP
  • Dev (2022-04-29) Download
    • based on unstable branch
    • Pipewire is at 0.3.50
    • callaudiod got updated to 0.1.4
    • gnome-calls is now at 42.0
    • most Gnome packages got updated to 42.1
    • Firefox is at 99.0.1
    • Pamac got updated to support Gnome 42
    • Kernel is now at 5.17.5
    • Phosh and Phoc support now gestures
    • Mesa got updated to 22.0.2
2 Likes

Did a fresh install instead of upgrading from Beta 22. The microphone on phone calls is super sensitive and in the settings I could not lower to any effect. This made calls nearly impossible. Installing pavucontrol (pulse audio volume control) and lowering mic input to about 15% returned calls to normal.

Was kind of cool though because the mic was so sensitive you could hear people having a conversation in another room on my phone calls. Just wanted to post in case someone else needs this fix.

Great work on the OS it really is coming along. I wish Plasma was closer to daily driver status it really is coming along nice as well.

This update made my pinephone beta voice call worse. The person on the end could not make out what I’m saying. I’ve tested with multiple calls and same result. Is anyone else experiencing this as well?

I assume you both talk about the original pinephone. We changed the audio profile. Maybe changing it back might work but it really should been reported to upstream.

I might need to update the profile again as more changes were made.

Let me know if this improves things: [pkg-upd] 0.5.6-2 (a4b57f3b) · Commits · manjaro-arm / packages / community / Pinephone / alsa-ucm-pinephone · GitLab

I was able to fix this by installing pulse audio control and turning the microphone sensitivity way down.

I don’t know if this is new with this update, or if it has happened for some weeks as i have not been using the feature, but after updating from beta22 currently when in landscape mode the OSK takes up the whole screen. A nice feature for when the phone is docked for sure, but standalone it makes landscape pretty impossible to use if there is text input active.

If others don’t find the same i will probably try clean install of beta23.

1 Like

Can’t make phone calls! At first I could make phone calls with this update, but the small update (alsa-ucm-pinephone) that appeared later on now makes calls impossible. I recall the description mentioning the PinePhone Pro…maybe I shouldn’t have updated it to my phone since I just have a regular PinePhone and that caused the problem. Either way ever since that update of alsa-ucm-pinephone, my phone can no longer make calls. Help.

is there a way to un-install the alsa-ucm-pinephone update?

Hey Philm, is gitlab the same as github can I use git clone and the link and the run makepkg like any other AUR package to test out that alsa-ucm-pinphone package?

I generally only build arch packages from the AUR just making sure thats the way I am supposed to do it.

Yes, you’ll want to use the HTTPS link found by clicking the Clone button on the package page.

Hmm so the update of ucm made it actually worse. Maybe I should revert to the known 0.5.5 state. Will check later.

Hey philm, I did a lot experimenting with my phone and I think I know a possible cause to the issue. I don’t think its the ucm…my hunch is that the handshake for VOLTE signal is not turning on. I did a fresh install of 23 and 22…the ones I know that had the ability to make phone calls on my phone but I’m getting the same results. Can’t make phone calls or receive any. I see the bars, but can’t make phone calls or even browse the web. I notice it switches from 4g, 3g, 2g (and sometimes no label) very often, which is an odd behavior. It never did this in 23, 22, 21, etc. Maybe my sim card is bad or my modem went bad? Note that all the 3g towers are being removed this year in place of 4g/5g (with VOLTE). Very possible my carrier cut the cord for 3g on March 1st (they have been notifying customers that 3g is going away in Feburary)…which is when I had all these problems appear…right at March 1st. Could you double check to make sure VOLTE capability is actually turning on?

I have a problem with the microphone. Callers repeatedly complain that my call rattles. So I used the “Sound recorder” and the result is really not good (ambient sound record and “silence”). The microphone does not respond at all to the sensitivity setting, nor does it respond to the “Configuration” switch (options “Play HiFi quality music”|“Make a phone call”. By the way, does anyone have any idea what this is for? I didn’t notice any difference). What is your experience with Mic and is there a solution?

Hmm, on my end I didn’t see any issue on my end with a regular PinePhone. Changes to the profiles can be found here: Commits · master · manjaro-arm / packages / community / Pinephone / alsa-ucm-pinephone · GitLab Issues can be reported here: Add UCM for PinePhone by tomfitzhenry · Pull Request #134 · alsa-project/alsa-ucm-conf · GitHub

1 Like

Let’s try Mobian UCM similar as Arch does …

1 Like

Different results might be achieved when dropping back to PulseAudio

1 Like

I thought I’d report having an issue with the mic as well; it has hyper sensitivity and is made all the worse if my caller has their mic on, so the terrible feedback appears to come from ambient noise and the phone picking up its own speaker. I thought I damaged my phone in a move but all appears to be well with the device’s integrity.

I installed pavucontrol as @kmsgli and reduced mic gain to 15–20% and I’m not getting this in my tests now. I’ll need someone else to verify this with me.

I also noticed garbled call audio with this update, using pavucontrol to set mic gain to 35% fixed it.

@thwright I am glad this helped it def seems to be the mic sensitivity, I am wondering if the call profile is setting the sensitivity by default to high. I have been running with the pavucontrol fix since this beta dropped (daily driver) with no other negative side effects. I did notice the other day when making a call the earpiece speaker turned itself up so this is why I am wondering if the call profile was turning up the mic sensitivity?

@philm I can also confirm call waiting is still an issue, I just turned it back on and tested and it still kills the call you are on. If anyone needs instruction on how to access the modem to turn call waiting off I did a write-up on the Pine64 forums;
https://forum.pine64.org/showthread.php?tid=15491&page=2

1 Like

In Manjaro/Phosh I can’t switch from PW to PA - the packages are in conflict and PW can’t be removed due to dependencies (I’ve already asked about this once in vain). So I tried to “standardize” the recording = Mic at 25% and 75% sensitivity set with pavucontrol is 3 cm from the laptop speaker (about like a call) with volume set to 50% and I play this. I recorded on Phosh (PW) and PlaMo ( PA) with these results: Phosh 25%, Phosh 75%, PlaMo 25% and PlaMo 75%