Manjaro ARM Beta 10 with Plasma Mobile (PinePhone / PinePhone Pro)

We are happy to present our tenth Beta Release of the Manjaro Plasma-Mobile edition for the PinePhone and PinePhone Pro.

This image includes

  • Kernel 5.16.2 optimized for the Pinephone
  • Frameworks 5.90
  • Plasma 5.23.5
  • Plasma-Mobile apps, which are bundled as Plamo Gear 21.12
  • Maui Apps 2.1 and
  • Camera app Megapixels 1.4.3 with great improvements in responsiveness
  • PulseAudio 15.0
  • Appimagelauncher 2.2.0 and
  • our Pico-Wizard for easy initial setup at first launch

Over the last month there has been steady improvements to the shell and default applications overall. Apps are now launching faster, too.
The drop-down menu provides Settings, Flashlight, a Screenshot function and more.
With Plamo Gear and the Maui Apps applications for all typical everyday needs are pre-installed.

Known issues:

  • Text prediction is not working.
  • Discover might not want to update packages.
  • Many translations are still missing.
  • Megapixels and camera does not work yet on Pinephone Pro.
  • Audio quality and routing on the Pinephone Pro is not good yet.
  • Some small graphical regressions made their way into Plasma 5.23.


Device PlaMo
PinePhone (Pro) Beta 10
PinePhone (Pro) Development

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

PinePhone Pro:
The Pinephone Pro is all you love about the PinePhone, except with better specifications. It has a 6-Core RK3399S SoC and 4 GB RAM, which is a huge upgrade compared to the regular Pinephones Allwinner A64 and 2/3 GB of RAM.
More information can be found on the Pine64 PinePhone Pro page.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store
Pinephone Pro Explorer Edition are now available! Order here.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone (Pro) should recognize the SD card as a bootable device and boot from it.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker


After using etcher to flash my SD with the PHOSH Beta 21 update, I installed manjaro-arm-flasher (which required a reboot) to fresh install this Plasma Beta 10 to my PinePhone’s eMMC. However, when I try launch manjaro-arm-flasher I’m left looking at the desktop (waited long enough for power management to kick in) and it fails to load. If I hit the chevron to see the running app list, it just collapses into the app list… so I suspect that means manjaro-arm-flasher crashed/aborted.

Maybe I’m using the incorrect tool? Or it and phosh beta 21 aren’t playing nice together?

Is there an alternative method to flash/update the eMMC with Plasma Beta 10?

EDIT: ran manjaro-arm-flasher via terminal and captured some details:

$ manjaro-arm-flasher
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_Platform=wayland to run on wayland anyway.
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized.  Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)
1 Like

At first welcome screen, after user creation, the wifi networks are not visible, had to skip to finish the wizard.
Once in the UI, screen never goes to sleep if the phone is left for a while, the power button is not working.
After a reboot from terminal, the phone is going to powersave, but once again, the power button is not working to wake the phone up. Third reboot made things work, but after a while screen is not responding to touch at all, and once again, power button fails to wake the phone up.

Thanks for another release guys, happy to see it come so quickly after beta 9 :slight_smile:

Plamo beta 10 is working really well on my PP CE. For me, pico-wizard worked fine to setup user, PIN and wifi and there was no need to reboot when finished. No problems with sleep/suspend/lock screen/power button here either, apart from the fact that the power button sometimes does not seem to register a push, and needs to be pushed twice before I see a response. Apps start reasonably fast, stability seems good.

Unfortunately, on one part it’s failing miserably: phone functionality :smile: On an incoming call, the modem consistently crashes. This can either be while it’s ringing or immediately after answering the call. I haven’t been able to make a successful call with it so far.

My PP is running modem SDK 0.5.1 and recovery firmware EG25GGBR07A08M2G_01.003.01.003. Will try updating the SDK to the latest version (0.5.5) and report back here in case that changes anything :slight_smile:

i had the same problems using the same modem firmwares which forced me back to phosh. I’m eager to know if switching to the testing firmware fixes it, so please let us know!

Using “Gnome Disks” under PHOSH to flash/expand my eMMC with this build worked very well.

Feedback for this release is that the Welcome Wizard doesn’t have a manual/hidden WiFi option… but easily worked around that by skipping it and setting WiFi up once the wizard was complete and I was logged in.

Sorry if this is the wrong place to ask, but is there any way to swap the buttons in the navigation bar?
I am used to vanilla android where back is left and menu/taskswitch is right.
The default on plasma seems to be the “samsung” way, with left being menu and right being back.

As far as i know the buttons in the navigation bar are hardcoded and may not be changed without recompiling.

On february 8th plasma 5.24 is supposed to be released and introduces touch gestures in plasma mobile which makes the navigation bar and discussions about its layout a bit less important.

Hi @varikonniemi and others,

I’ve followed up on this and installed modem SDK 0.5.5 yesterday afternoon. Rebooted afterwards and tested it by using the PP CE as my main driver since then. Phone functionality seems to have improved much! I can receive and make calls consistently. Receiving SMSs also seems to go well, have not sent any yet. I’ve witnessed the modem crash once and recover from it (carrier name disappearing and reappearing in the left top corner). Might have happened more often without me seeing it, of course.

So far so good, will report back later once I’ve used it for a longer period.

My PP is still on recovery firmware EG25GGBR07A08M2G_01.003.01.003, by the way. Also still on the Plamo Beta 10 release, haven’t switched to testing or dev repo’s.

The modem just crashed completely and did not come back up for me, unfortunately. Tried restarting eg25-manager and ModemManager through systemctl but this did not fix anything. A full reboot was required. Now trying to figure out if this was maybe because the SIM card is too loose, just stuffed a piece of paper in there to keep it in place more tightly. Curious to see if this changes things :slight_smile:

Regarding the modem I can mention that with the latest update and stock modem firmware I do not lose connection permanently, it just does a lot of automatic restarts like before. It unfortunately also does these restarts during a call which can lead to a couple of seconds of silence before conversation can be resumed. You can usually talk for 5+ minutes before it happens though so it does not happen that often. It seems that Plasma functions better with stock modem firmware?

I’m wondering if anyone has managed to make Dialer specifically only use the earpiece as sound output or at least automatically switch to the earpiece on an incoming call? Right now in order to hear the phone ring signal I have to set the phone sound output to speaker which means that the calls start in speaker mode and everyone I talk to complains that the sound on speaker is broken and that they can hear themselves. So when someone calls I take the call from the lock screen, then have to quickly unlock the phone, start Dialer and change from speaker to earpiece. This is quite annoying. Does anyone have a solution for this?

Is there for example a way to run a script on incoming call that switches sound output from speaker to earpiece?

Alternatively can the call sound quality on speaker be improved for the other caller? It’s fine for me but everyone I talk to says its horrible for them. Does taking calls on speaker have good sound for both caller and receiver in Phosh?

I have the same problem with calls.Мy problem with this is from earlier versions of plasma mobile.

i think you are mixing up something. You either have the recovery (stock) firmware, or open firmware. Are you maybe confusing the recovery and adsp firmware which is used along with open firmware?

I guess the confusion stems from the fact that the ADSP firmware is extracted from the stock firmware (as a “firmware within the firmware”), so uses the same version numbers and is shipped from the same eg25_quectel_recovery repository. (Users of the stock firmware normally automatically run the same version of the ADSP firmware. Users of the open firmware have to choose a version of the ADSP firmware in addition to choosing a version of the open firmware.)

After my fresh install of Manjaro-ARM-plasma-mobile-pinephone-beta9.img.xz on 1st Jan and a few times pacman -Suyy I’m stuck without a working plasmaphonedialer just like here. It seems like I always use an app with a nasty dependent package that breaks qt. This is the error now:

kf.kirigami: Units.devicePixelRatio is deprecated (since 5.86): This returns 1 when using Qt HiDPI scaling.
kf.kirigami: Units.wheelScrollLines is deprecated (since 5.86): Use Qt.styleHints.wheelScrollLines instead
kf.kirigami: Units.wheelScrollLines is deprecated (since 5.86): Use Qt.styleHints.wheelScrollLines instead
kf.kirigami: Units.devicePixelRatio is deprecated (since 5.86): This returns 1 when using Qt HiDPI scaling.
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/OverlaySheet.qml:570:17: QML ColumnLayout: Binding loop detected for property "height"
file:///usr/lib/qt/qml/org/kde/kirigami.2/AbstractApplicationWindow.qml:283:5: QML Binding: Not restoring previous value because restoreMode has not been set.
This behavior is deprecated.
You have to import QtQml 2.15 after any QtQuick imports and set
the restoreMode of the binding to fix this warning.
In Qt < 6.0 the default is Binding.RestoreBinding.
In Qt >= 6.0 the default is Binding.RestoreBindingOrValue.

void ActiveCallModel::onFetchedCallsChanged(const CallDataVector&) 0 0
file:///usr/lib/qt/qml/org/kde/kirigami.2/AbstractApplicationWindow.qml:283:5: QML Binding: Not restoring previous value because restoreMode has not been set.
This behavior is deprecated.
You have to import QtQml 2.15 after any QtQuick imports and set
the restoreMode of the binding to fix this warning.
In Qt < 6.0 the default is Binding.RestoreBinding.
In Qt >= 6.0 the default is Binding.RestoreBindingOrValue.

Speicherzugriffsfehler (Speicherabzug geschrieben)

When will you enable PSI on the kernel so we can run Waydroid and Android apps?

The kernels that have this are in unstable and testing branches.

So they will be there on next stable update.

Tried to make a call with AT command but the modem seems to be busy with the modem manager. Any other way to initiate a call until the above phone dialer problem has been fixed?

Hiya @Strit! Quick question, will the newly released Plasma 5.24 and Plasma Gear 22.02 be released into a new Manjaro Plamo Beta (11, probably :slight_smile: )? Or can I just update my Beta 10 installation to get the new Plasma packages?

There will likely be a new beta with plasma 5.24 and Gear 22.02 when they get into stable branch.

Updating will also get you those packages when they get into stable branch.

Does anyone know the modem-manager alternative to ofonoctl?

because since Beta10 I have the problem that the modem is disabled after the first reboot and the graphical tools offer little to no informations about it.