LUKS can't mount - dm_mod missing after upgrading to Kernel 5.13

I’ve created a LUKS encrypted disk while running Kernel 5.12.
Then I upgraded and tried to mount it on Kernel 5.13.

The errors I got from Dolphin and KDE Partition manager were cryptic.
So I tried commandline and got this:

# cryptsetup luksOpen /dev/sdc1 stuff
Enter passphrase for /dev/sdc1: 
Cannot initialize device-mapper. Is dm_mod kernel module loaded?
Cannot use device stuff, name is invalid or still in use.

The device mapper kernel module is indeed nowhere to be found.
I reinstalled device mapper and LUKS to no avail.

I have Linux-5.13 headers installed so I think the modules should be built and installed.

What can I do (except from switching back to Kernel 5.12)?

The first one simply reinstalled the kernel throwing the error but the second one used the previously working kernel.
As long as you do not need a new kernel (hardware support!), simply stick with what works for you.
One does not need to have the latest kernel installed/booted.

1 Like

Thanks. Looks like I’m not the only one having issues of this kind.
I hope there’s something else that can be done to fix this.