[Stable-Update] 2020-12-30: Cannot initialize device-mapper

After the 2020-12-30 Stable-Update & rebooting & giving the CORRECT PASSWORD on my encrypted system, I get the message (manually copied from screen):

Warning: /lib/modules/5.10.2-2-MANJARO/modules.devname not found - ignoring
Cannot initialize device-mapper. Is dm_mod kernel module loaded?
Cannot use device luks-<long_hexadecimal_number>, name is invalid or still in use.
Invalid keyfile. Reverting to passphrase.

A password is required to access luks-<long_hexadecimal_number> volume:
Enter passphrase for /dev/sdb3: [cursor]

At this point, input devices, such as KEYBOARD and MOUSE, seem to be disabled (or not enabled yet), so THERE IS NO WAY OF ENTERING A PASSPHRASE, even by plugging in the keyboard into other USB ports.

The result is the system is completely INACCESSIBLE.


Because of this, I welcome two fixing approaches:

  1. Booting from a Manjaro image and fixing the updated system with shell commands (please specify the ACTUAL COMMANDS rather than high-level instructions such as: “uninstall the open source driver…”); OR
  2. Doing a fresh reinstall (less preferred) that does NOT format /home and still asks for the previously setup encryption passphrase.

Oh, did I mentioned I was stupid enough as to NOT making a data backup? Yeah… :man_facepalming:

Please help!! My appreciation in advance!!

Do you have another kernel installed? You should always have at least 2 kernels installed on your computer at all times. If you do, did you try booting into that kernel?

You can also chroot into your system with a manjaro LiveISO and install another kernel if you didn’t.

From my experience, Kernel 5.10 has some issues.

I just want to say, since getting the latest updates, the lagging problem I had, was instantly fixed. So something in that update worked, where that script did not.

you need a way to access in chroot for luks

also after checks modules that should be kept & mkinitcpio ( dm-crypt )

Thank you for your reply!

I think I used to have at least two kernels installed, but the update replaced older kernels by the 5.10 only (I saw the messages of older ones being uninstalled). In any case, currently there’s no option for kernel selection from booting to the error screen.

I’m unfamiliar with the chroot procedure. Is there any link with step by step instructions?

The update installs the 5.10, and your experience says it has issues, does your reply boils down to having another kernel (maybe 5.9?) alongside with the 5.10? Thank you!

This is INTUITIVE but it does NOT work:

By booting from a rescue disk, I’ve noticed in the host system all files in /lib/modules/5.10.2-2-MANJARO/ were renamed with a “.old” suffix (probably by the update).

Renaming/Copying all of them back to their expected names (without the “.old” suffix) does NOT prevent the error message from appearing (which is weird, because the file /lib/modules/5.10.2-2-MANJARO/modules.devname now DO EXIST!!)

OK. Replying now with more experience on the issue…

Long story short, I really had to get rid of linux510, in order to be able to fully boot.

  1. I’ve booted a live ISO and issued a chroot [/path/to/target/root] (after reading it’s short man page);
  2. I then followed what’s in here, in order to (i) check available kernels (turns out I still had the linux59, and linux54 ones), and (ii) remove the linux510 one, with the help of pacman -R linux-latest;
  3. Then I was able to reboot (with GRUB errors!!), which led me finally to a grub menu, in which I was able to select a 5.9 kernel, which successfully booted;
  4. Now I’ve just edited my /etc/default/grub with GRUB_TIMEOUT_STYLE=menu (instead of hidden, which I think is a horrible default value), and issued a sudo update-grub, and I am about to check whether this has finally solved the issue (including now having a GRUB menu for me to be able to choose a kernel).

[Edit: Yes, this really solved the issue!]

THANK YOU, @realmain, for pointing me to the right direction!

Had the same issue today. After trying chrooting etc I found an easy solution: After you enter your cryptsetup password press and hold ESC key. This will show up GRUB menu on demand where you can select the kernel to boot from.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.