Lots of display problems after installation of Manjaro KDE (Lysia)

Hello!

After trying Manjaro KDE (Lysia) on a virtual machine for a few weeks, I yesterday installed it natively on a Dell Precision M4800, using the free drivers. The installation went well but the display resolution was set to maximum (3200) which made icons and text too small for my eyes. I changed resolution to 1920x1080 and the screen went black. I rebooted but after login the screen went black again.

As I didn’t know what else to do, I reinstalled Manjaro, this time using the non free drivers. This made for larger text but the resolution was still 3200 and I wasn’t able to change it to a lower resolution. Unfortunately, the installation stopped at 82% during “configuring hardware”.

I then installed it a third time, now using the free drivers again. After completion, I didn’t dare touch the resolution settings and only changed the magnification to 150%. This made the text look good but the icons were still too small. I opened System settings, selected Hardware configuration and tried to install the nvidia drivers but the installation failed (saying something about “core” missing).

Please advice! The native resolution for my display is too high and I need to lower it or use magnification that affects the icons too.

Please start here:

Most importantly, please provide

inxi -Fazy
1 Like

Might this help to resolve my issue?

System:
  Host: precisionm4800 Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=6ed3e909-4731-4ee4-87b6-d6df66c21618 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.18.5 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Precision M4800 v: 00 
  serial: <filter> 
  Mobo: Dell model: 0WNW0H serial: <filter> BIOS: Dell v: A26 
  date: 06/13/2019 
Battery:
  ID-1: BAT0 charge: 57.5 Wh condition: 65.3/73.3 Wh (89%) 
CPU:
  Topology: Quad Core model: Intel Core i7-4910MQ bits: 64 type: MT MCP 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
  L2 cache: 8192 KiB 
  Speed: 1198 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1197 
  2: 1197 3: 1198 4: 1198 5: 1197 6: 1199 7: 1199 8: 1199 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GK106GLM [Quadro K2100M] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: nouveau unloaded: modesetting 
  resolution: 3200x1800~60Hz 
  OpenGL: renderer: NVE6 v: 4.3 Mesa 20.0.7 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GK106 HDMI Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7260 driver: iwlwifi 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 7.06 GiB (3.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD SM841N 2.5 7mm 256GB 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
Partition:
  ID-1: / raw size: 85.46 GiB size: 83.62 GiB (97.84%) 
  used: 7.06 GiB (8.4%) fs: ext4 dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: 39.0 C sodimm: 40.0 C 
  gpu: nouveau temp: 46 C 
  Fan Speeds (RPM): cpu: 2075 
Info:
  Processes: 212 Uptime: 9m Memory: 15.58 GiB used: 1.35 GiB (8.7%) 
  Shell: bash inxi: 3.0.37

Can you also please provide:

mhwd -l

PS:
It also appears you are using kernel 5.6 which is EOL (end-of-life) … please ensure you are all up to date, and please choose a new kernel. ex:

sudo pacman-mirrors -f && sudo pacman -Syyu
sudo mhwd-kernel -i linux58

(kernel 5.8 is newest … but you may prefer an LTS kernel [long term support] like 5.4 … or both … many users choose to keep a known-working LTS kernel installed while using/testing a newer one)

1 Like

Why not using a fresher ISO?

https://manjaro.org/download/

If you are running 5.6 kernel you should NOT update right away - it’s not EOL - it’s not supported anymore. First, you need to install a supported kernel (e.g. 5.4 or 5.8) and then boot into it, remove 5.6 and then update.

1 Like

Gives:

0000:01:00.0 (0300:10de:11fc) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-418xx            2019.10.25               false            PCI
video-nvidia-390xx            2019.10.25               false            PCI
video-nvidia-340xx            2019.10.25               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

Thanks for trying to help, btw. If I change the resolution and the screen goes black again, is there something I can do besides starting all over again? Is there someway to revert the display settings?

wollie is correct … If I were you, I would start from a fresher ISO.

Did you do your updates and all successfully? If so, I guess its not necessary.

I’ve switched to kernel 5.8.6.

But I still don’t dare changing the resolution. If the screen goes black, I don’t know how to revert to previous settings.

What do I gain by using the latest ISO? I have the new kernel now. And can’t I update all other programs to new versions?

I should hope so.
Its the first thing to do before moving on.
If its successful then we can probably chug along.

My system “is up-to-date”, as stated by Pamac.

Alright.

Honestly … I dont know whether or not to trust pamacs output … especially since you started from an old ISO.

I would do this to be sure:

sudo pacman-mirrors -f && sudo pacman -Syyu

Then,
So first … you are currently using the open ‘nouveau’ driver.
Pretty much universally you get better results from using their proprietary drivers.
(assuming your card is supported)
As yours seems to be … you probably want to install whatever is best for you … I guess ‘video-nvidia-418xx’.
Its totally up to you … but heres an example of the install:
sudo mhwd -i pci video-nvidia-418xx

From there … I would say you dont want to mess with your resolution.
It should just be set to its automatic/optimum max.
From there you probably want to either set ‘Scaling’ in Display Configuration
Or use a combination of DPI settings.

Start by using the ‘global scale’ setting … if that is not to your liking I will show you the DPI route.

I changed the video drivers and it looks better now. This will do. Thanks! But I still have to ask: if I change the resolution and the screen goes black, is there a way to revert to previous settings?

Theres about a dozen ways to set resolution.
With KDE I guess we could use kscreen-doctor … heres a quick one-liner I cooked up for you:

mimon=$(xrandr | grep " connected" | cut -d' ' -f1); echo "Active screen recognized as "$mimon""; echo ""; echo "Desired resolution? (example: 1920x1080)"; read mires; kscreen-doctor output."$mimon".mode."$mires"@60

Hi,

Just by reading this thread I have been learning so much! My past 48h was exactly about this, as a total noob I have came to the exacvt same conclusion regarding kernel use: LTE or the latest non experimental, nothing in between. I Reinstalled my OS and the kernels like 15 times in 48h to learn this and figure this “optimal kernel” versio out on my RTX270+8700K PC by seeing its performance and visual glitches (tearing etc).

Thanks but are you saying I should run your one-liner if my screen goes black? Because I can’t see anything then. In Windows, the system reverts back to previous settings if the user doesn’t accept the new settings. I was looking for something like that. Or perhaps doing something from the boot screen.

Does the whole display crash?
If that (was) the case … it may not be any more after you have sorted out your drivers and such.

That said … its possible that maybe you could still access TTY (ctrl+alt+f2,3,4,5,etc)

Also… I could tweak the command to go a bit more like this maybe.
(ok I kinda gave up at the end … because I didnt start out to write a script :stuck_out_tongue_closed_eyes:)

mimon=$(xrandr | grep " connected" | cut -d' ' -f1); ores=$(xrandr | awk -F'[^0-9x]*' '/*/{print $2}'); orat=$(xrandr | awk -F'[^0-9]*' '/*/{print $4}'); echo ""; echo "Active screen recognized as  "$mimon" : "$ores"@"$orat"" ; echo ""; echo "Desired resolution? (example: 1920x1080)"; read mires; echo ""; echo "Desired rate? (example: 60)"; read mirat; echo ""; kscreen-doctor output."$mimon".mode."$mires"@"$mirat"; sleep 6; kscreen-doctor output."$mimon".mode."$ores"@"$orat"; echo ""; echo "If you want to make the resolution change permanent, then please enter the following command:"; echo "kscreen-doctor output."$mimon".mode."$mires"@"$mirat""; echo ""; echo "Enjoy! <3 cscs"

It will take your inputs for resolution, apply them, wait 6 seconds then reapply the original settings.

Sample Output

Active screen recognized as  eDP : 1920x1080@60

Desired resolution? (example: 1920x1080)
1680x1050

Desired rate? (example: 60)
60

kscreen.doctor: Taddaaa! Found mode "89" "1680x1050@60"
kscreen.doctor: Output 83 set mode "1680x1050@60"
kscreen.doctor: setop exec returned KScreen::Config( 
KScreen::Output( 83   "eDP" connected enabled primary pos: QPoint(0,0) res: QSize(1920, 1080) modeId: "89" scale: 1 clone: no followPreferredMode: false ) )
kscreen.doctor: Taddaaa! Found mode "88" "1920x1080@60"
kscreen.doctor: Output 83 set mode "1920x1080@60"
kscreen.doctor: setop exec returned KScreen::Config( 
KScreen::Output( 83   "eDP" connected enabled primary pos: QPoint(0,0) res: QSize(1680, 1050) modeId: "88" scale: 1 clone: no followPreferredMode: false ) )

If you want to make the resolution change permanent, then please enter the following command:
kscreen-doctor output.eDP.mode.1680x1050@60

Enjoy! <3 cscs

Yes, the display did crash previously and I didn’t know any other way than reinstalling.

Thanks a lot for the help!