Login screen freezes, could not connect to display

Hey there,

I’m unable to log in to graphical environment. After updating manjaro, login screen freezes after entering password.

Things I tried so far via Terminal (crlt + alt + f3):

  • Boot kde

sudo startx


unable to connect to d-bus: using x11 for dbus-deamon was disabled at compile at compile time, set your DBUS_SESSION_BUS_ADRRESS instead

couldn't exec startkde: no such file or directory

xinit: connection to X server lost




Xauth: unable to write authority file

Fatal server error: (EE) Cannot open log file "..../Xorg.1.log”
  • added new usr. Login screen appears again after entering psw.

  • switch kernel in advanced settings didn’t bring any changes, neither does fallback init

  • I tried to lounch an application

    qt.qpa.xcb: Could not connect to display
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.       
    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
    Aborted (core dumped)

Thanks for any ideas or replies. Please excuse any mistakes, as I am a noob. :slight_smile:

Thanks for your reply, if it was for me.

I checked both with

$ which (packagage name)

Answer is non of them are found.