[PROBLEM] Sometimes hangs(stuck) when booting on the splash screen after login (login screen appears twice)

The described problem appeared not so long ago. After installing the 5.9 kernel, I noticed that sometimes the system doesn’t boot and the boot process freezes on the splash screen.

Sequence of actions:

  • turn on the laptop
  • when loading, select the kernel 5.9
  • I see lines of text appear on the black screen
  • a password entry window appears
  • I enter my password and press Enter
  • again I see lines of text appear on the black screen
  • the login and password window appears AGAIN
  • I enter the password AGAIN and press Enter
  • the SplashScreen appears
  • the system doesn’t respond to anything else
  • sometimes the mouse cursor appears, but the system also does not load further than this screen

The Ctrl+F2 key combination works and I can log in, but it doesn’t help.

If I press Ctrl+Alt+Del, a choice of actions appears - restart, turn off, and so on. But this screen with a choice of actions does not look like a normal one - it does not have a background image and the buttons are on a black background. In addition, the buttons on the screen do not respond to the keyboard and mouse.

The problem only occurs on the 5.9 kernel.

Acer Nitro 5 AN515-44
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.9.3-1-MANJARO
OS Type: 64-bit
Processors: 12 × AMD Ryzen 5 4600H with Radeon Graphics
Memory: 7,2 GiB of RAM
Graphics Processor: AMD RENOIR


can you returns line boot

inxi -Fza
System:    Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=29bb1a52-a1c8-4301-96a0-db86462db6f6 rw 
           acpi_backlight=vendor apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Nitro AN515-44 v: V1.02 serial: <filter> 
           Mobo: RO model: Stonic_RNS v: V1.02 serial: <filter> UEFI: Insyde v: 1.02 date: 06/16/2020 
Battery:   ID-1: BAT1 charge: 50.7 Wh condition: 56.4/57.5 Wh (98%) volts: 17.4/15.4 model: LGC AP18E8M type: Li-ion 
           serial: <filter> status: Charging 
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600103 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71894 
           Speed: 1550 MHz min/max: 1400/3000 MHz boost: disabled Core speeds (MHz): 1: 1550 2: 1880 3: 1676 4: 1842 5: 1879 
           6: 1407 7: 1950 8: 1396 9: 1491 10: 1800 11: 1830 12: 2011 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm 
           bus ID: 01:00.0 chip ID: 10de:1f99 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel 
           bus ID: 05:00.0 chip ID: 1002:1636 
           Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 3-3:2 chip ID: 04f2:b64f serial: <filter> 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu,nvidia FAILED: ati 
           unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.3-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.2.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Acer Incorporated ALI 
           driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 05:00.5 chip ID: 1022:15e2 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.9.3-1-MANJARO 
Network:   Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000 bus ID: 03:00.0 
           chip ID: 10ec:2600 
           IF: enp3s0 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus ID: 04:00.0 chip ID: 8086:2723 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 125.77 GiB (52.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNI-82A0A size: 238.47 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 11000C00 scheme: GPT 
Partition: ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) used: 125.77 GiB (53.9%) fs: ext4 dev: /dev/nvme0n1p1 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: file size: 8.00 GiB used: 9.0 MiB (0.1%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 38.9 C mobo: N/A gpu: amdgpu temp: 37.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 314 Uptime: 1h 35m Memory: 7.21 GiB used: 3.78 GiB (52.4%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1285 lib: 351 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

there ares theses links topics

be careful with kernel5.9 and nvidias drivers ,
can this working with 450xx series ?

I don’t want to make such changes (use Nvidia only), it might cause problems, and I need my laptop for work.
What could be the problem? Maybe I should issue a bug report for KDE or SDDM or smth else?

can you provide

sudo mhwd -li

this point in log is to good

pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf >
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-455xx-prime            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

I plan to try going back to the 450 driver and see if the login problem remains. Should I do this?

or try with 450xx series

I reinstalled SDDM and 455 Nvidia driver … so far, the problem has not appeared again, I hope that this helped. If so, then it’s some kind of magic :smile:

It didn’t help. The problem appears even on the 450 driver and the 5.9 kernel. And after last SDDM update too. But now it just freezes after entering the password and pressing Enter.

I created an issue for SDDM: Hang on login screen · Issue #1330 · sddm/sddm · GitHub

Any other ideas?

Some fresh logs: Dropbox - SomeNovemberLogs.zip - Simplify your life

sometimes I have the same problem, look at this Login screen freezes, could not connect to display startx works for me.

I installed Manjaro today and am having the same problem. During the black screen I get

Failed to start Load/Save Screen Backlight Brightness of backlight:acp_video0


Failed to start Load/Save Screen Backlight Brightness of backlight:amdgpu_bl1

and on the second login screen I get to splash screen where it loads and gets stuck and my cursor is on screen and can be moved. Using safe mode worked for me though

I had the same problem with kernel 5.8.
I installed kernel 5.4. LTS and this problem didn´t occur anymore.

Got tired of it, I did a fresh install, just updated system, install programs, and so far it’s working ok. It seems like its a kernel problem, just like Keruskerfuerst said . We’ll have to wait unil 5.10 becomes stable, 5.4 doesn’t work with my laptop.

Unfortunately, my laptop will not work properly on kernel 5.4.
Let’s hope that this bug will be fixed soon.
Could it be a KDE problem?

Have you tried this? Problems when using nvidia non-free driver I did that change in the grub, and the failed to start doesn’t appear anymore.

I don’t think so, I had xfce the first time I commented the previous post.

Ah, ok.
Thanks, @guillopacheco ! I had already changed this line before (acpi_backlight). But I used the ‘vendor’ value, now I put ‘video’. I updated the grub and the system booted normally.
Let’s see what happens. The problem doesn’t always show up, I’ll test it.