KDE often freezes on login after recent updates

Dear fellow users,

my computer is currently running on Manjaro KDE edition. It was overall working fine until today, when I installed a number of updates that were recommended by the package manager.
It seems to me that there was already a problem during the update process, because I was suddenly logged out of the KDE session, but the update process continued after I logged back in and eventually finished.
Since I installed the aforementioned updates, KDE often freezes when I try to log in. The progress bar fills up to a degree, but then it stays that way. I noticed that I can still move the mouse cursor in that situation, but that doesn’t help. The only thing I can do about this at the moment is to shut down the computer by pressing and holding the on/off switch and hoping that the problem won’t occur on the next startup.
I would be thankful for any helpful hints, suggestions, etc. to solve my problem!

Hey, I’m facing a similar issue. After updating manjaro login screen freezes after entering psw.
Things I tried sofar via Terminal (crlt + alt + f3):

  • Boot kde

sudo startx


unable to connect to d-bus: using x11 for dbus-deamon was disabled at compile at compile time, set your DBUS_SESSION_BUS_ADRRESS instead

couldn't exec startkde: no such file or directory

xinit: connection to X server lost




Xauth: unable to write authority file

Fatal server error: (EE) Cannot open log file "..../Xorg.1.log”
  • added new usr. Login screen appears again after entering psw.

  • switch kernel in advanced settings didn’t bring any changes

Thanks for any ideas or replies. :slight_smile:

@Vivian I created a new topic so that I don’t undermine yours. Maybe the answers will be useful to you too.

Login screen freezes, could not connect to display

Can you check if you have ki18n-git package installed instead of ki18n?

@CarlosVGonzalez According to the package manager, ki18n is installed, ki18n-git is not installed.

@Setfiretoflames So far, I have only tried to restart KDE Plasma following this tutorial. That seems to have worked - more or less. A lot of text scrolled by, but at one point it stopped, and I’m not sure if it was finished or frozen.
Since yesterday KDE plasma has worked without any freezes - I don’t know why, maybe it fixed itself?! Since everything works at the moment, I hesitate to try anything else, but I would honestly feel much better if I knew why KDE plasma froze in the first place and if it could happen again.