Locale always resets on restart

Hello,
My system is set to english, but I noticed that winecfg and other programs are in german so I checked locale and saw this:

~ locale                                                                                                                                                                                           
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

This is my /etc/locale.conf

~ cat /etc/locale.conf
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

And my settings:
(Can’t post pictures, basically Display Language all 4 set to English US, Formats all set to Deutsch (German))

When I do
$ unset LANG
$ source /etc/profile.d/locale.sh
the locale will be correct and winecfg will be in english.

~ locale
LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

But after restarting/relogging, the config is back to the start, so something in my configuration must be wrong I guess. I installed Manjaro a few days ago.

I have no ~/.config/locale.conf, my ~/.xprofile does not export language specific variables, my /etc/environment is empty, locale-gen generates correct locales (de_DE, en_US, ja_JP, all UTF-8).
I tried the Locale page on the arch wiki, too.

I am kinda new to Manjaro, not to linux though. I recently installed an IMF (fcitx5 and mozc for Japanese character input), but that shouldn’t affect my locale settings, right?

Is there anything else I can try?

(Btw, I would like the locale to be set like it is in my /etc/locale.conf, meaning programs and display language in english, numbers, currency, etc. in german format.)

Plasma uses $HOME/.config/plasma-localerc, you might want to adjust that one:

$ cat ~/.config/plasma-localerc 
[Formats]
LANG=de_DE.UTF-8

[Translations]
LANGUAGE=de:en_US

There also is $HOME/.config/plasma-locale-settings.sh, but it has comments saying it’s generated:

$ cat ~/.config/plasma-locale-settings.sh 
# Generated script, do not edit
# Exports language-format specific env vars from startkde
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_DE.UTF-8
2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.