Live usb boot stuck when dealing with RTX 4060

Live usb boot fail with RTX 4060 graphical card

I’m trying to install Manjaro on a totally new host with intel i5-13400kf(no integrated graphical card) and RTX 4060 graphical card. After making a live usb with the latest manjaro kde iso image, It still cannot boot after the following setup:

  1. disable fastboot and secure boot
  2. tried both open source driver and nonfree driver.

Is RTX 4060 not supported by manjaro live usb yet?
Cannot setup manually.
Really need help. thanks.

try booting it with the ibt off parameter, which should no longer be needed, but try it anyway:
this is where you add it:

use Ventoy for flashing the iso…
you can download the latest from here, and download both zip files:

is the nvidia connected via cable? if so plug it directly to the motherboard and try again…

sorry for later reply, but I have tried ibt=off and it still doesn’t work. I don’t know what Ventoy is and the Nvidia GPU is connected to the montherboard using PCIe. And I decide to bypass the graphical display of live boot and install the system via the console mode directly, Hope it works and thanks for your advise.

Same issue as me.

The ibt=off method doesn’t work for me as well.
The workaround requires an AMD card to install a working copy of Manjaro first, then install the NVidia driver through TTY.
If you don’t have an AMD card, I dunno any other method that would work.

Maybe a silly question, but have you tried connecting your monitor to the motherboard hdmi and see if the usb stick can be loaded and install through there?

Have tried, and the question is that with the same configuration, another SSD which have Win11 installed can boot successfully.:disappointed_relieved:

Is this not about booting into a live manjaro usb?

Sure, I have tried with monitor connected to montherboard hdmi or graphical card hdmi, but neither works.

@bedna the OP’s CPU has no iGPU.