NVidia card + AMD CPU - Cannot boot into live media / installed OS

Please see my edit above

My PSU is 850W.
My setup has no OC.

When using RTX4060 card, I can install W11 flawlessly, using Ventoy.
So do I still need this step?

So to expand to horizon:

R290 installed

  • CSM ON mode + Secure Boot OFF
  • can install Manjaro (EFI).
  • can install W11.

RTX4060 installed

  • CSM OFF mode + Secure Boot OFF.
  • cannot install Manjaro - live media boot up stuck.
  • cannot boot from installed copy of Manjaro - blank screen.
  • can install W11.

When Secure Boot is ON, Ventoy cannot be booted due to key issue.
I tried to enroll the key, but the screen stuck.
Rebooted, retried, still same.
So CSM OFF + Secure Boot OFF, and Ventoy can be launched.

FYI, I have 2 USB drives - both GPT partitions, but one with Secure Boot enabled in Ventoy, and one with Secure Boot disabled.
Both encountered key issues with Secure Boot ON.

Not necessarily - I am throwing in ideas why you get a black screen.

CSM has nothing to do with it. If you can install Win11 which requires secure boot then you may not be able to boot Manjaro due to Secure Boot.

Could you try reaching a TTY using the described edit of the Live ISO kernel line and of course Secure Boot disabled?

Ouch - if you have not already done so - you should use your firmware to load defaults for the firmware.

Sometimes not doing so may leave behind incompatible leftovers in the nvram which needs to be removed by applying defaults.



A default install OR Live media uses real timestamps with date and time…

So yea my “accusations” are mere educated guesses…
:woman_facepalming: :woman_shrugging:

I think the whole FW update did cause a lot of issues.
And it started 1 week ago.
After the FW update, there were multiple issues - OS, GFX card, BIOS settings, blah blah.
Eventually I performed CMOS clearing, which should change all settings to default, but no help.
And that’s why I get a GFX card, cuz it seems like most likely culprit.

The SecureBoot setting needs to be done in your UEFI-BIOS, not ventoy…
For ventoy, or any other bootloader to work in combination with SecureBoot, you need to use a signed SHIM that is accepted by your UEFI-BIOS, only after that you will be able to enroll the key(s)/hashes of the other bootloaders and drivers used by the kernels…

Eg/In other words:
SecureBoot = ON ==> Blank screen using a driver that is not allowed by your UEFI-BIOS…

If you created a backup before flashing you could roll back.

Or fetch an earlier firmware from vendor’s downloadpage.

unfortunately, this board does not have dual BIOS, so cannot switch to backup BIOS when things failed.
The update process was successful - after reboot, the MB boot up with new firmware, and all previous settings reverted to default.
But when I adjusted the BIOS setting and rebooted, the MB entered into loop of endless reboot - just keep rebooting itself - status LED cycled between CPU, DRAM and VGA.
Not entering Boot Device, and no display.
So I have no way to flash any firmware.
Clearing CMOS is the only solution.
But no display still.
Anyway, this is side story - irrelevant to my current NVidia issue.

Please…i beg you when you say stuff, be EXACT of what you did and changed…
With that info ONLY, i would conclude your BIOS-Update just failed and you bricked your MB…

Plus, Please answer a simple question first:
Are you booting on bare metal or from a VM?

what settings?

error message - the only way the board can communicate error

That often helps

Not necessary - the process is exactly the same - just provide an earlier firmware …

I think it is relevant - perhaps you have placed the card in the wrong pcie slot?

Even as you state - I con boot Windows - possibly - but Windows is not LInux.

I have absolutely no ideas left.

And you have not yet provided any respnse to my query about booting to TTY from Manjaro Live ISO.

When I have already directly replied to you in post 9, that I am not using VM…
And u are asking it again in post 20?

Thanks for your time…

Yes because booting using Ventoy is NOT bare metal…
Plus we still have no command output of your exact system, just your descriptions…

So yea, i guess ill exit this stage from the right…

Sorry, I made a mistake when doing this - hence the extra time taken.

Let me understand your approach:
This TTY approach is using the TTY from live media, to install NVidia driver, directly into an installed version of Manjaro?

I managed to boot into TTY, and following your guide, it prompted me to choose which Linux to mount, then it installed the NVidia driver.
Right now, with RTX4060 installed, CSM OFF, Secure Boot OFF, I’m able to boot into the previous installation of Manjaro (the successful installation from R290).

So, the next question is: how about booting a live media to install new copy of Manjaro?

Fantastic :raised_hand_with_fingers_splayed:

That would be using the proprietary driver selection in the ISO boot menu.

I tried this approach previously - stuck.

If you have a working installatin now - why would you reinstall - simply updating your system will suffice.

sudo pacman -Syu

I cannot help you there - you may need to add specific instructions for the kernel - same method as adding the boot to runlevel 3.

But those kernel arguments I have no knowledge about - I keep Nvidia at a distance - so I cannot help you with that.

New issue:
I can boot into Manjaro now.
But some apps cannot be launched.

Telegram (Flatpak) reported OpenGL disabled, and cannot launch.
After I clicked OK, it launched…

QBitorrent (Flatpak) failed to launch, no error prompted - just no response after clicking.
Makemkv (Flatpak) also failed.

Reboot, and still same.

I uninstalled, and reinstalled back.
During installation, the flatpak installed org.freedesktop.platiform.GL.nvidia.
And these 2 apps working now.
I guess org.freedesktop.platiform.GL.nvidia makes all flatpak working in NVidia now.

Still trying to find a way to install Manjaro with Nvidia card installed…

New issues are best tackled in new topic(s)…

Remove the flatpak apps and reinstall them

For installing anew you would likely need an ISO with the newer drivers.

For the benefits of other users experiencing the same issue with NVidia card,

This above would allow an installed Manjaro to boot using NVidia card.
ie. You need an installed copy of Manjaro + a working version of live media.

After booting into Manjaro, some of the apps would need to be refreshed - uninstall and reinstall.

I still haven’t found a way to boot into live media on Nvidia card - which as @linux-aarhus said: maybe the solution is to wait for new manjaro ISO with newer Nvidia drivers.