Libreoffice is broken

the actual update has broken libreoffice. seems there is a packaging error. uninstalled libreoffice, used a fresh install from package-manager but it doesn’t work.

be more specific on which package you have installed and the exact version and branch.

installed version of libreoffice:

7.4.6-1 from the official extra repo

pacman-mirrors -G


  Kernel: 6.1.29-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=b8ddf48f-df06-4600-91b1-746ba323dc6b rw quiet audit=0
    usbcore.autosuspend=10 btusb.enable_autosuspend=n
    psmouse.synaptics_intertouch=1 rfkill.default_state=1 mitigations=off
    pcie_port_pm=off usbcore.blinkenlights=1
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux

So you mean the still branch: Packages

What is the issue? What happens if you call libreoffice from a terminal?

nothing happens. there is no warning or error while calling



libreoffice --writer

it’s stuck, no response.

btw: i tried it on 2 different computers, my acer-laptop and an mac 12,2.
both use the actual manjaro-stable-branch and have the same behaviour.

[xxx@xxx ~]$ pacman-mirrors -G
[xxx@xxx ~]$ inxi -Fza
  Kernel: 6.3.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.3-x86_64
    root=UUID=8c3416f2-d9e9-4fc5-9bf0-304d140efc8c rw quiet audit=0
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Apple product: iMac12,2 v: 1.0
    serial: <superuser required> Chassis: type: 13 v: Mac-942B59F58194171B
    serial: <superuser required>
  Mobo: Apple model: Mac-942B59F58194171B v: iMac12,2
    serial: <superuser required> BIOS: Apple v: IM121.88Z.0047.B1F.1201241648
    date: 01/24/12

Works here.

Though there was recently an issue where it wouldnt open …

Found it was actually the editions - writer, etc … libreoffice the umbrella would open … then choosing to launch writer from there, such as by selecting a document, would fix it. Subsequent opening of writer on its own would work as expected.

(while the exact cause wasnt found… it leads me to believe some form of config/cache may be the culprit)

1 Like

deleting the ./config/cache didn’t affect anything. still stuck

C’mon… I know you know better. I guess we’ll have to send you to the Newbie Corner. :stuck_out_tongue_winking_eye:

Don’t do this

It doesnt work!!!

That is not output, that says absolutely nothing. It’s probably the most useless thing you could post.

Post complete logs/output/versions/error messages / Newbie Corner / Arch Linux Forums

1 Like

well maybe, but there are no logs, no errors, nothing that could point to the cause your Excellence.
this is on 2 different machines the same behaviour.

What behaviour?


No one here is better than anyone else. Let’s all be excellent to one another. :guitar:

1 Like

What has happened in the past (twice for me) is that it does open but the window is very small, like a vertical line. Find it expand it and you won’t have the problem again. Here is a link that explains it better than I did LibreOffice Calc Does Not Open Correctly After Recent "Testing" Update? - #2 by megavolt There are a few more

How long do you wait? There was a bug that made certain packages like firefox and libre office take ages to open. The solution was to remove an orphan package which I’m sure someone will chime in with if that’s the issue

It wasnt necessarilly orphaned.
But a lot of people had accidentally pulled a non-matching version of desktop-portal (either because of fltapaks or some other installation).
Specifically the gnome one was buggy, and especially on non-gnome DE’s.
Depending on your situation it might mean remove or replace with another, such as gtk or kde.

Heres the post philm has been tagging on the announcements:

1 Like
  • There was this Topic, but I’m not sure of the solution (language: german)

  • Reboot after install

  • Are there any coredumps (coredumpctl)

  • Is there perhaps a libreoffice already running that is hung (i.e., zombie) (ps -p $(pgrep -fd ',' soffice || echo $$) -F)

  • Can libreoffice be started in --safe-mode

  • There is some libreoffice troubleshooting info at wiki.archlinux.

    In one case opencl is mentioned. I looked at my Tools> Options > LIbreOffice > OpenCL and it is not checked.

I am not having any problem with libreoffice. My software enivronment:

===> pacman -Q ‘libreoffice-still’
libreoffice-still 7.4.6-1



1 Like

Does the process remains in the background or does it dies immediately?

Usually, from experience, OpenCL is the culprit.
Can you temporarily remove the directory ~/.config/libreoffice and test again?

yes it stays in background

ps -ax 

shows up a running process that i can kill

i already tried without success

After executing Libreoffice try to maximize the window with Meta+PageUp. I think some of the users (including me) have had the problem that it starts with a non visible window size.

there is no window