Libreoffice is broken

That’s the thing, it has some non working size that you don’t see anything. You have just to be sure that it has focus and press the combination I mentioned: Meta+PageUp

Edit: This is the same that @fbt89 was also talking about

for whatever reason it also installed onlyoffice-desktop with libreoffice. that’s a weird mixed up. downgraded libreoffice and same result.

Install LibreOffice from flatpak, problems solved.
LibreOffice was also broken for me, although it started if I launch from terminal. The problem was solved in the flatpak package.

I would concentrate on this. It sounds like, libreoffice started but the window is not visible to you. I would stop “installing/reinstalling/removing” libreoffice.


  1. Libre Office Writer Window No Longer Visible

  2. Main UI of all applications won't show all of a sudden - English - Ask LibreOffice

  3. If you alt-tab (task switcher), does it show up and is it selectable.

  4. Is there some indication (i.e., icon) that libreoffice is running from the KDE panel. Hover over the KDE panel. If there is, you can right-click, select More and select a window property like resize, maximize, etc.

  5. The below was probably a typo, but did you delete the contents of $HOME/.cache/ (notice the . in front of cache). Logoff/on after doing the remove.

  1. [Solved] LibreOffice Writer misbehaving / Applications & Desktop Environments / Arch Linux Forums
    Note the wmctrl -r libreoffice -e 0,128,128,512,512 command.

This seems like a common issue, where libreoffice is running but the window is not visible for whatever reason.

1 Like
0x01600011 -1 pebbles Arbeitsfläche @ QRect(0,0 3840x2160)  — Plasma
0x0160001b -1 pebbles Plasma
0x0680002c  2 pebbles Startpage - Private Search Engine. No Tracking. No Search History. — Abrowser
0x03c00008  0 pebbles patchbay — A PipeWire Graph Qt GUI Interface
0x06c00065  0 pebbles Software hinzufügen/entfernen
0x06800165  0 pebbles NixOS Setup Guide - Configuration / Home-Manager / Flakes - YouTube — Abrowser
0x068001a5  0 pebbles Manjaro Downloads — Abrowser
0x068001d0  0 pebbles Nixos Vorteile | Linuxteaching — Abrowser
0x06600004  0 pebbles Shortwave
0x068001f4  0 pebbles Comment and uncomment blocks of code | MPS Documentation — Abrowser
0x06a00009  0 pebbles PycharmProjects — Dolphin
0x0680021c  0 pebbles Libreoffice is broken - Support / Software & Applications - Manjaro Linux Forum — Abrowser
0x06e0000a  0 pebbles ~ : bash — Konsole
0x07000001  0     N/A LibreOffice

Thanks for the tip with wmctrl. that brings up a really curious thing. as you can see the command

wmctrl -l

list all open windows i’m using in the moment. all x11-windows are in conjunction with my machine “pebbles” but LibreOffice does not, it is N/A

Any conclusions @all ?

from my understanding, libreoffice starts (yes a process is started with pid) but there is no graphical window created. usually if you start a app like libreoffice in a terminal and there are problems with plasma/qt then errors and failure messages are spilled out but it does not and therefor are no messages in the log files. that’s what happens here.