Laptop suspends when lid closes despite power settings

Manjaro XFCE Mikah 20.1

Power manager settings:

imgur com/a/jrlgncZ

I have my laptop connected to an external monitor via hdmi. In display manager, the laptop screen is already turned off. When I close the laptop lid, I expect nothing to happen thusly. However in reality the external monitor goes black because the laptop has suspended. How do I make it behave?

Do you have a swap partition?



in terminal to find out. Also, please paste the output here.

I don’t have swap

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
nvme0n1                                       259:0    0 476,9G  0 disk  
├─nvme0n1p1                                   259:1    0   300M  0 part  /boot/efi
└─nvme0n1p2                                   259:2    0 476,6G  0 part  
  └─luks-72aea425-613d-4a0d-a0e2-d679a9e50959 254:0    0 476,6G  0 crypt /

Do you have a live usb you can boot from?

If so, boot from it and shrink one of your partitions with gparted by 8 GB.

Then, make a new partition in gparted that is 8 GB.

Then go to terminal and:


Look for the new partition and then type:

sudo mkswap /dev/(whichever partition is new)


sudo swapon /dev/(whichever partition you just turned swap on for)

then this command

sudo bash -c "echo UUID=$(lsblk -no UUID /dev/your-partition-name) none swap defaults 0 0 >> /etc/fstab"

to add it to your /etc/fstab file


You can also follow this guide^^^

Hi, I don’t really see what an on disk memory pool has to do with unwanted suspending? You might be thinking of hibernating and saving state to disk which to reiterate is even further from what I want.

I also do not want a swap because it murders my ssd writes.

I apologize. That was my misunderstanding.

As a side note, I enabled the noatime flag in my fstab and have had 0 issues with read/write with a swap file.

I will continue to try and help if that’s okay…

Also, the reason I suggested the swap file is because I was having the same issue with my laptop when I first got it and I made the swap file and the problem went away.

1 Like

Interesting, but I’d still rather not use a swap. Sorry for my rude tone.

No problems. I will keep searching for a solution.

Unfortunately, I can’t post links on here,

but there is a discord server for Manjaro support.

They are extremely knowledgeable and have helped me twice. If I am not mistaken they are the ones that helped me when my laptop was doing this.

I will continue looking though.

Here is the discord invite code:


1 Like

This is what they told me to tell you:

<@!400290721396948992> tell them to edit /etc/systemd/logind.conf and set HandleLidSwitch=ignore in there

I have opened #ticket-0336

I already read that on another forum but it doesn’t seem to do anything (I have rebooted since editing)

$ cat /etc/systemd/logind.conf 
#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
# See logind.conf(5) for details.


I have this same issue. I do have swap configured for hibernate.

My system is a Thinkpad E595 with the USB-C dock with external monitors connected to that. Running Manjaro XFCE, fully updated.

Uname info:

5.8.6-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:19:36 UTC 2020 x86_64 GNU/Linux

What’s interesting is that I can initiate a reboot, then close the lid and all the bios will show on the external monitor, unlock the disk, and show the login screen just fine. But as soon as I log in, the system suspends itself and the screen goes black.

I’ve edited the logind.conf file to ignore all of the lid related stuff, and tried every permutation of power/lid related config I can find in the GUI tools. Full reboot after every single config change.

Any thoughts or suggestions?

$ lsblk
NAME                                        MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
nvme0n1                                     259:0    0  1.8T  0 disk  
├─nvme0n1p1                                 259:1    0  300M  0 part  /boot/efi
├─nvme0n1p2                                 259:2    0  1.8T  0 part  
│ └─luks-dc5a97cc-2ec8-4d6e-8ccd-4de5363805c3
│                                           254:0    0  1.8T  0 crypt /
└─nvme0n1p3                                 259:3    0 32.3G  0 part  
                                            254:1    0 32.3G  0 crypt [SWAP]

I filed this bug report with xfce4, perhaps if you comment your stuff as well they can get it fixed sooner

I fixed it!!

Here’s what I did:
Uninstall light-locker package
Reboot (probably not necessary)

Logged in, lid open:
Display settings, enable laptop display (
External monitor is primary display

Use these power manager settings:

You can now close the lid, and the laptop screen will turn off, while the session remains uninterrupted.

Edit: nvm , even though the laptop screen goes black, it doesn’t turn off. It is still being rendered to in the background, I know this because I get screen tearing on my external monitor when both laptop and monitor are on (laptop is 60.1Hz, the monitor 60.0Hz). Disabling the laptop display in the display settings manually reintroduces de bug. Not doing so introduces screen tearing.

What may help to prevent ext. monitor to turn off upon lid close is this one liner command:

sed -i "s|#IgnoreLid=true|IgnoreLid=true|g" /etc/UPower/UPower.conf;sed -i "s|IgnoreLid=false|IgnoreLid=true|g" /etc/UPower/UPower.conf;sudo systemctl restart upower.service

That’s like dropping a nuke. It’s not like I never want it to act on it. I just don’t want it to disable my ext monitor. It can disable the built in display all it wants. In any case I have already achieved the desired behaviour, but thanks for the help.

Fix in this thread:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.