Laptop lid clopsed means external monitor goes black screen

I am having the same problem as user here.

Ho can i close laptop lid and continue working on the external monitor? I already set my ext. monitor as default and set lid close action to lock screen. Other options are unacceptable (computer suspend, turn off screen).

1 Like

gnome-tweaks has an option that prevents suspending the machine when the lid is closed. Which desktop environment do you use?

i forgot, default XFCE… suspension is not problem, just that it turn off the external monitor screen (connected via HDMI)

That option in gnome is exactly what you want, I think. It doesn’t turn off the external monitors, only the internal display.

I think this may be relevant. Isn’t there an option like “do nothing”?

no, it is not (they forgot to add it maybe).
btw gnome-tweaks does not seem to be working on XFCE.

Yes, it probably won’t work. What are the options, then?

Switch off display
Suspend
Hibernate
Lock screen

first and last = screen turns black

Have you tried the last two suggestions there ?

Another option to try: edit /etc/systemd/logind.conf, and change

#HandleLidSwitch=suspend

to

HandleLidSwitch=ignore

then

sudo systemctl restart systemd-logind

no, that does not affect it, it continue to shut off the external screen when lid closed. reboot done.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=ignore
##HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RuntimeDirectoryInodes=400k
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192

1 Like

postcd,
Uncomment line in file
/etc/UPower/UPower.conf

IgnoreLid=true

And you could disable built-in laptop display in Display settings near selectbox with display name.
Or make external default one. That’s need in case when some prompt window appears, like prompt for entering password in Firefox etc.

1 Like

That UPower.conf modification seems to be the one that works. Thank you for sharing that.
Note that you have to then restart this service: sudo systemctl restart upower.service