Laptop display detected but not working

Help. i have an intel N2840 laptop. Everything was working perfect. I use both my laptop display and a secondary display through hdmi . But after update and reboot both screens are detected but only my secondary screen is working. My laptop display is ok till the boot screen and the grub menu. But after that and before manjaro starts it s getting black. I checked a lot of things… Tried many different kernels…nothing. Checked brightness… everything appears ok.
Everything else is ok except this. I can use a second display but the problem is that I use this laptop at work and i need to take it with me very often.
I would appreciate any help!

And since you tagged your topic with i3, you checked also your configs, right?


Did you try to activate the laptop screen with xrandr?

Please post your full system information: [HowTo] Find system information

of course i did. it appears detected and connected

Screen 0: minimum 320 x 200, current 1680 x 1818, maximum 16384 x 16384
eDP-1 connected primary 1366x768+157+1050 (normal left inverted right x axis y axis) 309mm x 173mm
   1366x768      59.99*+  40.02  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
VGA-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1680x1050     59.95*+
   1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98  
   1920x1080i    60.00    50.00    59.94  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  

my full information:

  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=a81d12d0-2400-4f56-91dd-948ef50ca9d7 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: i3 v: 4.22 info: polybar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP 14 Notebook PC
    v: 096E120000405F00050360180 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 220F v: 57.58 serial: <superuser required>
    UEFI-[Legacy]: Insyde v: F.44 date: 03/12/2018
  ID-1: BAT1 charge: 27.5 Wh (86.5%) condition: 31.8/41.4 Wh (76.7%)
    volts: 16.3 min: 14.8 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: not charging
  RAM: total: 7.65 GiB used: 4.73 GiB (61.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron N2840 bits: 64 type: MCP arch: Silvermont
    level: v2 built: 2013-15 process: Intel 22nm family: 6 model-id: 0x37 (55)
    stepping: 8 microcode: 0x838
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 2584 min/max: 500/2582 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 2584 2: 2584 bogomips: 8671
  Flags: 3dnowprefetch acpi aperfmperf apic arat arch_perfmon bts clflush
    cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est
    fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx monitor movbe
    msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs pge pni
    popcnt pse pse36 pti rdrand rdtscp rep_good sep smep ss sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer
    tsc_known_freq tsc_reliable vme xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-7
    process: Intel 22nm built: 2012-13 ports: active: HDMI-A-1,eDP-1
    empty: DP-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300
  Device-2: Realtek HP Truevision HD integrated webcam type: USB
    driver: uvcvideo bus-ID: 1-4:4 chip-ID: 0bda:5776 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: Picom v: git-b700a driver:
    X: loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1818 s-dpi: 97 s-size: 438x474mm (17.24x18.66")
    s-diag: 645mm (25.41")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: top-left model: Samsung SyncMaster
    built: 2008 res: 1680x1050 hz: 60 dpi: 267 gamma: 1.2
    size: 160x90mm (6.3x3.54") diag: 184mm (7.2") ratio: 16:9 modes:
    max: 1680x1050 min: 720x400
  Monitor-2: eDP-1 pos: primary,bottom-r model: BOE Display 0x0602
    built: 2014 res: 1366x768 hz: 60 dpi: 112 gamma: 1.2
    size: 309x173mm (12.17x6.81") diag: 354mm (13.9") ratio: 16:9
    modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:0f04 class-ID: 0403
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active
    tools: pacat,pactl,pavucontrol,pulsemixer
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 1000 bus-ID: 04:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-3.3:6 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 176.99 GiB used: 58.71 GiB (33.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Plextor model: PX-128S3C
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 1.04 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 57.75 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 119.24 GiB size: 116.81 GiB (97.96%)
    used: 23.97 GiB (20.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: a81d12d0-2400-4f56-91dd-948ef50ca9d7
  ID-2: /mnt/doc-server raw-size: N/A size: 228.16 GiB
    used: 129.67 GiB (56.8%) fs: cifs dev: /dev/documents-server
  ID-3: /mnt/media-server raw-size: N/A size: 931.51 GiB
    used: 363.9 GiB (39.1%) fs: cifs dev: /dev/volume(sda1)
  ID-4: /mnt/music-server raw-size: N/A size: 447.13 GiB
    used: 409.98 GiB (91.7%) fs: cifs dev: /dev/patriot-burst
  ID-5: /mnt/videos-server raw-size: N/A size: 233.25 GiB
    used: 127.65 GiB (54.7%) fs: cifs dev: /dev/videos-server
  ID-6: /mnt/videos2-server raw-size: N/A size: 228.16 GiB
    used: 16.01 GiB (7.0%) fs: cifs dev: /dev/videos2-server
  ID-7: /run/media/aris/ΛΗΨΕΙΣ raw-size: 57.75 GiB
    size: 56.54 GiB (97.91%) used: 34.74 GiB (61.4%) fs: ext4 dev: /dev/sdb1
    maj-min: 8:17 label: \xce\x9b\xce\x97\xce\xa8\xce\x95\xce\x99\xce\xa3
    uuid: 2a689970-092c-463b-8f0e-239225dec0c5
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: MosArt Wireless Keyboard/Mouse type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 062a:4101 class-ID: 0301
  Hub-2: 1-3:3 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1a40:0101 class-ID: 0900
  Device-1: 1-3.2:5 info: Kingston DataTraveler 100 G3/G4/SE9 G2/50
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s
    power: 300mA chip-ID: 0951:1666 class-ID: 0806 serial: <filter>
  Device-2: 1-3.3:6 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.1 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
  Device-3: 1-4:4 info: Realtek HP Truevision HD integrated webcam
    type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 0bda:5776 class-ID: 0e02 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 1 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 199 Uptime: 9h 4m wakeups: 4 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1466 libs: 354 tools: pamac,paru,yay Shell: Bash
  v: 5.1.16 running-in: ranger inxi: 3.3.26

Moderator edit: Updated inxi info

Looks like your laptop display is set offline.

 xrandr --listactivemonitors 

Edit: Some notebooks allow disabling the screen by FN-Keys, so switching the output. Maybe that could be the problem?

i m sorry i ran inxi having it deactivated
now it is on, detected, connected but black

Monitors: 2
 0: +*eDP-1 1366/309x768/173+157+1050  eDP-1
 1: +HDMI-1 1680/160x1050/90+0+0  HDMI-1

everything was perfect before last big update 2-3 weeks ago
of course i have installed all new updates since then, but nothing fixed

Moderator edit: Updated inxi info above

That’s really strange. What xrandr command did you use to set this? I can now only imagine that the screen output has been shifted too far and is therefore black. You have checked the screen brightness, anyway…

i just ran xrandr with no parameters

This is a screenshot from arandr. My hdmi monitor is working absolutely fine. It doesnt look shifted away. Laptop display is set exactly below my hdmi monitor

Did you try running a live session? Does it work there? Maybe there is something wrong with the screen brightness. Everything else seems to be okay-ish.

Increase it by:

xbacklight -inc 10

i tried it…nothing changed cause brightness is at 100%. And the display is working till the boot screen… i can change kernels before starting manjaro on my laptop display just fine. The problems starts when manjaro starts

If a live session (booting a Manjaro ISO) and the brightness control changes nothing, then I would say it is a hardware defect.

Get a flashlight and shine it on the screen. Can you see anything then? If so, then the backlight is dead.

the screen works absolutely fine at start. i can get into bios setup, or grub menu just fine. The problem happens after the boot menu

Then please provide a full journal log of the current boot:

journalctl --boot 0 | curl -F'file=@-'

this is such a large output to post there any other wayto post it here?

Erm… the command above should upload the output and print a link?

my bad sorry. i tried to paste the output here.
here’s the link

Απρ 21 14:36:52 manjaro-hp systemd[1]: Created slice Slice /system/systemd-backlight.
Απρ 21 14:36:52 manjaro-hp systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
Απρ 21 14:36:52 manjaro-hp systemd[1]: Finished Load/Save Screen Backlight Brightness of backlight:intel_backlight.
Απρ 21 14:36:52 manjaro-hp audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=unconfined msg='unit=systemd-backlight@backlight:intel_backlight comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Works :white_check_mark:

Απρ 21 14:37:21 manjaro-hp pkexec[1101]: aris: Executing command [USER=root] [TTY=unknown] [CWD=/home/aris] [COMMAND=/usr/bin/xfpm-power-backlight-helper --set-brightness-switch 0]
Απρ 21 14:37:21 manjaro-hp pkexec[1131]: pam_unix(polkit-1:session): session opened for user root(uid=0) by (uid=1000)
Απρ 21 14:37:21 manjaro-hp audit[1131]: USER_START pid=1131 uid=1000 auid=1000 ses=2 subj=unconfined msg='op=PAM:session_open grantors=pam_systemd_home,pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/pkexec" hostname=? addr=? terminal=? res=success'
Απρ 21 14:37:21 manjaro-hp pkexec[1131]: aris: Executing command [USER=root] [TTY=unknown] [CWD=/home/aris] [COMMAND=/usr/bin/xfpm-power-backlight-helper --set-brightness-switch 0]

You set bright to 0 with xfpm-power-backlight-helper ok…

Απρ 21 14:53:13 manjaro-hp pkexec[7607]: aris: Executing command [USER=root] [TTY=unknown] [CWD=/home/aris] [COMMAND=/usr/bin/xfpm-power-backlight-helper --set-brightness 7812]

and here you set it to 7812.

Sorry, I have no idea what wrong on your side. Possibly it controls the wrong device since the update? Maybe have look at this wiki article: Backlight - ArchWiki

ls -R /sys/class/backlight 

thanks for your time :slightly_smiling_face:.
i ve been trying to find a solution the last 2-3 weeks.
i hope someone else can see what is wrong here. i really enjoyed manjaro on such an old but useful laptop

I see… this in the wiki:

Since Linux 6.1 the backlight subsystem was revamped, if your backlight does not work after an update first try to remove an existing acpi_backlight kernel parameter.

Add acpi_backlight=video to the kernel parameter. Maybe that helps.