Kvantum is causing problems

Kvantum is causing problems making PAMAC and KeePassXC popup in white, everything else seems to be obeying the dark theme. I cant work with a white screen.

Thought it was just:

but I found also that kvantum-manjaro is required by manjaro-xfce-settings
So ignored all 4 updates but still same effect !

so now I’ve only updated glibc and both appear fine.
So what is causing this ?


I replaced the kvantum-theme-matcha dependency with kvantum-manjaro as it’s been more recently updated.

kvantum-theme-matcha hasn’t been maintained upstream for almost 4 years.
The developer asked me about two years ago to remove his packages from the repos. That’s the only one left as it may still work alongside the matcha-gtk-theme on at least Xfce.

1 Like

I’m using timeshift only on the system partition, so when I timeshift back and forth my ~/.cache wouldn’t matter. Besides I don’t see any pamac stuff only an ini file for KeePassXC.

The pamac GUI is GTK-based — gtk3 for pamac-gtk3 and gtk4 for pamac-gtk — so kvantum cannot have any effect on that.

It’s probably a matter of cache and/or permissions. Make sure that you clean out ~/.cache and that your dark themes are installed as they should be.

pamac is gtk-based and therefore uses gtk themes. On my system, those are installed in ~/.themes. There are however different configuration files for the different gtk generations under ~/.config.

KeePassXC is a qt5 application and will follow the qt theme as set in the Plasma System Settings, or in qt5ct if you’re not on Plasma.

I’m on XFCE

Then use qt5ct. :wink:

Dont have a .themes in home dir

Well, it’s your system, so figure out where it stores your themes. I’m on Plasma, so I cannot check that for you. :man_shrugging:

Cant see how to use qt5ct, not convinced it’s that if one is gtk the othe qt.

i’ll do the usual tomorrow install half the updates and so on till I find the culprit or do a reinstall.

(The fonts are what come with manjaro-Xfce and was reinstalled after hardware failure 6 weeks ago)

@jaroMAN Note that I’ve moved the discussion to a new thread. :wink:

If it’s not installed, then install it. It’s in the repository. And if it is installed, use it to select the theme for your qt applications.

Note: You have to set the qt style to kvantum in qt5ct in order to be able to load a kvantum theme into the kvantum manager.

Your package manager will tell you so, if only you look. keepassxc has qt5 as a dependency, and both of the pamac GUIs are gtk-based, as I already told you.

Unfortunately, after removing the now orphan kvantum-theme-matcha, what is left in the kvantum selector, like kvMatchaDarkSea or DarkAzul, is not dark at all. There are other dark themes working, but no matcha anymore.

So if you are using MatchaDarkSea for example in the Appearance settings and want a matching experience in Qt, dark, kvantum-theme-matcha is still the only way. Old or not, you may remove it from default dependencies, but pretty please do not remove it from the repos.

1 Like

blargh … are there no alternatives for you QT-on-GTK folks?
I can look at the matchama (especially kvantum) stuff again if its really needed.

PS … regardless of its state in the repos … you may find the project here:

1 Like

Inrerestingly, with both KeePassXC and Pamac up and by cycling through the inbuilt adwaita and matcha’s in “appearance” I can see the only dark theme that works is Adwaita-dark which is what I use and this is the status before today’s updates.
So looking like find a dark theme on internet or see what other distros do these days…

You are on XFCE … which is not only GTK , but a turtle in terms of development.
So its behind other GTK desktops like Gnome, which is now using GTK4 (And specifically libadwaita) … which is not going to be supported by every theme that ‘works’ on XFCE.
pamac now is also gtk4 (and libadwaita)
If you want an older pamac, for now you can use pamac-gtk3

1 Like

Hi @jaroMAN ,
I am on XFCE an I solved the problem removing kvantum:

sudo pacman -Rdd kvantum

Then, as was posted on the stable release announcment I also run:

sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

because it requires manual intervention.

Hope it helps, regards

1 Like

Removing kvantum is a very drastic “solution”, if one continues to use QT apps, they will be even more ugly.
And pamac is either a gtk3 or gtk4 app so it does not use kvantum anyway.
Just don’t remove the now orphaned matcha package, or select another similar dark theme from kvantum, like the adwaita ones work.

1 Like

Issue with pamac GUI theme on Xfce was reported 3 months ago and is still included in stable update announcements:

pamac GUI is based on GTK not QT so it does not need qt5ct or kvantum on Xfce

IMO suggestion to remove kvantum is misinformation from KDE users

1 Like

No, its just a false assumption that OP made, which has been debunked a few times.

First line, first post:

The other component of the post does have to do with QT.

It all boils down to not understanding the theme frameworks. :person_shrugging:

1 Like

Xfce and Budgie ISOs include kvantum and kvantum-theme-matcha
Gnome and Cinnamon ISOs include kvantum and kvantum-manjaro

IMO It would make more sense to have kvantum-manjaro on all DEs