[Stable Update] 2023-10-09 - Mesa, Grub, GlibC, Thunderbird, KDE Frameworks Renaming

Update failed using pacman-mirrors -f && sudo pacman -Syyu but updating via GUI/pamac worked.

One minor thing that caught my eye is that favorites in the application overview are no longer in the order I set.

The update also solved a problem I had been having for some time where icons on the desktop would no longer show as highlighted after they were selected. :+1:

1 Like

Thank you for getting the security fix for glibc out!

I’m also getting a renamed GTK package, before updating:
libgedit-amtk and amtk are in conflict
and Pacman wants me to remove the latter [y/N]

Says the package amtk was renamed here:
“The project has been renamed to libgedit-amtk and is now hosted on…” Gedit Technology.

So it’s probably reinstalled under the new name during the process.

8 posts were split to a new topic: Kvantum is causing problems

Never use sudo with pamac. It will mess up the permissions on your package databases.

pamac is intended to be run with the user’s own privileges and will prompt you for a password when needed.

It simply implies that there will be a choice when Plasma 6 hits the repos, so that no packages from Plasma 6 will be overwriting packages needed in Plasma 5.


A post was merged into an existing topic: Kvantum is causing problems

7 posts were split to a new topic:

:trophy: :trophy:


Somehow — only the universe knows why — my Plasma desktop was once again completely screwed up after updating. The symptoms were the same as the last time.

I had to restore a full system backup — and a separate (and even earlier) copy of my $HOME, because the copy in the last backup was corrupt again as well — and then run the update process all over again. And then it all worked out fine again. :man_shrugging:

After reading this update announcement as I always do the update went fine
(I did sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\* and said Yes to replace some packages), the only thing I noticed is that pamac in now full white (it had a dark theme like the rest of my system) but not bothering me at all since everything is working as it should.
Manjaro XFCE for more than 3 years here.

The update with pamac GUI went fine on my PC but my AMD Laptop (with a little newer Manjaro install) showed a popup message that a few locale files are backed up under the restart button, after i try to select this info’s about the files with ctrl+a and try to copy them with ctrl+c the OS froze instantly.

I had to press the powerswitch to shutdown my AMD Laptop, the OS normaly booted after this again (after a orphan message spamm, while booting :crazy_face:)… is there anything i should do about this backup files? I don’t see any errors in journal btw.

The strange thing, in testing branch Topic, i saw people had a refuse install from it… thats why i though i just blindly install this update… didnt expect a system freeze because of it and also wondering why i have this files on a newer install, while also having even less package installed on my Laptop.


pacman -Qi glibc-locales

Required By     : None
Optional For    : None

Looks save to uninstall on my Laptop, no idea why it was installed at all.

Easy fix: replace pamac-gtk by pamac-gtk3. :wink:

1 Like

For some reason I doubt this…


After pamac upgrade and reboot I can’t login into system via gdm or ssh. Always “bad password” message…

1 Like

You can just hit enter for the KDE packages, you’ll see when you have to stop doing that because the packages are listed in alphabetical order.

One GTK package was also renamed, here you have to confirm the removal of amtk (it’s renamed and reinstalled as libgedit-amtk) by y+ENTER, it is the last of the packages to show up.

I can not confirm any of the KDE issues above, the favorites list in Appl. Launcher is untouched. But then my install is from June this year, and I’m not using Kvantum and stayed with Breeze/Breath.

I have 2 smaller, tiny issues, one already after the last update, one forever, Web Browser widget and 2 apps that don’t save the screen they’re being started on (flatpak Duolingo, portmaster-stub) that I’ll open topics for shortly.

Thank you for this update!

Due to renaming of KDE Frameworks the packages might get removed and installed fresh. during this process some local settings may restored to default ones, if anything was changed …


Ah, that might explain it. :wink:

Hi everyone,

I got the glibc-locales error. I ran the suggested fix:

sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

But the error persists – I am still geting the message (the end of a long list):

glibc-locales: /usr/lib/locale/zu_ZA.utf8/LC_TIME exists in filesystem
Errors occurred, no packages were upgraded.

What are other options to fix this?

Did you reboot before you tried the update again?
After a reboot, can you try with

sudo pacman -Syyu 


Before the last 2 updates, I had had stuck sddm screens (on Plasma) for up to a minute or so randomly at times after the password input and ENTER.
This seems to have gone with the SDDM or shells pacnew :slight_smile: .

There seems to be an issue with grub/btrfs in the latest update.
I just tried fresh install and after the first update without installing anything else
@ boot i get this error:
error: file “/@/boot/grub/x86_64-efi/bli.mod” was not found.
System boots fine after a few seconds.
I tried install on both encrypted drive and nonencrypted using btrfs. Same issue on both.
After boot running grub-install as root solves the issue.

Thank you for this. It explains why in recent months I’ve had to rebuild my pacman keys so often. I’ve been screwing things up by running pamac via sudo. A lesson learned.