Keyboard "super" (windows key) key turns black screen

With normal developer use, using nodejs, git client, web browser, vagrant, after hours of use, randomly the following happens:
When you press the “super” key on the keyboard to open the xfce whisker menu, the screen goes black with cursor. I press Ctrl + Alt + F7, and it returns to my desktop, where the displayed whiskey menu appears.

I started closing open processes, and nothing. Until I closed, process xfce4-session, which closed my user session. I opened it again and the “super” button on the keyboard returned to normal operation, opening the whisker menu without locking the screen to black.
With this it seems to me that the problem may go in xfce4 session.

Edit:

Checking more, after leaving the system constantly suspended for a long time, the above mentioned error appears. It only happens sometimes, so I can’t confirm it, but it may be related

My setup:
4790k cpu
rx580 8GB sapphire nitro vid card
Logitech 710+ keyboard
Logitech g600 mouse
z97mpro4 motherboard
1440p 144hz ips monitor
intel 750 800GB pci express ssd ( manjaro …was installed into)
1TB 860 samsung evo drive ( games, docs, etc)
1TB 860 samsung evo drive ( gopro backups)
1TB micron drive ( timeshift backups for mint 20 installation)

I experienced this exact same problem also on Manjaro 20

It began occurring some random time after I either copy and pasted some files from a separate storage drive into my Manjaro-installed drive, or while I was fighting with the xfce panel trying to set it up like I have my Mint 20 cinnamon panel. Or, possibly it began as a result of an update. ( good grief…the creators of xfce need to take a lesson from cinnamon. Legit, cinnamon is so much easier to deal with)

The thing is, I confirmed over and over that both the left and right super keys had absolutely nothing to do with ending the xfce4 session. So when I pressed the super key by itself, it was only supposed to open the whisker menu, but it would basically crash the session/put it in a temporary coma and it would stay that way ( I literally waited over an hour for it to auto come back and never would) until I pressed ctrl alt F7. Then everything came back within 3 seconds or less with the whisker menu open as it should be.

I’ve looked all over the net and your post , zimudec, is the only thing I’ve encountered about this.

Surely someone out there has a fix for this odd and seemingly simple problem. I even purposely changed the default end-xfce4 session OOTB keyboard shortcut key combo to something completely different that I would never use ( I think ctrl alt shift = or +…something like that) and the problem still persisted.

Upon a fresh install of Manjaro 20, the problem is gone, but it reappears after some random time or doing something. I have yet to figure this out

Unfortunately as often as I use the left super key to open that menu ( just like i did in windows from 7 onward and mint cinnamon), this problem makes it a deal-breaker for me trying to use Manjaro, and that saddens me a little. I really wanted to test to see if kernel 5.8 would yield a little better/more stable frame times gaming results for my setup; not that my Mint 20 cinnamon install isn’t solid so far.

Edit:

I never suspend my system in any way sleep nor hibernate as that is already turned off by the time I’m done setting it up. I don’t suspend my laptop either.

If anyone has any ideas I could try, please let me know. I really want to give Manjaro a fair shake here as I’ve heard good things about it from the likes of Anthony from Linus Media Group and a few good things from Chris Titus Tech.

1 Like