Kernel 6.5 series - no power off or reset at end of shutdown/reboot process

Hello everyone,

following update to 6.5 series, my dell optiplex 7040 does not power off or reset anymore.
Using 6.4 series everything is working well.
I tried to add kernel parameters acpi=force and apm=power_off and the both, no change.

I will try 6.6 series, but I do not like to user Release Candidate kernel.

Any help will be appreciate.

Have you tried Kernel 6.1 (LTS) with and without those kernel parameters?
Is the system fully updated? Are you dual-booting?
Please post information about your system as outlined here:

short explanation why I request help :
6.1 kernel does not contain module I need for my wifi/bluetooth usb dongle
6.4 kernel contain module, but will be shortly EOL
6.5 is failing since first release 6.5.1
6.6 is failing too

I tried “shutdown -h” (with and without additional parameters, result is the same) in for :

  • 6.1 ok
  • 6.4 ok
  • 6.5 poweroff failed
  • 6.6 poweroff failed

System is fully up-to-date

There is dual boot, using rEFInd, with a windows 10 (dedicated drive)

here are my details (for 6.5):

  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: root=UUID=5d3d2c20-d929-4c1d-a7ab-cef2d428eb2e
    init=/lib/systemd/systemd rw
    resume=UUID=81cc9d6a-fc6c-4078-858d-53856b1a32b5 udev.log_priority=3
    nvidia-drm.modeset=1 initrd=\boot\initramfs-6.5-x86_64.img
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 7040 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0HD5W2 v: A01 serial: <superuser required> UEFI: Dell
    v: 1.24.0 date: 07/14/2022
  Info: model: Intel Core i5-6600 bits: 64 type: MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1562 high: 3851 min/max: 800/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 3851
    bogomips: 26411
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Vulnerable: No microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Micro-Star MSI
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 4 ports: active: none
    off: DP-1,HDMI-A-1 empty: none bus-ID: 01:00.0 chip-ID: 10de:1d01
    class-ID: 0300
  Device-2: Microsoft LifeCam HD-3000 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4.2.4:11
    chip-ID: 045e:0810 class-ID: 0102
  Display: wayland server: v: with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: 0
  Monitor-1: DP-1 model: Dell U2419H serial: <filter> built: 2021
    res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x296mm (20.75x11.65")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-1 model: Dell P2217 serial: <filter> built: 2017
    res: 1680x1050 dpi: 90 gamma: 1.2 size: 474x296mm (18.66x11.65")
    diag: 559mm (22") ratio: 16:10 modes: max: 1680x1050 min: 640x480
  API: EGL Message: No EGL data available.
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GT 1030/PCIe/SSE2
    memory: 1.95 GiB display-ID: :0.0
  API: Vulkan v: 1.3.264 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GT 1030 driver: nvidia v: 535.113.01
    device-ID: 10de:1d01 surfaces: xcb,xlib,wayland
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: NVIDIA GP108 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
    bus-ID: 01:00.1 chip-ID: 10de:0fb8 class-ID: 0403
  Device-3: Plantronics Blackwire C5220 headset (remote control and 3.5mm
    audio adapter) driver: plantronics,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4.2.2:7 chip-ID: 047f:c053
    class-ID: 0300 serial: <filter>
  Device-4: GN Netcom Jabra SPEAK 510 driver: jabra,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4.2.3:9
    chip-ID: 0b0e:0420 class-ID: 0300 serial: <filter>
  Device-5: Microsoft LifeCam HD-3000 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4.2.4:11
    chip-ID: 045e:0810 class-ID: 0102
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.80 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: bridge1 state: down mac: <filter>
  IF-ID-2: bridge2 state: down mac: <filter>
  IF-ID-3: virbr0 state: down mac: <filter>
  IF-ID-4: wg0 state: unknown speed: N/A duplex: N/A mac: N/A
  IF-ID-5: wlp0s20f0u5i2 state: down mac: <filter>
  Device-1: Realtek 802.11ac+Bluetooth 5.0 Adapter driver: btusb,rtw_8822bu
    type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3
    chip-ID: 0bda:b82c class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c0104
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020
    bus-ID: 00:17.0 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 1.38 TiB used: 402.41 GiB (28.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: P3-512 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 810a scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MK5065GSXF
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 8B scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WDS500G2B0B-00YS70 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 40WD
    scheme: GPT
  ID-1: / raw-size: 460 GiB size: 451.71 GiB (98.20%) used: 276.2 GiB (61.1%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 250 MiB size: 249.7 MiB (99.89%)
    used: 57.2 MiB (22.9%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16.94 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 41.0 C pch: 58.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 242 Uptime: 22m wakeups: 0 Memory: total: 16 GiB
  available: 15.42 GiB used: 3.2 GiB (20.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 2058 pm: pacman pkgs: 2047 libs: 534
  tools: gnome-software,pamac,yay pm: flatpak pkgs: 8 pm: snap pkgs: 3
  Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.30

Same issue here with similar maschine. No kernel above 6.4 works for me.

there is a thread on archlinux and reddit.

it seems issue occurs only on Dell Optiplex …


Perhaps the solution solution :slight_smile:

commit 0c1773bf8f386a8e34ce1da6d2c2923aa06299e1
Author: Linus Torvalds
Date: Sun Oct 15 12:02:02 2023 -0700

same for kernel 6.6, revertion correct the issue.

subject closed !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.