Kernel 6.5 doesn't work with AMD A9 APU

Try brightness keys first.
If it doesn’t help: boot into a working kernel and then read the journal.

1 Like

ok, will try

brightness key didn’t help

i attached journalctl output from booting with kernel 6.5

i didn’t find the root cause, there is no red text at the end of the journal

here is screenshot of mkinitcpio.conf

have tried adding =“amdgpu” and sudo mkinitcpio -P

then restart with kernel 6.5, but result is the same, sorry

thank you for the advice, anyway

Please do not post screenshots of text. Use copy+paste and proper formatting:


hi,actually i have saved the output of command :

journalctl -b -1

as txt file, i used journalctl -b -1 > [filename].txt
but it contains > 1000 lines

i have tried to send the txt file to this form, but failed
is there better way to communicate the content of this file?

journalctl --boot=-1 | curl -F'file=@-'

It will print a link when upload is successful.

More here: [HowTo] use public command-line pastebin services without installing anything!


ok, will try

here are the journals (i also sent booting in 6.4 & 6.1LTS for comparison)

boot kernel 6.5
(seems problem with org.kde.Ksplash?)

boot kernel 6.4

boot kernel 6.1LTS

i tried again, but get different journal (confused)

My take: Choose stability over any perceived performance boost.

Use the LTS (long-term support) kernel (6.1), and enjoy life.

i know that, but curiosity is not a sin, right?

Not that I’m aware of.
…but then, there is that old saying “curiosity killed the … fluffy … cat”, or something like that. Cheers.

haha, don’t worry, the cat is fine

inxi -Fazy
1 Like

hello, please check link below :

@fluffy_bunny At least, when I look at all journals, then it related to KDE Plasma alone, not Kernel 6.5 in general and not the gpu module. There was probably a change in the gpu module and KDE needs to adapt it.

Look what happens after “Finished Splash screen shown during boot.

Anyhow… it is something KDE Developer should look into. Debugging would be needed.

Maybe try X11 instead of Wayland.

1 Like

“… related to KDE …” >> could be, makes sense

have tried X11, & it didn’t help

hello, i think the culprit has been found, suspect is display setting, especially the scale (if set < 100%)
see screenshot below :

the display hardware resolution is 1366x768, but on the display setting, i set the resolution = 1280x720 and scale = 80% (i need to do this because some apps are misbehave in 1366x768, needs higher resolution to run properly)

if i set the display as above, & restart the laptop in kernel 6.5, the laptop goes black screen after entering login password

also another situation, if the display setting is as above, & i left the laptop idle for couple minutes, the display swiches off, then it goes black screen also, can’t be revived (in kernel 6.5)

those 2 problems don’t occurr in kernel 6.4, even with resolution = 1280x780 & scale = 80%

for temporary solution, i set the resolution = 1366x768 & scale = 100%, if i want to use kernel 6.5 (with some apps become mis-behave)

then, where does the issue come from? linux-kernel / manjaro / KDE?