Kernel 6.5 doesn't work with AMD A9 APU

haha, don’t worry, the cat is fine

inxi -Fazy
1 Like

hello, please check link below :

@fluffy_bunny At least, when I look at all journals, then it related to KDE Plasma alone, not Kernel 6.5 in general and not the gpu module. There was probably a change in the gpu module and KDE needs to adapt it.

Look what happens after “Finished Splash screen shown during boot.

Anyhow… it is something KDE Developer should look into. Debugging would be needed.

Maybe try X11 instead of Wayland.

1 Like

“… related to KDE …” >> could be, makes sense

have tried X11, & it didn’t help

hello, i think the culprit has been found, suspect is display setting, especially the scale (if set < 100%)
see screenshot below :

the display hardware resolution is 1366x768, but on the display setting, i set the resolution = 1280x720 and scale = 80% (i need to do this because some apps are misbehave in 1366x768, needs higher resolution to run properly)

if i set the display as above, & restart the laptop in kernel 6.5, the laptop goes black screen after entering login password

also another situation, if the display setting is as above, & i left the laptop idle for couple minutes, the display swiches off, then it goes black screen also, can’t be revived (in kernel 6.5)

those 2 problems don’t occurr in kernel 6.4, even with resolution = 1280x780 & scale = 80%

for temporary solution, i set the resolution = 1366x768 & scale = 100%, if i want to use kernel 6.5 (with some apps become mis-behave)

then, where does the issue come from? linux-kernel / manjaro / KDE?

Selecting ‘Legacy applications (X11): Apply scaling themselves’ (leaving scaling at 100%) doesn’t change anything?

Out of interest, what are your Power Management settings?

hello, if scaling = 100%, there is no blackscreen issue, regardless whatever the X11 setting (apply scaling themselves or scaled by system)

i choose “scaled by system” because zoom (meetin app) crashes if i choose “scaling themselves”

here is power management settings :

OK. Then the Power Management settings have just become less interesting. :wink:

1 Like

i want to raise this case to KDE bugs, but what is the most proper case category? (kwin / ksplash / else?)

Can you not simply use the 6.4 kernel instead of 6.5?

I don’t think your issue should qualify as a bug in KDE.

Aside:- I’ve noticed a few forum comments about the 6.6 kernel solving various issues; ofcourse that’s yet to be released. If the display seems fine using the 6.4 kernel, just use that until the 6.6 kernel is released.

yes, i can use 6.4, i don’t mean i need quick solution, i can wait patiently

i just want guys / girls at KDE aware about this issue

1 Like

hello, i would like to update about this issue, the latest stable update fixes this

now, in kernel 6.6, the display scaling works! no black screen anymore, thank you very much

just i don’t know exactly which part of the update that solves the problem

here is screenshot of the display scaling (now works)

1 Like

Probably a combination of factors, but the 6.6 kernel would surely be among them (6.4 has now reached EOL, so, goodbye to all that). Plus KDE is constantly being updated in the mad rush to make ready for the Qt6 version in January/February.

I’m glad it’s worked out for you. :rabbit2: :slight_smile:

Do you have similar success now in both Wayland and X11?

hello, X11 is fine from beginning, because there is no menu to adjust the display scale in X11 (the menu exisits in wayland only), thus the scale is always 100% (in X11), and therefore no black screen

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.