KDE plasma bugs after each update [Stable Update] 2022-09-12

Even that could be optimistic. I recommend grabbing the PlasmaConfigSaver - it’s solved my last 2 problems (not 100%) without too much effort.

1 Like

I’ll take a look at that actually… :+1:

1 Like

I completely agree with this.

I know I’m not the most experienced Linux user, so I actually value people that has more knowledge and more experience’s opinion.

Why would I do that and not just go for it myself? Because I know we, humans are supposed to be better and smarter than an animal, that can’t, won’t learn from other animals lessons.

1 Like

…And, yet, we are…primates…apparently :speak_no_evil:



And more 5.25.5 goodness… :roll_eyes:

1 Like

The show goes on… :grin:

1 Like

I don’t see how these posts are proof of anything. I bet at least half (being generous here:P) of all posts are caused by inexperienced users doing something that they shouldn’t ie. use 1000 theming and other customizations, or not doing what they should ie. in your last example, he is still using 5.18 kernel.

By this same logic I can create a compilation of GRUB, pacman, pamac, calamares, et cetera “bugs” which will have 100x as many posts as this. :stuck_out_tongue:

And I’m not saying there aren’t any bugs, or that it’s always user’s fault. Merely that we can’t discern anything super useful from these posts. So instead of people crying and b**ching, they should rather spend that time trying to troubleshoot their system. How many of them tried creating a new user or clearing .config or .cache? How many of them tried uninstalling all the extra theming, widgets and whatnot?

I agree, it’s annoying, unnecessary work, but it is what it is. And it won’t solve everything for everyone (because some “bugs” are bugs :P) but it definitely will for some.

Also I see some people literally being afraid to update. If that’s the case, then you shouldn’t be using rolling distro at all. #yolo :smiley:


I just wanted to say that I find it interesting that this thread/conversation is allowed to continue when it’s not in the members hub where non-support topics are said to belong. Can someone answer me this: why does this topic get to remain open when other topics that are non-support get shut down and told by moderators their non-support topics are better suited for reddit or whatever? Thanks.

1 Like

Or maybe just cautious, because we learn from other people’s experiences, instead of having to experience them ourselves.

Y’know. Actually using the brain we’ve been given.



You are only seeing a small sample of people with problems. Everyone else with working system isn’t posting anything.

1 Like

And, as @winnie said earlier in the thread, neither is everyone with a problem:


I am only linking those posts here which I think are relevant. There are tons more posts/threads about problems with Plasma of which I think they are caused by something else, and those are posts/threads I will not link to here.

Well, I am using 5.4 LTS — remember those three letters? Besides, the kernel doesn’t have anything to do with the stability of Plasma.

This thread is about a very real problem with one of the official Manjaro releases — a problem that is all too gratuitously being shrugged off — and although there is a solution (for now), it’s not an officially supported one.

Furthermore, the #member-hub is not accessible to everyone. One has to be a TL2 or above to have access to it.

Still, your subtle hint at requesting that this thread be closed is noted, but perhaps you could be more aggressive in your attempt, in which case it is my duty to point out that you are free to flag the thread, or any post on it. Alternatively, if the existence of this thread offends you so much, then you can also always unsubscribe from it and/or add it to your mute/ignore list.

Meanwhile, the rest of us are looking for an actual solution that doesn’t require a partial upgrade scenario.


I’m aware of all that, and I find the topic interesting, hence the reason I didn’t flag or unsubscribe. I just wanted to point out the obvious double standard of allowing this non-support thread to remain open when other non-support topics get shut down by moderators.

It’s not a non-support thread. The problem is real and needs to be remedied, one way or the other.

Here’s another one, and it may provide us with a clue… :arrow_down:

I don’t think it’s their network driver. I think it’s a race condition, and if so, then this may also lie at the root of most of the other problems, because from my own experiences with 5.25.5, the problems appear to be timing-related.

A few weeks ago, @philm told me that he had had to apply three patches in order to get Plasma 5.24.6 to work with the previous release of the KDE Frameworks, and that seems odd to me, given that the split-up between the KDE Frameworks, Plasma Desktop and KDE Applications should guarantee that either of those three projects should allow for an upgrade without breaking anything — that’s why KDE split them up into separate projects.

In addition to that, I am also wondering whether Arch also had to apply those patches, and whether it is those patches that are causing the problems with 5.25.5. :thinking:


u may be right b/c i tried fedora and it was working fine …the wifi was working flawless. I didnt try arch based distro to see if the issue is similar but thanks for the info


Looks like I switched from cinnamon to a train wreck… :laughing:
I was happy about the upgrade to Plasma 5.25 'cause I use multiple monitors and 5.25 fixed some of the disaster. Of course a lot still remains.

Q: do I interpret this thread correctly that for the next month or two whatever I have in front of me is what there is, and then there will be an upgrade to 5.26 which will bring “new fun”, and sometime in 2023 I should expect a 6.0 upgrade with more “real fun”?

Folks, I have some good news. :wink: Thanks to the Upper Grandmaster of the Secret Order of the Manjaruminati, @philm, those of us who chose to skip the update from Plasma 5.24.6 to Plasma 5.25.5 now have the ability to install the updated Plasma 5.24.7 LTS. @philm was so kind as to build the packages on the GitHub server and to make them available here. :arrow_down:

So if you’ve skipped the upgrade from 5.24.6 to 5.25.5 but you want to upgrade to the newest 5.24.7 LTS, then here’s what you need to do… :arrow_down:

P.S.: Make sure you create a backup first!

First, get the file plasma-5.24.7-LTS.zip from the link above — you only need that one file.

Now, I have personally opted to create a local repository under /var/cache/pacman/, but you can use a directory in your $HOME if you like. Note that if you do put it under /var, then it’s best to become root first… :arrow_down:

su -

… or, for those of you who’ve disabled the root account, … :arrow_down:

sudo su -

Given that on my system here, I’ve put the new local repo under the /var hierarchy, I will be continuing this HowTo with the methodology as I have done things here — I’m sure you can adapt this to your own needs. :wink:


mkdir /var/cache/pacman/plasma-lts
cd /var/cache/pacman/plasma-lts
mv /home/your-username-here/Downloads/plasma-5.24.7-LTS.zip ./
unzip plasma-5.24.7-LTS.zip
repo-add plasma-lts.db.tar.xz *.zst
cp /etc/pacman.conf /etc/pacman.conf.bak
nano /etc/pacman.conf

At this point, you’re going to have to make sure that you first and foremost comment out the line for ignoring the plasma group… :arrow_down:

#IgnoreGrp = plasma

Next, look for the section where the repos are being defined, and add your own local repo between the [core] section and the [extra] section… :arrow_down:

Include = /etc/pacman.d/mirrorlist

[plasma-lts]                                # ← new section
Server=file:///var/cache/pacman/plasma-lts  # ← new section
SigLevel = Optional TrustAll                # ← new section

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Save the file — if you’re not familiar with nano, press Ctrl+O followed by Enter and then exit the editor with Ctrl+X.

Next, log out of Plasma completely — you have to be looking at the SDDM login screen — and switch to a tty with Ctrl+Alt+F2. Log in as yourself and issue the command to update your system… :arrow_down:

sudo pacman -Syu

After this step, it is not strictly necessary to reboot, but it might be a good idea nevertheless. :wink:

Once again, a big Thank You to @philm for making this possible. :wink:

:clap: :clap: :clap:


Would we still have to add the KDE-relevant packages to pacman’s ignore list?

1 Like

You lucky guys :grin:

1 Like